Contents

Release Notes for ImageJ 1.45m vii
Noteworthy viii
Macro Listings ix
Guide Conventions x
I Getting Started
1 What is ImageJ? 1
2 Installing and Maintaining ImageJ 2
2.1 ImageJ Distributions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
2.2 Software Packages Built on Top of ImageJ . . . . . . . . . . . . . . . . . . . . 3
2.3 ImageJ2 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
3 Getting Help 4
3.1 Help on Image Analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
3.2 Help on ImageJ . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
II Working with ImageJ
4 Using Keyboard Shortcuts 8
5 Finding Commands 9
6 Undo and Redo 9
7 Image Types and Formats 10
8 Stacks, Virtual Stacks and Hyperstacks 11
9 Color Images 13
10 Selections 17
11 Settings and Preferences 19
III Extending ImageJ
12 Macros 20
13 Scripts 21
14 Plugins 21
15 Scripting in Other Languages 22
16 Running ImageJ From the Command Line 23
IV ImageJ User Interface
17 ImageJ Interoperability 24
18 Tools 4
18.1 Area Selection Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
18.2 Line Selection Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
18.3 Arrow Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
18.4 Angle Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
18.5 Point Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
18.6 Multi-point Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
18.7 Wand Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
18.8 Text Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
18.9 Magnifying Glass . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
18.10 Scrolling Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
18.11 Color Picker . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
18.12 Toolset Switcher . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
18.13 Macro Tools . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
19 Contextual Menu 34
20 Results Table 35
21 ImageJ Editor 36
22 Log Window 38
V Menu Commands
23 File> 40
23.1 New> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
23.2 Open... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
23.3 Open Next [O] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
23.4 Open Samples> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
23.5 Open Recent> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
23.6 Import> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
23.7 Close [w] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
23.8 Close All . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
23.9 Save [s] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
23.10 Save As> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
23.11 Revert [r] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
23.12 Page Setup... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
23.13 Print... [p] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
23.14 Quit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
24 Edit> 51
24.1 Undo [z] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
24.2 Cut [x] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
24.3 Copy [c] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
24.4 Copy to System . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
24.5 Paste [v] . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Summarized Release Notes for ImageJ 1.45m

<table>
<thead>
<tr>
<th>Issue</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>Undoable Edit Undo [z]</td>
</tr>
<tr>
<td>10</td>
<td>ImageJ can now open ZIP-compressed TIFFs</td>
</tr>
<tr>
<td>21</td>
<td>New macro functions: drawString(&quot;text&quot;, x, y, background), IJ.pad(), Overlay.setPosition(), roiManager(&quot;select&quot;, indexes), Stack.getFrameInterval(), Stack.getUnits() and Stack.setFrameInterval()</td>
</tr>
<tr>
<td>27</td>
<td>Improved Rounded Rectangular Selection Tool</td>
</tr>
<tr>
<td>29</td>
<td>Improved Arrow Tool</td>
</tr>
<tr>
<td>45</td>
<td>File&gt;Import&gt;Stack From List accepts URLs</td>
</tr>
<tr>
<td>55</td>
<td>Improved Edit&gt;Selection&gt;Merge Band...</td>
</tr>
<tr>
<td>57</td>
<td>New command: Edit&gt;Selection&gt;Area to Line</td>
</tr>
<tr>
<td>61</td>
<td>Multiple undo buffers</td>
</tr>
<tr>
<td>62</td>
<td>Improved handling of DICOM images</td>
</tr>
<tr>
<td>69</td>
<td>Auto-threshold based on stack histograms</td>
</tr>
<tr>
<td>73</td>
<td>Improved Image&gt;Color&gt;Merge Channels...</td>
</tr>
<tr>
<td>83</td>
<td>Improved Image&gt;Stacks&gt;Tools&gt;Make Substack...</td>
</tr>
<tr>
<td>83</td>
<td>New command: Image&gt;Stacks&gt;Tools&gt;Remove Slice Labels</td>
</tr>
<tr>
<td>88</td>
<td>Improved zooming commands</td>
</tr>
<tr>
<td>89</td>
<td>Improved handling of image selections (ImageROIs)</td>
</tr>
<tr>
<td>97</td>
<td>New command: Process&gt;Noise&gt;Remove NaNs...</td>
</tr>
<tr>
<td>105</td>
<td>Multithreaded Process&gt;Math&gt;Macro...</td>
</tr>
<tr>
<td>109</td>
<td>Multithreaded Process&gt;Filters...</td>
</tr>
<tr>
<td>110</td>
<td>Reduced memory footprint when running Process&gt;Filters... on non-float images</td>
</tr>
<tr>
<td>112</td>
<td>Added more macro snippets to Process&gt;Batch&gt;Macro</td>
</tr>
<tr>
<td>123</td>
<td>More accurate calculation of Feret’s diameter</td>
</tr>
<tr>
<td>124</td>
<td>Measured ROIs can be automatically added to the image overlay</td>
</tr>
<tr>
<td>133</td>
<td>Improved handling of ROIs in stacks and hyperstacks by the ROI Manager</td>
</tr>
<tr>
<td>135</td>
<td>New command: ROI Manager’s Multi Plot</td>
</tr>
<tr>
<td>136</td>
<td>ROI Manager can now use ROI names as labels</td>
</tr>
<tr>
<td>136</td>
<td>Scale bars can now be added as overlays</td>
</tr>
<tr>
<td>141</td>
<td>Improved Plugins&gt;Utilities&gt;Search...</td>
</tr>
<tr>
<td>141</td>
<td>New command: Plugins&gt;Utilities&gt;Monitor Events...</td>
</tr>
<tr>
<td>142</td>
<td>Redesigned Plugins&gt;Utilities&gt;Monitor Memory...</td>
</tr>
</tbody>
</table>

This list is not extensive. Detailed release notes for version 1.45m are available on the ImageJ News web site: http://imagej.nih.gov/ij/notes.html.
Guide Formats

This guide is available in the following formats:


Conventions Used in this Guide

Throughout the guide, internal links are displayed in gray (e.g., Part IV ImageJ User Interface). Links to external URLs, such as the ImageJ website, [http://imagej.nih.gov/ij/](http://imagej.nih.gov/ij/), are displayed in dark blue.

ImageJ commands are typed in sans serif font with respective shortcut keys flanked by square brackets (e.g., ```Image>```). As explained in Using Keyboard Shortcuts this notation implies shift-modifiers (i.e., ```[D]``` means pressing the ```D``` key only the ```[D]``` key) and assumes that ```require control key for shortcuts in Edit>Options> Misc.``` is unchecked.

Useful tips and reminders are placed in ‘Noteworthy notes’ located with upper case roman numerals (e.g., I Frontmost Window and Windows Activation). The full list of these notes is available on page viii.

Filenames, directory names and file extensions are indicated in italic, e.g., the `/Application-s/ImageJ/macros/` folder.

Macros and code snippets are typed in monospaced font, e.g., ```resetMinAndMax()```.

Scripts and macros are numbered with arabic numerals included in parentheses (e.g., (1) Replace Red with Magenta.ijm (Using Image>Color Channels... on page 16) and typeset with the same syntax markup provided by the Fiji Script Editor. The full list of macro listings is available on page ix.

Selected highlights of version 1.45m are listed on page vii and flagged with colored marginal notes. These should be interpreted as:

- **NEW IN IJ 1.45m**
  A new feature implemented in ImageJ 1.45m.

- **IMPROVED IN IJ 1.45m**
  A routine that has been improved since previous versions. Typically, a faster or more precise algorithm, a command with better usability, or a task that has been extended to more image types.

- **CHANGED IN IJ 1.45m**
  A pre-existing command that has been renamed or moved to a different menu location in ImageJ 1.45m.

### Part I

#### Getting Started

This part provides basic information on ImageJ installation, troubleshooting and update strategies. It discusses Fiji and ImageJ2 as well as third-party software related to ImageJ. Being impossible to document all the capabilities of ImageJ without exploring technical aspects of image processing, external resources allowing willing readers to know more about digital signal processing are also provided.

1 What is ImageJ?

ImageJ is a public domain Java image processing and analysis program inspired by NIH Image for the Macintosh. It runs, either as an online applet or as a downloadable application, on any computer with a Java 1.5 or later virtual machine. Downloadable distributions are available for Windows, Mac OS X and Linux. It can display, edit, analyze, process and print 8-bit, 16-bit and 32-bit images. It can read many image formats including TIFF, GIF, JPEG, BMP, DICOM, FITS and ‘raw’. It supports ‘stacks’ (and hyperstacks), a series of images that share a single window. It is multithreaded, so time-consuming operations such as image file reading can be performed in parallel with other operations.

It can calculate area and pixel value statistics of user-defined selections. It can measure distances and angles. It can create density histograms and line profile plots. It supports standard image processing functions such as contrast manipulation, sharpening, smoothing, edge detection and median filtering.

It does geometric transformations such as scaling, rotation and flips. Image can be zoomed up to 32:1 and down to 1:32. All analysis and processing functions are available at any magnification factor. The program supports any number of windows (images) simultaneously, limited only by available memory.

Spatial calibration is available to provide real world dimensional measurements in units such as millimeters. Density or gray scale calibration is also available.

ImageJ was designed with an open architecture that provides extensibility via Java plugins. Custom acquisition, analysis and processing plugins can be developed using ImageJ’s built in editor and Java compiler. User-written plugins make it possible to solve almost any image processing or analysis problem.

Being public domain open source software, an ImageJ user has the four essential freedoms defined by the Richard Stallman in 1986: 1) The freedom to run the program, for any purpose; 2) The freedom to study how the program works, and change it to make it do what you wish; 3) The freedom to redistribute copies so you can help your neighbor; 4) The freedom to improve the program, and release your improvements to the public, so that the whole community benefits.

ImageJ is being developed on Mac OSX using its built in editor and Java compiler, plus the BBEEdit editor and the Ant build tool. The source code is freely available. The author, Wayne Rasband (wsr@nih.gov), is a Special Volunteer at the National Institute of Mental Health, Bethesda, Maryland, USA.

See also: History of ImageJ at [imagejdev.org](http://imagejdev.org)

---

1 A somehow outdated list of ImageJ’s features is available at [http://imagej.nih.gov/ij/features.html](http://imagej.nih.gov/ij/features.html)
## 2 Installing and Maintaining ImageJ


The downloaded package may not contain the latest bug fixes so it is recommended to upgrade ImageJ right after a first installation. Updating IJ consists only of running Help → Update ImageJ → Fiji, which will install the latest imagej.jar in the ImageJ folder (on Linux and Windows) or inside the ImageJ.app (on Mac OS X).

Help → Update ImageJ → Fiji can be used to upgrade (or downgrade) the imagej.jar file to release updates or daily builds. Release updates are announced frequently and are labelled alphabetically (e.g., v.1.43m). Typically, these releases contain several new features and bug fixes, described in detail on the ImageJ News page. Daily builds, on the other hand, are labelled with numeric sub-indexes (e.g., v.1.43m4) and are released without documentation. Nevertheless, if available, release notes for daily builds can be found at [http://imagej.nih.gov/ij/source/release-notes.html](http://imagej.nih.gov/ij/source/release-notes.html). When a release cycle ends (v.1.42 ended with 1.42q, v.1.43 with 1.43u, etc.) an installation package is created, downloadable from [http://imagej.nih.gov/ij/download.html](http://imagej.nih.gov/ij/download.html). Typically, this package is bundled with a small list of add-ons (Macros, Scripts and Plugins).

### See also:
- Luts, Macros and Tools Updater, a macro toolset that performs live-updating of macros listed on the ImageJ web site

#### 2.1 ImageJ Distributions

ImageJ alone is not that powerful: it's real strength is the vast repertoire of Plugins that extend ImageJ's functionality beyond its basic core. The many hundreds, probably thousands, freely available plugins from contributors around the world play a pivotal role in ImageJ's success [6].

Running Help → Update ImageJ → Fiji, however, will not update any of the plugins you may have installed.

ImageJ add-ons (Plugins, Scripts and Macros) are available from several sources (ImageJ's plugins page [Help → Plugins →], ImageJ Information and Documentation Portal and Fiji’s webpage, among others) making manual updates of a daunting task. This reason alone, makes it extremely convenient the use of ImageJ Distributions bundled with a pre-organized collection of add-ons.

Below is a list of the most relevant projects that address the seeming difficult task of organizing and maintaining ImageJ beyond its basics. If you are a life scientist and have doubts about which distribution to choose you should opt for Fiji. It is heavily maintained, offers an automatic updater, improved scripting capabilities and ships with powerful plugins. More specialized adaptations of ImageJ are discussed in Software Packages Built on Top of ImageJ.

### Fiji

**Fiji (Fiji Is Just ImageJ – Batteries included)** is a distribution of ImageJ together with Java, Java 3D and several plugins organized into a coherent menu structure. Citing its developers,

> “Fiji compares to ImageJ as Ubuntu compares to Linux”. The main focus of Fiji is to assist research in life sciences, targeting image registration, stitching, segmentation, feature extraction and 3D visualization, among others. It also supports many scripting languages (BeanScript, Clojure, Jython, Python, Ruby, see Scripting in Other Languages). Importantly, Fiji ships with a convenient updater that knows whether your files are up-to-date, obsolete or locally modified. Comprehensive documentation is available for most of its plugins. The Fiji project was presented publicly for the first time at the ImageJ User and Developer Conference in November 2008.

#### MBF ImageJ

The MBF ImageJ bundle or ImageJ for Microscopy (formerly WCIF-ImageJ) features a collection of plugins and macros, collated and organized by Tony Collins at the MacBiophotonics facility, McMaster University. It is accompanied by a comprehensive manual describing how to use the bundle with light microscopy image data. It is a great resource for microscopists but is not maintained actively, lagging behind the development of core ImageJ.

Note that you can add plugins from MBF ImageJ to Fiji, combining the best of both programs. Actually, you can use multiple ImageJ distributions simultaneously, assemble your own ImageJ bundle by gathering the plugins that best serve your needs (probably, someone else at your institution already started one?) or create symbolic links to share plugins between different installations.

### See also:
- Description of all ImageJ related projects at ImageDev

#### 2.2 Software Packages Built on Top of ImageJ

**µManager** Micro-Manager is a software package for control of automated microscopes. It lets you execute common microscope image acquisition strategies such as time-lapses, multi-channel imaging, z-stacks, and combinations thereof. µManager works with microscopes from all four major manufacturers, most scientific-grade cameras and many peripherals used in microscopy imaging.

**TrakEM2** TrakEM2 is a program for morphological data mining, three-dimensional modeling and image stitching, registration, editing and annotation. TrakEM2 is distributed with Fiji and capable of:

- **3D modeling** Objects in 3D, defined by sequences of contours, or profiles, from which a skin, or mesh, can be constructed, and visualized in 3D.
- **Relational modeling** The extraction of the map that describes links between objects. For example, which neuron contacts which other neurons through how many and which synapses.

**ObjectCT** ObjectCT, the successor object-image, of supports graphical vector objects that non-destructively mark images on a transparent layer. Vector objects can be placed manually or by macro commands, and composite objects can encapsulate different color-coded marker structures in order to bundle features that belong together. ObjectCT provides back-and-forth navigation between results and images. The results table supports statistics, sorting, color coding, qualifying and macro access.

**MRI–CIA** MRI Cell Image Analyzer, developed by the Montpellier RIO Imaging facility (CNRS), is a rapid image analysis application development framework, adding visual...
scripting interface to ImageJ’s capabilities. It can create batch applications as well as interactive applications. The applications include the topics “DNA combing”, “quantification of stained proteins in cells”, “comparison of intensity ratios between nuclei and cytoplasm” and “counting nuclei stained in different channels”.

**SalsaJ**
SalsaJ is a student-friendly software developed specifically for the EU-HOU project. It is dedicated to image handling and analysis of astronomical images in the classroom. SalsaJ has been translated into several languages.

**Bio7**
Bio7 is an integrated development environment for ecological modeling with a main focus on individual based modeling and spatially explicit models. Bio7 features: Statistical analysis (using R); Spatial statistics; Fast communication between R and Java; BeanShell and Groovy support; Sensitivity analysis with an embedded flowchart editor and creation of 3D OpenGL (Jogl) models (see also RImageJ in ImageJ Interoperability).

**See also:** BioImageXD, Endrov, Image SXM and VisBio

### 2.3 ImageJ2

ImageJDev is a federally funded, multi-institution project dedicated to the development of the next-generation version of ImageJ: “ImageJ2”. ImageJ2 will be a complete rewrite of ImageJ, that will include the current, stable version ImageJ (“ImageJ1”) with a compatibility layer so that old-style plugins and macros can run the same as they currently do in ImageJ1. Below is a summary of the ImageJDev project aims:

- To create the next generation version of ImageJ and improve its core architecture based on the needs of the community.
- To ensure ImageJ remains useful and relevant to the broadest possible community, maintaining backwards compatibility with the current ImageJ as close to 100% as possible.
- Expand functionality by interfacing ImageJ with existing open-source programs.
- To lead ImageJ development with a clear vision, avoiding duplication of efforts.
- To provide a central online resource for ImageJ: program downloads, a plugin repository, developer resources and more.

Right now ImageJ remains a highly experimental application but a finalized released is expected by the end of 2011. Be sure to follow the project news and the ImageDev blog for further developments.

### 3 Getting Help

#### 3.1 Help on ImageJ Analysis

Below is a list of online resources (in no particular order) related to image processing and scientific image analysis, complementing the list of external resources on the IJ web site.

### Ethics in Scientific Image Processing

- **Online learning Tool for Research Integrity and Image Processing**
  This website, created by the Office of Research Integrity, explains what is appropriate in image processing and what is not.
- **Digital Imaging: Ethics (at the Cellular Imaging Facilay Core, SEHSC)**
  This website, compiled by Douglas Cromey at the University of Alabama – Birmingham, discusses thoroughly the topic of digital imaging ethics. It is recommended for all scientists. The website contains links to several external resources, including:

### Scientific Image Processing

- **What you need to know about scientific image processing**
  Simple and clear, this Fiji webpage explains basic aspects of scientific image processing.
- **imagingbook.com**
  Web site of Digital Image Processing: An Algorithmic Introduction using Java by Wilhelm Burger and Mark Burge [51]. This technical book provides a modern, self-contained, introduction to digital image processing techniques. Numerous complete Java implementations are provided, all of which work within ImageJ.
- **Hypermedia Image Processing Reference (HIPR2)**
  Developed at the Department of Artificial Intelligence in the University of Edinburgh, provides on-line reference and tutorial information on a wide range of image processing operations.
- **IFN wiki**
  The Imaging Facility Network (IFN) in Biopolis Dresden provides access to advanced microscopy systems and image processing. Its wiki hosts high quality teaching material and useful links to external resources.
- **stereology.info**
  Stereology Information for the Biological Sciences, designed to introduce both basic and advanced concepts in the field of stereology.

**See also:** ImageJ Related Publications on page 155

#### 3.2 Help on ImageJ

Below is a list of the ImageJ help resources that complement this guide (see Guide Formats). Specific documentation on advanced uses of ImageJ (macro programming, plugin development, etc.) is discussed in Extending ImageJ.

1. The ImageJ online documentation pages
   Can be accessed via the Help>Documentation... command.
2. The Fiji webpage:
   [http://fiji.sc/](http://fiji.sc/)
3. The ImageJ Information and Documentation Portal (ImageJ wiki):
   http://imagejdocu.tudor.lu/doku.php

4. Video tutorials on the ImageJ Documentation Portal and the Fiji YouTube channel:

5. The ImageJ for Microscopy manual
   http://www.macbiophotonics.ca/imagej/

6. Several online documents, most of them listed at:

7. Mailing lists:
   (a) ImageJ — http://imagej.nih.gov/ij/list.html
       General user and developer discussion about ImageJ. Can be accessed via the Help ⊿ Mailing List… command. This list is also mirrored at Nabble and Gmane. You may find it easier to search and browse the list archives on these mirrors. Specially useful are the RSS feeds and the frames and threads view provided by Gmane.
   (b) Fiji users — http://groups.google.com/group/fiji-users
       For user discussion specific to Fiji (rather than core ImageJ).
   (c) IJ Macro Support Group — http://listes.inra.fr/wws/info/imagejmacro
       The ImageJ macro support group connects a network of ImageJ users who are specifically interested in improving their skills in writing macros and plugins for ImageJ. The membership base includes experienced programmers, and new users who are interested in learning to write their very first macros.
   (d) Fiji developers — http://groups.google.com/group/fiji-devel
       For developer discussion specific to Fiji.
   (e) ImageJX — http://groups.google.com/group/imagejx
       Highly technical developer discussion about ImageJ future directions.
   (f) ImageJDev — http://imagejdev.org/mailman/listinfo/imagej-devel
       For communication and coordination of the ImageJDev project.
   (g) Dedicated mailing lists for ImageJ related projects

Using Mailing-lists

If you are having problems with ImageJ, you should inquiry about them in the appropriated list. The ImageJ mailing list is an unmoderated forum subscribed by a knowledgeable worldwide user community with ≈2000 advanced users and developers. To have your questions promptly answered you should consider the following:

1. Read the documentation files (described earlier in this section) before posting. Because there will always be a natural lag between the implementation of key features and their documentation it may be wise to check briefly the ImageJ news website (Help ⊿ ImageJ News…).

2. Look up the mailing list archives (Help ⊿ Mailing List…). Most of your questions may already been answered.

3. If you think you are facing a bug try to upgrade to the latest version of ImageJ (Help ⊿ Update ImageJ…). You should also check if you are running the latest version of the Java Virtual Machine for your operating system. Detailed instructions on how to submit a bug report are found at http://imagej.nih.gov/ij/docs/faq.html#bug.

4. Remember that in most cases you can find answers within your own ImageJ installation without even connecting to the internet since the heuristics for finding commands or writing macros have been significantly improved in later versions (see Finding Commands and Extending ImageJ).

5. As with any other mailing list, you should always follow basic netiquette, namely:
   (a) Use descriptive subject lines – Re: Problem with ImageJ:Set Scale command is much more effective than a general Re: Problem.
   (b) Stay on topic – Do not post off-topic messages, unrelated to the message thread.
   (c) Be careful when sending attachments – Refrain from attaching large files. Use, e.g., a file hosting service instead.
   (d) Edit replies – You should include only the minimum content that is necessary to provide a logical flow from the question to the answer, i.e., quote only as much as absolutely necessary and relevant.
Part II

Working with ImageJ

This part introduces some basic aspects of ImageJ so that you can use the software more efficiently. It also introduces some important terms and concepts used throughout this guide. You may skip it if you already use the program efficiently and are familiar with terms such as Virtual Stacks, Hyperstacks, Pseudocolor Images, Color Composites or Composite Selections.

4 Using Keyboard Shortcuts

You’ll learn more and more shortcut keys as you use ImageJ, because (almost) all shortcuts are listed throughout ImageJ menus. Similarly, in this guide each command has its shortcut key listed on its name (flanked by square brackets). Please note that the notation for these key-bindings is case sensitive, i.e., shift-modifiers are not explicitly mentioned (a capital A means Shift–A) and assumes that ‘require control key for shortcuts in Edit>Options>Misc...’ is unchecked (i.e., except when using ImageJ Editor, you won’t have to hold down the Control key to use menu shortcuts). For example, the command ‘Edit> Invert [I]’ can be evoked by ‘cmd–I’ or ‘ctrl–I’ if ‘require control key for shortcuts’ is checked. The full list of ImageJ shortcuts (see Keyboard Shortcuts) can be retrieved at any time using the Plugins>Utilities> List Shortcuts... command.

There are three modifier keys in ImageJ:

Control (Command Key on Apple keyboards) Denoted by ‘Ctrl’ or ‘cmd’ in this document. Although a control key is typically present on Apple keyboards, on a Macintosh computer running ImageJ the Command key replaces the functionality of the control key of other operating systems. For sake of simplification, ‘Ctrl’ will always refer to both throughout this guide.

Shift Denoted by ‘Shift’ or ‘shift’ in this document.

Alt Denoted by ‘Alt’ or ‘alt’ in this document. This is also the ‘Option’ or ‘Meta’ key on many keyboards.

See also: KeyboardShortcuts.txt macro, demonstrating how assign shortcuts to custom macros.

1 Frontmost Window and Windows Activation

In ImageJ, all operations are performed on the active (frontmost) image (which has its title bar highlighted). If a window is already open it will activate when its opening command is evoked (e.g., if the B&C window is already opened, pressing its keyboard shortcut [alt–F1] will activate it. In addition, pressing [f] on any image will bring the ImageJ window to the foreground.

5 Finding Commands

Navigating through the extensive list of ImageJ commands, macros and plugins may be quite cumbersome. Through its built-in Command Finder / Launcher [40], ImageJ offers an expedite alternative that allows you to retrieve commands extremely fast: Plugins>Utilities>Find Commands... [I].

In addition, ImageJ features a find function that locates macros, scripts and plugins source (.java) files on your computer: the Plugins>Utilities>Search... command. Because most of IJ source files contain circumsancess comments, you can use this utility to retrieve files related not only to a image processing routine (e.g., background or co-localization) but also to a practical context such as radiogram, cell or histology. Indeed, ImageJ source files contain detailed annotations useful to both developers and regular users that want to know more about ImageJ routines and algorithms.

Search... and Find Commands... [I] are described in detail in Plugins>Utilities>...

See also: Control Panel... [I], Keyboard Shortcuts and SourceCodeRetriever, a macro that searches for a menu entry and tries to retrieve the java source file of the respective plugin.

6 Undo and Redo

Probably the first thing you will notice is that ImageJ does not have a large undo/redo buffer. Undo (Edit>Undo [z]) is currently limited to the most recent image editing/filtering operation. With time you will appreciate that this is necessary to minimize memory overhead. Nevertheless, with IJ 1.45 and later, Undo [z] is, in most cases, undoable and can be applied to multiple images if ‘keep multiple undo buffers is checked in Edit>Options>Memory & Threads...’.

If you cannot recover from a mistake, you can always use File>Revert [r] to reset the image lo its last saved state. For selections, Edit>Selection>Restore Selection [E] can be used to recover any misdealt selection.
In ImageJ the equivalent to 'Redo' is the Process > Repeat Command [R], that re-runs the previous used command (skipping Edit > Undo [a] and File > Open... commands).

**SEE ALSO:** Plugins > Utilities > Reset..., Multi Undo plugin

### 7 Image Types and Formats

Digital Images are two-dimensional grids of pixel intensities values with the width and height of the image being defined by the number of pixels in x (rows) and y (columns) direction. Thus, pixels (picture elements) are the smallest single components of images, holding numeric values – pixel intensities – that range between black and white. The characteristics of this range, i.e., the number of unique intensity (brightness) values that can exist in the image is defined as the bit-depth of the image and specifies the level of precision in which intensities are coded, e.g.: A 2-bit image has $2^2 = 4$ tones: 00 (black), 01 (gray), 10 (gray), and 11 (white). A 4-bit image has $2^4 = 16$ tones ranging from 0000 (0) to 1111 (16). In terms of bits per pixel (bpp), the most frequent types of images that ImageJ deals with (ImageJ2 will support many more types of image data) are:

<table>
<thead>
<tr>
<th>Bit Depth</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>8-bit</td>
<td>Images that can display 256 ($2^8$) gray levels (integers only).</td>
</tr>
<tr>
<td>16-bit</td>
<td>Images that can display 65,536 ($2^{16}$) gray levels (integers only).</td>
</tr>
<tr>
<td>32-bit</td>
<td>Images that can display 4,294,967,296 ($2^{32}$) gray levels (integers and fractional values). 32-bit images pixels can have ANY intensity value (i.e., any real number) including NaN (Not a Number). In computing these are called floating point images.</td>
</tr>
</tbody>
</table>

**RGB Color** Images that can display 256 values in the Red, Green and Blue channel. These are $2^{24}$ ($2^{8} \times 3$) images. RGB color images can also be 32-bit color images ($2^{24}$ bit color images with additional eight bits coding alpha blending values, i.e., transparency).

**SEE ALSO:** Color Images

### Native Formats

Natively (i.e. without the need of third-party plugins) ImageJ opens the following formats:

- TIFF, GIF, JPEG, PNG, Dicom, BMP, PGM and FITS. Many more formats are supported with the aid of plugins. These are discussed in Non-native Formats.

**TIFF** (Tagged Image File Format) is the ‘default’ format of ImageJ (cf. File > Save [s]). Images can be 1-bit, 8-bit, 16-bit (unsigned1), 32-bit (real) or RGB color. TIFF files with multiple images of the same type and size open as Stacks or Hyperstacks. ImageJ opens lossless compressed TIFF files (see II Image Types: Lossy Compression and Metadata) by the LZW, PackBits and ZIP (Deflate/Inflate) [2] compression schemes. In addition, TIFF files can be opened and saved as ZIP archives. TIFF tags and information needed to import the file (number of images, offset to first images, gap between images) are printed to the Log Window when ImageJ is running in Debug Mode (Edit > Options > Misc...), see Settings and Preferences).

1A numeric variable is signed if it can represent both positive and negative numbers, and unsigned if it can only represent positive numbers.

### 8 Stacks, Virtual Stacks and Hyperstacks

**Stacks**

ImageJ can display multiple spatially or temporally related images in a single window. These image sets are called stacks. The images that make up a stack are called slices. In stacks, a

**DICOM** (Digital Imaging and Communications in Medicine) is a standard popular in the medical imaging community. Support in ImageJ is limited to uncompressed DICOM files. DICOM files containing multiple images open as Stacks. Use File > Show Info... [i] to display the DICOM header information. A DICOM sequence can be opened using File > Import > Image Sequence... or by dragging and dropping the folder on the ‘ImageJ’ window. Imported sequences are sorted by image number instead of filename and the tags are preserved when DICOM images are saved in TIFF format. ImageJ supports custom DICOM dictionaries, such as the one at http://imagej.nih.gov/ij/download/docs/DICOM_Dictionary.txt. More information can be found here.

**FITS** (Flexible Image Transport System) is a format adopted by the astronomical community for data interchange and archival storage. Use File > Show Info... [i] to display the FITS header. More information here.

**PGM** (Portable GrayMap), PBM (Portable BitMap) and PPM (Portable Pixmap) are simple image formats that can open as ASCII header.

**AVI** (Audio Video Interleave) is a container format which can contain data encoded in many different ways. ImageJ only supports uncompressed AVIs, various YUV 4:2:2 compressed formats, and PNG or JPEG-encoded individual frames. Note that most MJPEG (motion-JPEG) formats are not read correctly. Attempts to open AVIs in other formats will fail.

**SEE ALSO:** Non-native Formats, II Image Types: Lossy Compression and Metadata, X Warning on JPEG compression

### Non-native Formats

When opening a file, ImageJ first checks whether it can natively handle the format. If ImageJ does not recognize the type of file it calls for the appropriate reader plugin using HandleExtraFileTypes, a plugin bundled with ImageJ. If that fails, it tries to open the file using the LOCI Bio-Formats library (if present), a remarkable plugin that supports around eighty of the most common file formats. The ImageJ Documentation Portal maintains a list of file formats that are supported natively (i.e. without the need of third-party plugins) ImageJ opens the following formats:

- TIFF, GIF, JPEG, PNG, Dicom, BMP, PGM and FITS. Many more formats are supported with the aid of plugins. These are discussed in Non-native Formats.

**SEE ALSO:** Non-native Formats, II Image Types: Lossy Compression and Metadata, X Warning on JPEG compression, Acquisition plugins, Input/Output plugins
Stacks and Hyperstacks in ImageJ: File>Open Samples>Mitosis (26MB, 5D stack). Hyperstacks dimensionality can be reduced using the Image>Hyperstacks>Reduce Dimensionality... Image>Stacks>Z Project... or Image>Hyperstacks>Channels Tool... [Z] commands. The ‘(V)’ on the window titles denotes a virtual image (see Virtual Stacks).

Virtual Stacks

Virtual stacks are disk resident (as opposed to RAM resident) and are the only way to load image sequences that do not fit in RAM. There are several things to keep in mind when working with virtual stacks:

- Virtual stacks are read-only, so changes made to the pixel data are not saved when you switch to a different slice. You can work around this by using macros (e.g., Process Virtual Stack) or the Process>Batch>Virtual Stack... command implemented in ImageJ 1.43.
- You can easily run out of memory using commands like Image>Crop [X] because any stack generated from commands that do not generate virtual stacks will be RAM resident.
- TIFF virtual stacks can usually be accessed faster than JPEG virtual stacks. A JPEG sequence can be converted to TIFF by opening the JPEG images as a virtual stack and using File>Save As>Image Sequence... to save in TIFF format.

ImageJ appends a ‘(V)’ to the window title of virtual stacks and hyperstacks (see Hyperstacks).

Stack Manipulations on Fiji website, Image5D

Hyperstacks

Hyperstacks are multidimensional images, extending image stacks to four (4D) or five (5D) dimensions: x (width), y (height), z (slices), c (channels or wavelengths) and t (time frames). Hyperstacks are displayed in a window with three labelled scrollbars (see Stacks and Hyperstacks).

SEE ALSO: LOCI Bio-Formats and RegisterVirtualStackSlices plugins, Process Virtual Stack and VirtualStackFromList macros

9 Color Images

ImageJ deals with color mainly in three ways: pseudocolor images, RGB images, RGB/HSB stacks, and composite images.

SEE ALSO: Stack Manipulations on Fiji website, Image5D

1This section is partially extracted from the MBF ImageJ online manual at http://www.macbiophotonics.ca/imagej/colour_image_processi.htm.
Pseudocolor Images

A pseudocolor (or indexed color) image is a single channel gray image (8, 16 or 32-bit) that has color assigned to it via a lookup table or LUT. A LUT is literally a predefined table of gray values with matching red, green and blue values so that shadows of gray are displayed as colorized pixels. Thus, differences in color in the pseudo-colored image reflect differences in intensity of the object rather than differences in color of the specimen that has been imaged.

8-bit indexed color images (such as GIFs) are a special case of pseudocolor images as their lookup table is stored in the file with the image. These images are limited to 256 colors (24-bit RGB images allow 16.7 million of colors, see Image Types and Formats) and concomitantly smaller file sizes. Reduction of true color values to a 256 color palette is performed by color quantization algorithms. ImageJ uses the Heckbert’s median-cut color quantization algorithm (see Image Type menu), which, in most cases, allows indexed color images to look nearly identical to their 24-bit originals.

See also: Image > Lookup Tables > submenu

True Color Images

As described in Image Types and Formats, true color images such as RGB images reflect genuine colors, i.e., the green in an RGB image reflects green color in the specimen. Color images are typically produced by color CCD cameras, in which color filter arrays (Bayer masks) are placed over the image sensor.

Color Spaces and Color Separation

Color spaces describe the gamut of colors that image-handling devices deal with. Because human vision is trichromatic, most color models represent colors by three values. Mathematically, these values (color components) form a three-dimensional space such as the RGB, HSB, CIE Lab or YUV color space.

Representation of an eight pixel color image in the RGB and HSB color spaces. The RGB color space maps the RGB color model to a cube with Red (R) values increasing along the x-axis, Green (G) along the y-axis and Blue (B) along the z-axis. In the HSB cylindrical coordinate system, the angle around the central vertical axis corresponds to Hue (H), the distance from the axis corresponds to Saturation (S), and the distance along the axis corresponds to Brightness (B). In both cases the origin holds the black color. The right panel shows the same image after brightness reduction, easily noted by the vertical displacement along the HSB cylinder. Images produced using Kai Uwe Barthel’s 3D Color Inspector plugin.

RGB (Red, Green, Blue) is the most commonly-used color space. However, other alternatives such as HSB (Hue, Saturation, Brightness) provide significant advantages when processing color information. In the HSB color space, Hue describes the attribute of pure color, and therefore distinguishes between colors. Saturation (sometimes called “purity” or “vibrancy”) characterizes the shade of color, i.e., how much white is added to the pure color. Brightness (also known as Value – HSV system) describes the overall brightness of the color. In terms of digital imaging processing, using the HSV system over the traditional RGB is often advantageous: e.g., since the brightness component of an HSB image corresponds to the grayscale version of that image, processing only the brightness channel in routines that require grayscale images is a significant computational gain.

In ImageJ, conversions between image types are performed using the Image > Type > submenu. Segmentation on the HSB, RGB, CIE Lab and YUV color spaces can be performed by the Image > Adjust > Color Threshold... command [17]. Segregation of color components (specialy useful for quantification of histochemical staining) is also possible using Gabriel Landini’s Colour Deconvolution plugin. In addition, several other plugins related to color processing can be obtained from the ImageJ website.

Conveying Color Information

People see color with significant variations. Indeed, the popular phrase “One picture is worth ten thousand words” may not apply to certain color images, specially those that do not follow the basic principles of Color Universal Design. Citing Masataka Okabe and Kei Ito:

Colorblind people can recognize a wide ranges of colors. But certain ranges of colors are hard to distinguish. The frequency of colorblindness is fairly high. One in 12 Caucasian (8%), one in 20 Asian (5%), and one in 25 African (4%) males are so-called ‘red–green’ colorblind.

There are always colorblind people among the audience and readers. There should be more than ten colorblind in a room with 250 people (assuming 50% male and 50% female).

 [...] There is a good chance that the paper you submit may go to colorblind reviewers. Supposing that your paper will be reviewed by three white males (which is not unlikely considering the current population in science), the probability that at least one of them is colorblind is whopping 22%!

One practical point defined by the Color Universal Design is the use of magenta in red–green overlays (see also [30]). Magenta is the equal mixture of red and blue. Colorblind people that have difficulties recognizing the red component can easily recognize the blue hue. The region of double positive becomes white, which is easily distinguishable for colorblind. In ImageJ this is easily accomplished using the ImageJ macro language (see IV Replacing Red with Magenta in RGB Images).

It is also possible to simulate color blindness using the Vischeck plugin, or, in Fiji, using the Image > Color > Simulate Color Blindness command.

---

2 This section is partially extracted from Masataka Okabe and Kei Ito, Color Universal Design (CUD) — How to make figures and presentations that are friendly to Colorblind people, http://jfly.iam.u-tokyo.ac.jp/color/, accessed 2009.01.15
The IJ User Guide — Booklet 13

Color Images

Red-green images and partial color blindness. Deuteranopia (second panel), protanopia (third panel) are the most common types of partial color blindness (red/green confusion). Tritanopia (blue/orange confusion, fourth panel) is quite rare. Replacing Red with Magenta in RGB Images (bottom row) is a simple way to compensate for color vision deficiencies.

IV REPLACING RED WITH MAGENTA IN RGB IMAGES

For two-channel images, magenta can be obtained by selecting the same source for both the red and the blue channels in the Image > Color > Merge Channels dialog.

RGB images can be converted to ‘MGB’ using Image > Color > Channels Tool... [2]. Alternatively, the Process > Image Calculator... command can be used to add the red channel to the blue channel.

Both these approaches can be automated using the ImageJ macro language as exemplified by Macros (1) and (2). Once saved in the ImageJ/plugins/ folder these macros are treated as regular ImageJ commands (see Macros).

In Fiji, as expected, the procedure is even more simple: one just needs to run Image > Color > Replace Red with Magenta. For even more convenience, Fiji provides an analogous command that replaces the system clipboard’s image with a magenta-green one.

1 /* This macro replaces red with magenta in RGB images using Process > Image Calculator... command. */
2 if (bitDepth != 24)
3 // Ignore non-RGB images
4 exit("This macro requires an RGB image");
5 setBatchMode(true);
6 title = getTitle();
7 // Enter ‘Batch’ mode
8 r = getTitle("(red)"), g = getTitle("(green)"), b = title "(blue)";
9 run("Split Channels");
10 imageCalculator("Add", b, r);
11 rename(title + " (MGB)");
12 setBatchMode(false);

Color Composites

In a composite image colors are handled through channels. The advantages with this type of image over plain RGB images are:

1. Each channel is kept separate from the others and can be turned on and off using the ‘Channels’ tool (Image > Color > Channels Tool... [2]). This feature allows, e.g., to perform measurements on a specific channel while visualizing multiple.
2. Channels can be 8, 16 or 32-bit and can be displayed with any lookup table
3. More than 3 channels can be merged or kept separate

10 Selections

Selections are typically created using the Toolbar Tools. Although ImageJ can display simultaneously several selections or regions of interest (ROIs), only one selection can be active at a time. Selections can be measured (Analyze > Measure... [m]), drawn (Edit > Draw [d]), filled (Edit > Fill [f]) or filtered (Process > Filters > submenu), in the case of area selections. In addition, since ImageJ 1.43 it is also possible to create non-destructive image overlays (Image > Overlay > submenu).

Selections can be initially outlined in one of the nine ImageJ default colors (Red, Green, Blue, Cyan, Yellow, Orange, Black and White). Once created, selections can be contoured or painted with any other color (cf. Edit > Selection > Properties... [g]). Selection Color can be changed in Edit > Options > Colors... or by double clicking on the Point Tool. It is highlighted in the center of the Point, Multi-point Tool (cf. The ImageJ window).

Three types of area selections In ImageJ. Notice the cursor changes: to an arrow when it is within the selection, to a cross-bar when outside the selection, to a hand when over a selection ‘handler’. Notice also the filled handler in the polygon selection and the absence of point handlers in Composite Selections.
Most of commands that can be useful in defining or drawing selections are available in the Edit ⊥ Selection ⊥ submenu. Listed below are the most frequent manipulations involving selections:

---

**Adjusting**

Area selections can be adjusted with the Brush Selection Tool. In addition, vertexes of polygon selections can be adjusted by Alt/Shift-clicking (cf. Polygon Selection Tool).

**Deleting**

Choose any of the selection tools and click outside the selection, or use Edit ⊥ Selection ⊥ Select None [A]. Use Edit ⊥ Selection ⊥ Restore Selection [E] to restore a selection back after having deleted it.

**Managing**

A selection can be transferred from one image window to another by activating the destination window and using Edit ⊥ Restore Selection [E]. Selections can be saved to disk using File ⊥ Save As ⊥ Selection... and restored using File ⊥ Open... Use the ROI Manager (Analyze ⊥ Tools ⊥ ROI Manager...) to work with multiple selections.

**Moving**

Selections can be moved by clicking and dragging as long as the cursor is within the selection and has changed to an ↳. The status bar displays the coordinates of the upper left corner of the selection (or the bounding rectangle for non-rectangular selections) as it is being moved. To move the contents of a selection, rather than the selection itself, Edit ⊥ Copy [c], Edit ⊥ Paste [v], and then click within the selection and drag.

**Nudging**

Selections can be ‘nudged’ one pixel at a time in any direction using the arrow keys. Note that the up and down keys zoom the image in and out in the absence of selections (see Arrow Keys).

**Resizing**

Rectangular and oval selections (see Area Area Selection Tools) can be resized by holding Alt while using the arrow keys.

---

**Composite Selections**

Composite selections are non-contiguous ROIs containing more than one cluster of pixels and/or ROIs containing internal holes. Composite ROIs are typically originated with the Brush Selection Tool but they can be defined with any other selection tool using key modifiers. The following modifier keys can be used to create composite selections:

- **SHIFT**
  - Drawing outside current selection while pressing Shift creates new content. To add a non-square rectangle or ellipse, the Shift key must be released after adding the selection.

- **ALT**
  - Drawing inside current selection while pressing Alt creates a hole removing content from ROI.

Note that some operations may not be performed properly on complex ROIs. In these cases, it may be useful to convert a composite ROI into a polygon using the Edit ⊥ Selection ⊥ Enlarge... command, see XIII Converting Composite Selections.

---

**Settings and Preferences**

ImageJ preferences are automatically saved in a preferences file, the IJ_prefs.txt text file. This file is stored in the ~/Library/Preferences/ folder on Mac OS X, in the ~/.imagej/ folder on Linux and in the ImageJ folder on Windows. Several macros and plugins also write parameters to this file. If the IJ_prefs.txt is erased, ImageJ creates a new one the next time it is opened, resetting all parameters to their default values.

Sometimes, it may be useful to override (or restore) certain settings that may have been changed during a working session. For example, the Limit to threshold option (Analyze ⊥ Set Measurements...) will affect most measurements performed on thresholded images. Thus, it may be wise to check the status of this parameter before each analysis, specially when working on multiple computers.

The setOption() macro function can be used to set this and several other ImageJ options (cf. Built-in Macro Functions — setOption()). Calling this function from the “AutoRun” macro in the StartupMacros.txt file ensures preferences are set each time ImageJ starts.

So, e.g., to make sure that:

1. TIFF tag values are displayed by ImageJ (Debug Mode in Edit ⊥ Options ⊥ Misc...)
2. Bicubic interpolation is preferred over bilinear (e.g., Edit ⊥ Selection ⊥ Straighten...)
3. The name of the measured image name is recorded in the first column of the Results Table (Display Label in Analyze ⊥ Set Measurements...)
4. Measurements are not restricted to thresholded pixels (Limit to Threshold in Analyze ⊥ Set Measurements...)
5. Binary images are processed assuming white objects on a black background (Black background in Process ⊥ Binary Options..., see XXI Interpreting Binary Images)
6. Background color is black and foreground color is white (Edit ⊥ Options ⊥ Colors...)

are set properly at startup, the following ‘AutoRun’ macro could be appended to the Startup-Macros.txt file:

```java
1   macro "AutoRun" {  
2       setOption("DebugMode", true);  
3       setOption("Bicubic", true);  
4       setOption("Display Label", true);  
5       setOption("Limit to Threshold", false);  
6       setOption("Black Background", true);  
7       setBackgroundColor(0,0,0);  
8       setForegroundColor(255,255,255);  
9       // run("Colors...", "foreground=white background=black");  
10   }
```

See also: FAQ’s on ImageJ Documentation Wiki
Part III
Extending ImageJ

ImageJ capabilities can be extended by loadable code modules in the form of macros, scripts or plugins. 300+ macros, 500+ plugins and 20+ scripts are available through the ImageJ web site. Below is a short description of these three type of ImageJ add-ons:

Macros The easiest way to execute a series of ImageJ commands. The ImageJ macro language – a Java-like language – contains a set of control structures, operators and built-in functions and can be used to call built-in commands and other macros. Macro code is stored in text files (.txt and .ijm extensions).

Plugins Much more powerful, flexible and faster than macros (most of ImageJ's built-in menu commands are actually plugins) but harder to write and debug. Plugins are written in the Java programming language (.java source files) and compiled to .class files.

Scripts ImageJ uses the Mozilla Rhino interpreter to run JavaScripts. Similarly to plugins, scripts have full access to all ImageJ and Java APIs but do not need to be compiled (scripts and macros run interpretively). On the other hand, scripts lack the simplicity of macro language and feel less integrated in ImageJ.

12 Macros

A macro is a simple program that automates a series of ImageJ commands. The easiest way to create a macro is to record a sequence of commands using the command recorder (Plugins>Macros>Record...).

A macro is saved as a text file (.txt or .ijm extension) and once installed executed by selecting the macro name in the Plugins>Macros submenu, by pressing a key or, in the case of Macro tools, by clicking on an icon in the ImageJ toolbar. In addition, any macro file placed in the ImageJ/plugins folder with an .ijm extension will be installed in the Plugins>menu like any other plugin (before version 1.41 only files with an underscore in the name would be listed).

There are more than 300 example macros, on the ImageJ Web site. To try one, open it in a browser window and drag it directly to the ImageJ Window or, copy it to the clipboard – Ctrl A – switch to ImageJ, and run File>New>System Clipboard [V] – CTRL-AL-F – pasting the macro into a new editor window (cf. ImageJ Editor). Run it using the editor's Macros>Run Macro command – CTRL-E. Most of the example macros are also available in the macros folder, inside the ImageJ folder.

Macro Programming

The ImageJ community has created excellent tutorials on macro programming. These resources are indispensable guides to the ImageJ macro language:

1. The ImageJ Macro Language — Programmer’s Reference Guide by Jérôme Mutterer and Wayne Rasband. This booklet compiles most of the documentation dispersed throughout the web related to ImageJ’s macro programming. It provides an up to date printable manual for the ImageJ macro language:

2. The Built-in Macro Functions webpage (Help>Macro Functions...), the indispensable guide to the built-in functions that can be called from the ImageJ macro language. It is thoroughly documented and constantly updated:

3. Tutorials on the Fiji webpage:

   http://imagejdocu.tudor.lu/

SEE ALSO: Scripts and Plugins

13 Scripts

ImageJ 1.41 added support for JavaScript scripting. ImageJ uses the Mozilla Rhino interpreter built into Java 1.6 for Linux and Windows to run JavaScript. Mac users, and users of earlier versions of Java, must download JavaScript.jar into the plugins folder. This JAR file is available at rsb.info.nih.gov/ij/download/tools/JavaScript.jar. It is also included with the Mac version of ImageJ 1.41 and later, in the ImageJ/plugins/tools folder.

Example JavaScript programs are available at rsb.info.nih.gov/ij/macros/js/. Since ImageJ 1.43 thread safe JavaScript code can be generated using the Recorder (Plugins>Macros>Record...). Scripts can be opened in the editor as any other macro (cf. Macros). Scripts with the extension .js can be run using the Macros>Run Macro command otherwise Macros>Evaluate JavaScript (Macro Run) must be used.

JavaScript Programming

Resources on ImageJ JavaScript scripting include:

1. The ImageJ web site, with growing documentation:

2. Tutorials on the Fiji webpage:
   http://fiji.sc/wiki/index.php/JavaScript_Scripting

14 Plugins

Plugins are a much more powerful concept than macros and scripts and most of ImageJ’s built-in menu commands are in fact implemented as plugins. Quoting Werner Bailey [87]:

Plugins are implemented as Java classes, which means that you can use all features of the Java language, access the full ImageJ API and use all standard and third-party Java APIs in a plugin. This opens a wide range of possibilities of what can be done in a plugin.

The most common uses of plugins are filters performing some analysis or processing on an image or image stack and I/O plugins for reading/writing not natively supported formats from/to file or other devices. But as you can see when looking at the plugins listed on the ImageJ plugins page, there are many other things you can do with plugins, such as rendering graphics or creating extensions of the ImageJ graphical user interface.

15 Resources on ImageJ JavaScript scripting include:

1. The ImageJ web site, with growing documentation:

2. Tutorials on the Fiji webpage:
   http://fiji.sc/wiki/index.php/JavaScript_Scripting

14 Plugins

Plugins are a much more powerful concept than macros and scripts and most of ImageJ’s built-in menu commands are in fact implemented as plugins. Quoting Werner Bailey [87]:

Plugins are implemented as Java classes, which means that you can use all features of the Java language, access the full ImageJ API and use all standard and third-party Java APIs in a plugin. This opens a wide range of possibilities of what can be done in a plugin.

The most common uses of plugins are filters performing some analysis or processing on an image or image stack and I/O plugins for reading/writing not natively supported formats from/to file or other devices. But as you can see when looking at the plugins listed on the ImageJ plugins page, there are many other things you can do with plugins, such as rendering graphics or creating extensions of the ImageJ graphical user interface.
Scripting in Other Languages

Advantages and disadvantages of JavaScript in ImageJ. A thorough comparison between different scripting languages is available on the Fiji webpage.

<table>
<thead>
<tr>
<th>JavaScript Advantages</th>
<th>JavaScript Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full access to ImageJ and Java APIs</td>
<td>Slower, especially starting up</td>
</tr>
<tr>
<td>Standardized</td>
<td>No equivalent of macro sets</td>
</tr>
<tr>
<td>Richer language (objects, ?, operator, break, continue, etc.)</td>
<td>Cannot use most of ImageJ’s 360+ built in macro functions</td>
</tr>
<tr>
<td>Extensive documentation</td>
<td>Requires knowledge of complex ImageJ and Java APIs</td>
</tr>
</tbody>
</table>

JavaScript Advantages

- Full access to ImageJ and Java APIs
- Standardized
- Richer language (objects, ?, operator, break, continue, etc.)
- Extensive documentation

JavaScript Disadvantages

- Slower, especially starting up
- No equivalent of macro sets
- Cannot use most of ImageJ’s 360+ built in macro functions
- Requires knowledge of complex ImageJ and Java APIs

CodeBar is a convenient ‘ActionBar’ that retrieves snippets and common tasks frequently used in macro writing. ‘ActionBars’ provide one or many easy to use button bar(s) that extend ImageJ’s graphical user interface. You can read more about the ActionBar plugin at the ImageJ Documentation Portal.

Developing ImageJ Plugins

More information on how to develop ImageJ plugins can be obtained on the following documents:


15 Scripting in Other Languages

Support for other languages is possible in ImageJ using Fiji and its powerful editor. Fiji adds extra support for BeanShell, Clojure, Python and Ruby. The following documents will introduce you to the advanced scripting capabilities of Fiji:


Fiji Script Editor

Fiji features a more powerful script editor than ImageJ’s built-in one (see ImageJ Editor). The Fiji editor is an invaluable help when writing scripts in any of Fiji’s supported languages, including the ImageJ macro language. The editor features full undo support, syntax highlighting, tabs, bookmarks and several other tools that simplify scripting workflows in ImageJ. For more information see the Fiji website at [http://fiji.sc/wiki/index.php/Script_Editor](http://fiji.sc/wiki/index.php/Script_Editor).

Running ImageJ from the Command Line

ImageJ recognizes the following command line options:

```
"file-name"
Opens a file. Examples:
  blobs.tif
  /Users/wayne/images/blobs.tif
e81*.tif

-ijpath path
Specifies the path to the directory containing the plugins directory.
Example:
  -ijpath /Applications/ImageJ

-port
Specifies the port ImageJ uses to determine if another instance is running. Examples:
  -port1 (use default port address + 1)
  -port2 (use default port address + 2)
  -port0 (do not check for another instance)
```

See also: [IJ_ED](http://ij.cidr.jgi.doe.gov/bindings/jedit/#IJ_ED), a plugin by Jérôme Mutterer that binds jEdit to ImageJ
ImageJ Interoperability

- **macro path [arg]** Runs a macro or script, passing it an optional argument, which can be retrieved using `getArgument()`. Examples:
  - `macro analyze.ijm`
  - `macro analyze /Users/wayne/images/stack1`

- **batch path [arg]** Runs a macro or script in batch mode (no GUI), passing it an optional argument. ImageJ exits when the macro finishes.

- **eval "macro code"** Evaluates macro code. Examples:
  - `eval "print('Hello, world');"`
  - `eval "return getVersion();"`

- **run command** Runs an ImageJ menu command. Example:
  - `run "About ImageJ..."`

- **debug** Runs ImageJ in debug mode.

See also: ImageJ Documentation Portal: Command line, Running ImageJ in headless mode, Linux installation

Part IV

ImageJ User Interface

Unlike most image processing programs ImageJ does not have a main work area. ImageJ’s main window is actually quite parsimonious containing only a menu bar (at the top of the screen on the Mac) containing all the menu commands, a toolbar, a status bar and a progress bar. Images, histograms, profiles, widgets, etc. are displayed in additional windows. Measurement results are displayed in the Results Table. Most windows can be dragged around the screen and resized.

The ImageJ window (version 1.44f).

<table>
<thead>
<tr>
<th>Status bar</th>
<th>Progress bar</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Rectangular Selection Tool and Rounded</td>
<td>7 Point Tool and Multi-point Tool</td>
</tr>
<tr>
<td>2 Rectangular Selection Tool</td>
<td>8 Wand Tool</td>
</tr>
<tr>
<td>3 Elliptical Selection Tool</td>
<td>9 Text Tool</td>
</tr>
<tr>
<td>4 Oval Selection Tool</td>
<td>10 Magnifying Glass</td>
</tr>
<tr>
<td>5 Polygon Selection Tool</td>
<td>11 Scrolling Tool</td>
</tr>
<tr>
<td>6 Freehand Selection Tool</td>
<td>12 Color Picker</td>
</tr>
<tr>
<td>7 Angle Tool</td>
<td>13 Toolset Switcher</td>
</tr>
<tr>
<td>8 Straight Line Selection Tool, Segmented Line and Brush Selection Tool</td>
<td></td>
</tr>
<tr>
<td>9 Wand Tool</td>
<td></td>
</tr>
<tr>
<td>A–H Macro Tools loaded from StartupMacros.txt, macros/tools/ or macros/toolsets/</td>
<td></td>
</tr>
</tbody>
</table>

The IJ User Guide — Booklet 17

Toolbar

The ImageJ toolbar contains tools for making selections, drawings, zooming and scrolling, etc. In addition, the right-side of the toolbar contains seven slots that can host any of the 60+ tools and 15+ tool sets available on the ImageJ website (cf. Macro Tools).

All ImageJ tools share common features:

- The ▼ on the bottom right corner of some icons in the toolbar depicts a contextual menu that can be accessed by right-clicking on the tool icon.
- If an ‘Options’ dialog is available for a particular tool, it can be accessed by double clicking on the tool icon (e.g., Wand Tool).

Status bar

When the cursor is over an image, pixel intensities and coordinates are displayed in the status bar. After running a filter, elapsed time and processing rate (in pixels/second) is also displayed. When clicking on the status bar the ImageJ version, the Java version, memory in use, memory...
available and percent memory used will be displayed. As selections are created or resized, selection properties (e.g., location, width, etc.) are displayed on the status bar.

In addition, clicking on ImageJ’s status bar, forces the Java garbage collector to run, which may help to reclaim unused memory (cf. Edit→Options→Memory & Threads...).

In addition, clicking on ImageJ's status bar, forces the Java garbage collector to run, which may help to reclaim unused memory (cf. Edit→Options→Memory & Threads...).

See also: Plugins→Utilities→ImageJ Properties..., Help→About ImageJ...

### Progress bar

The progress bar, located to the right of the status bar, shows the progress of time-consuming operations. It will not appear if the operation requires less than approximately one second.

#### 18 Tools

#### 18.1 Area Selection Tools

These tools share the first four toolbar slots. As described in Toolbar, use the right click drop-down menu to switch a different tool. Selection Color can be changed by double clicking on the Point Tool/Multi-point Tool.

#### 18.1.1 Rectangular Selection Tool

Location, width, height, and aspect ratio are displayed in the status bar during drawing (see V Toggling Calibrated Units).

The following modifier keys apply to the Rectangular Tool:

- **Shift**: Selection is constrained to a square.
- **Alt**: Width/height are changed with arrow keys one pixel at a time.
- **Ctrl**: Selection is resized around the center.
- **Ctrl Alt**: Current aspect ratio is maintained while resizing.

See also: Rounded Rectangular Selection Tool, Specify..., V Toggling Calibrated Units, XVII Embedding Color Annotations in Grayscale Images

#### 18.1.2 Rounded Rectangular Selection Tool

This tool creates rectangular shapes with rounded corners. It shares the same toolbar slot and the same modifier keys with the Rectangular Selection Tool. Double clicking on its icon opens the depicted dialog in which it is possible to specify:

- **Stroke width**: The width of the contour.
- **Corner diameter**: The arc size at the vertices.

See also: Rectangular Selection Tool, XVII Embedding Color Annotations in Grayscale Images

#### 18.1.3 Oval Selection Tool

Location, width, height, and aspect ratio are displayed in the status bar during drawing (see V Toggling Calibrated Units).

The following modifier keys apply to the Oval Tool:

- **Shift**: Selection becomes circular.
- **Alt**: Width/height are changed with arrow keys one pixel at a time.
- **Ctrl**: Selection is resized around the center.
- **Ctrl Alt**: Current aspect ratio is maintained while resizing.

See also: Elliptical Selection Tool, Specify..., V Toggling Calibrated Units, XVII Embedding Color Annotations in Grayscale Images

#### 18.1.4 Elliptical Selection Tool

Ellipse properties are adjusted by dragging the four handlers on its antipodal points [4]. To rotate or resize, drag the handlers on its major axis (transverse diameter). To adjust eccentricity, drag the handlers on its minor axis (conjugate diameter).

See also: Oval Selection Tool, XVII Embedding Color Annotations in Grayscale Images

#### 18.1.5 Brush Selection Tool

Adjusts the shape of any area selection using a circular ‘brush’ [5]. Clicking inside the area selection and dragging along its boundary will expand the boundary outwards. Clicking outside the area selection and dragging along its boundary will shrink the boundary inwards. Brush diameter can be adjusted by double clicking on the tool icon. Location, width, height, and aspect ratio are displayed in the status bar during drawing.

The following modifier keys apply to the Brush Tool:
18.1.6 Polygon Selection Tool

Creates irregularly shaped selections defined by a series of line segments. Segment length and angle are displayed in the status bar during drawing (see V Toggling Calibrated Units). To create a polygon selection, click repeatedly with the mouse to create line segments. When finished, click in the small box at the starting point (or double click), and ImageJ will automatically draw the last segment. The vertex points that define a polygon selection can be moved and modifier keys can be used to delete or add new vertices to the polygon.

The following modifier keys apply to the Polygon Tool:

- **Shift**
  - Clicking on a point with with the Shift key pressed adds a new point.
  - Clicking on a point with the Alt key down removes it.

SEE ALSO: Composite Selections, V Toggling Calibrated Units

18.1.7 Freehand Selection Tool

As with the polygon selection tool, ImageJ automatically draws the last segment. Location and intensity of starting pixel are displayed in the status bar during drawing.

SEE ALSO: Freehand Line Selection Tool, Polygon Selection Tool, Enlarge…, V Toggling Calibrated Units, XVII Embedding Color Annotations in Grayscale Images

18.2 Line Selection Tools

Use these tools to create line selections. Double click on any line tool to specify the line width by opening the Image > Adjust > Line Width… widget. The three line selection tools share the same toolbar slot. As described in Toolbar, use the right click drop-down menu to switch between line tools.

18.2.1 Straight Line Selection Tool

Length and line angle are displayed in the status bar during drawing (see V Toggling Calibrated Units).

The following modifier keys apply to the Straight Line Tool:

- **Shift**
  - Forces the line to be horizontal or vertical.
- **Alt**
  - Keeps the line length fixed while moving either end of the line.

Forces the two points that define the line to have integer coordinate values when creating a line on a zoomed image.

SEE ALSO: Calibration Bar…, Set Scale…, V Toggling Calibrated Units, XVII Embedding Color Annotations in Grayscale Images

18.2.2 Segmented Line Selection Tool

Works exactly as described for the Polygon Selection Tool. Create a segmented line selection by repeatedly clicking with the mouse. Each click will define a new line segment. Double click when finished, or click in the small box at the starting point. The points that define a segmented line selection can be moved or deleted, and new points can be added. Length and line angle are displayed in the status bar during drawing (see V Toggling Calibrated Units).

The following modifier keys apply to the Segmented Line Tool:

- **Shift**
  - Clicking on an existing point with the Shift key down adds a point.
- **Alt**
  - Clicking on an existing point with the Alt key down deletes it.

SEE ALSO: Polygon Selection Tool, Freehand Selection Tool, V Toggling Calibrated Units, XVII Embedding Color Annotations in Grayscale Images

18.2.3 Freehand Line Selection Tool

Select this tool and drag with the mouse to create a freehand line selection.

SEE ALSO: Freehand Selection Tool, V Toggling Calibrated Units, XVII Embedding Color Annotations in Grayscale Images

18.3 Arrow Tool

This tool shares the same toolbar slot with the Line Selection Tools. Double clicking on the tool icon opens the Options prompt depicted on the left [6]. Because it is an annotation tool, changing Color will change foreground color and not selection color (see Point Tool, Color Picker… [K]).

Width and Size (in pixels) can be adjusted by dragging the respective sliders or by direct input. Apart from the arrow styles listed here, a Headless option is also available.

As with other tools, add arrows to a non-destructive overlay using Image > Overlay > Add Selection… [b] or Edit > Draw [d] to permanently draw an arrow (see XVII Embedding Color Annotations in Grayscale Images).

Straight Line Selection Tool key modifiers can be used when creating an arrow, e.g., holding down `Ctrl` will force the arrow to be horizontal or vertical.
18.4 Angle Tool

This tool allows you to measure an angle defined by three points. Double click on the angle tool icon to enable the measurement of reflex angles. The angle is displayed in the status bar while the selection is being created or adjusted. Press \(\text{Alt} + (\text{Analyze} \rightarrow \text{Measure} \ldots [m])\) to record the angle in the Results Table.

18.5 Point Tool

Use this tool to create a point selection, to count objects or to record pixel coordinates. The following modifier keys apply to the Point Tool:

- **Shift**: Shift-clicking will add more points. Point count is displayed on the Status bar.
- **Alt**: Alt-clicking on a point will delete it. Alt-clicking and dragging with the rectangular or oval selection tool will delete multiple points.

Double clicking on the point tool icon (or running Edit \(\rightarrow\) Options \(\rightarrow\) Point Tool \(\ldots\)) displays its configuration dialog box.

- **Mark Width**: If greater than zero, a mark of the specified diameter will be permanently drawn in the current foreground color (cf. Color Picker \(\ldots [K]\)). Note that marks modify the image (it may be wise to work with a copy) and color marks are only available with RGB images (see XVII Embedding Color Annotations in Grayscale Images).

- **Auto-Measure**: If checked, clicking on the image records the pixel location and intensity. Note that if Mark Width is not zero, every time a point selection is measured a mark will be painted (cf. Measure \(\ldots [m]\)). If unchecked, Edit \(\rightarrow\) Draw \([d]\) can be used to paint the mark (Mark Width diameter) at the location of each point.

- **Auto-Next Slice**: If checked, ImageJ will automatically advance to the next stack slice. Note that this feature will only allow one point per slice.

- **Add to ROI Manager**: If checked, points will be automatically added to the ROI Manager.

- **Label Points**: If checked, each point selection will be displayed with an accompanying numeric label.

- **Selection Color**: Specifies the selection color, chosen from one of the nine ImageJ default colors: Red, Green, Blue, Magenta, Cyan, Yellow, Orange, Black and White. Note that the selection color is highlighted in the center of the Point/MultiPoint Tool (cf. Selections).

See also: Multi-point Tool, Cell Counter plugin

18.6 Multi-point Tool

The Multi-point Tool selects multiple points behaving as the Point Tool when \(\text{Shift} \) is pressed. Label Points is checked and Auto-Measure and Auto-Next Slice are deselected. As described for the Point Tool, \(\text{Alt} \) can also be used to remove points. Similarly, when using Edit \(\rightarrow\) Draw \([d]\) marks are painted with the diameter of Mark Width.

Double clicking on the tool icon runs the Image \(\rightarrow\) Overlay \(\rightarrow\) Add Selection \(\ldots [b]\) command.

See also: Point Tool, Cell Counter plugin

18.7 Wand Tool

Creates a selection by tracing objects of uniform color or thresholded objects. To trace an object, either click inside near the right edge, or outside to the left of the object. To automatically outline and measure objects have a look, e.g., at the WandAutoMeasureTool macro.

To visualize what happens, imagine a turtle that starts moving to the right from where you click looking for an edge. Once it finds the edge, it follows it until it returns to the starting point. Note that the wand tool may not reliably trace some objects, especially one pixel wide lines, unless they are thresholded (highlighted in red) using Image \(\rightarrow\) Adjust \(\rightarrow\) Threshold \(\ldots [T]\).

Double clicking on the wand tool icon (or running Edit \(\rightarrow\) Options \(\rightarrow\) Wand Tool \(\ldots\)) opens the configuration dialog box in which three modes (4-connected, 8-connected or 'Legacy') plus a tolerance value can be set \([T]\).

The Wand Tool. 4/8-connected particles can be traced within an intensity range.

- **Tolerance**: The wand takes the pixel value where you click as an initial value. It then selects a contiguous area under the condition that all pixel values in that area must be in the range \(\text{initial value} - \text{tolerance} \leq \text{initial value} + \text{tolerance}\).

- **4-connected**: Only the four neighbors of a pixel are considered neighbors. E.g., the wand does not follow a one-pixel wide diagonal line because the pixels of that line are not four-connected.

- **8-connected**: Each pixel is considered to have eight neighbors. So the wand follows a diagonal line if you click onto it. On the other hand, if you have an area of constant value dissected by a one-pixel wide diagonal line, the 8-connected wand will 'jump over the line' and include the other part of that area.

- **Legacy**: In this mode no neighbor is checked and no tolerance is used. This is the default mode of the Wand Tool in ImageJ 1.42 and earlier.

18.8 Text Tool

Use this tool to add text to images. It creates a rectangular selection containing one or more lines of text. Use the keyboard to add characters to the text and the backspace key to delete...
characters. Use Image ➤ Overlay ➤ Add Selection... [b] to add the text non-destructively to the overlay. Use Edit ➤ Draw [d] to permanently draw the text on the image. Use Edit ➤ Options ➤ Fonts... [c] or double click on the text tool, to specify the typeface, size, alignment and style. Alternatively, use Edit ➤ Selection ➤ Properties... [y] to adjust font size and text alignment.

SEE ALSO: TextDemo, DrawTextWithBackground, OverlayDrawStringDemo and TextOverlay macros

18.9 Magnifying Glass

Click on the image with this tool to zoom in. Right-click (or Alt-click) to zoom out. The current magnification is shown in the image’s title bar. Double click on the magnifying glass icon to revert to the image’s original magnification. There are 21 possible magnification levels: 3.1, 4.2, 6.3, 8.3, 12.5, 16.7, 25, 33.3, 50, 75, 100, 150, 200, 300, 400, 600, 800, 1200, 1600, 2400 and 3200 percent.

The following modifier keys apply to the Magnifying Glass Tool:
- Shift: When zooming in will prevent the window from being enlarged.
- Alt: Will zoom out (right-click behavior).

SEE ALSO: Zoom ➤, XVIII Scrolling Zoomed Images

18.10 Scrolling Tool

Allows you to scroll through an image that is larger than its window. When using other tools (except the text tool), you can temporarily switch to this tool by holding down the space bar (see XVIII Scrolling Zoomed Images).

18.11 Color Picker

Sets the foreground drawing color by 'picking up' colors from any open image. Colors can also be 'picked up' from the Color Picker (CP) window (Image ➤ Colors ➤ Color Picker... [k]) window using any tool. In the icon, the 'eye dropper' is drawn in the current foreground color while the frame around it is drawn in the current background color. Edit ➤ Draw [d] and Edit ➤ Fill [f] use the foreground color. Edit ➤ Clear, Clear Outside and Cut [x] use the background color. Double clicking on the tool icon will display the Color Picker window.

The following modifier key applies to the Color Picker Tool:
- Alt: Alt-clicking with the Color Picker Tool on an image will change the background color.

SEE ALSO: Image Types and Formats, XVII Embedding Color Annotations in Grayscale Images
19 Contextual Menu

As mentioned earlier macros and macro tools in the StartupMacros.txt are automatically installed in the Plugins>Macros submenu and in the toolbar when ImageJ starts up.

In addition, the StartupMacros.txt file also installs the contextual (popup) menu displayed when right-clicking on an image. Other macros and toolsets (e.g., Magic Montage) may also replace the default menu with specialized ones. In this case, re-installing the StartupMacros (using the Toolset Switcher) will revert the contextual menu to its default.

The ImageJ Macro Language — Programmer’s Reference Guide explains how this menu can be customized:

```java
var pmCmds = newMenu("Popup Menu", newArray("Help...", "Rename...", "Duplicate...", "Original Scale", "Paste Control...", "Record...", "Capture Screen", "Monitor Memory...", "Startup Macros...", "Search...", "Find Maxima...", "-", "Subtract Background..."));
```

The menu that is displayed when a user right-clicks (or ctrl-clicks) on an image window can be customized through installation of the "Popup Menu" macro. Any menu has a name and a list of menu items. The newMenu(name, items) macro function allows the creation of a new menu. This menu passes the chosen item as a simple string to the "Popup Menu" macro. From this point you can decide what to do, according to what item was chosen.

(4) Customizing the Image Popup Menu

So, e.g., to add the ability to run the Process>Subtract Background... command from the contextual menu one can simply add that command to the list of items defining the PopUp Menu. Note that "-" defines menu separators:

```java
var pmCmds = newMenu("Popup Menu", newArray("Help...", "Rename...", "Duplicate...", "Original Scale", "Paste Control...", "Record...", "Capture Screen", "Monitor Memory...", "Startup Macros...", "Search...", "Find Maxima...", "-", "Subtract Background..."));
```

20 Results Table

Most of ImageJ analyses are printed to the Results table. Table commands are organized in four menus: File> , Edit> , Font> and Results> . A contextual menu listing the majority of these commands can be accessed by right-clicking anywhere in the Results window.

File> Save As...  Exports the measurements as a tab-delimited or comma-delimited text file as defined in Results> Options...

File> Rename... Renames the table. Because ImageJ outputs measurements exclusively to the Results table, renaming the table will freeze its contents.

Font> This menu contains commands to adjust font size.

Results> Clear Results... Alias for the Analyze> Clear Results command.

Results> Summarize Alias for the Analyze> Summarize command.

Results> Distribution... Alias for the Analyze> Distribution... command.

Results> Set Measurements... Alias for the Analyze> Set Measurements... command.

Results> Options... Opens the Edit> Options> Input/Output... dialog in which is possible to specify if column headers and row numbers should be saved or copied from ImageJ tables (including the Summarize table, cf. Analyze> Analyze Particles... ). In addition, it allows to specify the file extension to be used when saving data. Custom extensions (e.g., .csv, .xls or .ods) allow ImageJ tables to be imported seamlessly by spreadsheet applications. ImageJ tables are saved in CSV format if File extension for tables is .csv.

For more information see: Plugins> New> Table...
The ImageJ editor (version 1.43m).

21 ImageJ Editor

Macros▷, Scripts and Plugins can be opened and executed in the ImageJ editor. The editor commands are organized in five menus: File▷, Edit▷, Font▷, Macros▷ and Debug▷.

File▷ Basic file operations (Open, Save, Print, etc.) are listed in this menu. The last saving directory is kept in $IJ\_prefs\_txt$, the IJ preferences file.

Edit▷ Similarly to any other text editor this menu contains commands related to text handling as well as commands for locating text. Specially useful are:

Go to Line... [l]. This dialog box enables you to quickly go to a specified line of code.

Zap Gremlins This command finds and deletes the extraneous non-visible, non-printing characters that sometimes appear when cutting and pasting from other sources, such as email messages that may contain extraneous control characters, or any non-ASCII characters.

Copy to Image Info This command will copy the selected text (or the entire contents of the editor if no selection is present) to the image header, being available through the Image▷ Show Info... [i] command. Note that the copied text will substitute any other information present in the file header and will only be available in images saved as TIFF (see II Image Types: Lossy Compression and Metadata).

Font▷ This menu contains commands to adjust font size and type.

Macros▷ This menu contains commands that allow you to run, install or evaluate macro code:

Run Macro [r]. Runs the macro or the selected line(s) of code.

Evaluate Line [y]. Runs the line of code that contains the insertion point.

Abort Macro Exits the macro.

Install Macros [i]. Adds the macro(s) contained in the editor to Plugins▷ Macros▷ submenu (Plugins▷ Macros▷ Install... command).

Function Finder... [F]. Retrieves macro functions in the same way Find Commands... [f] retrieves commands. Functions are read from the ‘functions.html’ file stored in the macros folder (a local copy of http://imageij.nih.gov/ij/developer/macro/functions.html). This file is deleted by Help▷ Update ImageJ... command every time ImageJ is updated to a release version (i.e., not a daily build), forcing Function Finder to download a fresh copy the next time it is launched.

Evaluate JavaScript [j]. Runs JavaScript code in the editor window. Note that Run Macro runs JavaScript code if the title of the file ends with ‘.js’.

Debug▷ This menu contains seven commands related to the macro debugging. You can debug a macro using the commands in the Debug menu. You start a debugging session initiating Debug Macro. You can then single step through the macro code by repeatedly running Step.

Debug Macro [d]. Starts running the macro in debug mode and opens the ‘Debug’ window, which initially displays the memory usage, number of open images, and the active image’s title. The macro stops running at the first executable line of code, which is highlighted. Use one of the following commands to continue execution.

Step [e]. Executes the highlighted statement and advances to the next. The variable names and values in the ‘Debug’ window are updated.

Trace [t]. Runs the macro, displaying variable names and values in the ‘Debug’ window as they are encountered. Fast Trace [T] Same as above, but faster.

Run To Insertion Point. Runs the macro to a statement that was previously run. Run to Insertion Point. runs JavaScript code if the title of the file ends with ‘.js’.

Abort Exits debug mode.

SEE ALSO: Extending ImageJ (Macros and Scripts), The ImageJ Macro Language – Programmer’s Reference Guide, Fiji’s Introduction into Macro Programming, Plugins▷ Macros▷ Record... , Fiji Script Editor, IJ_ED

36 Latest revision: 2011/12/27

37 Latest revision: 2011/12/27
22 Log Window

The Log window is used to display useful information about ongoing operations. It is frequent for plugins and macros to send messages to the Log window reporting progress, errors or troubleshooting information.

If you are troubleshooting a problem, you can check Debug mode in Edit ⊲ Options ⊲ Misc... to have ImageJ outputting messages to the Log window (ImageJ will exit debug mode as soon as the Log window is closed).

In addition, Tiff tags and information needed to import files are printed to the log window when ImageJ runs in Debug Mode.

Most of the general shortcuts described in ImageJ Editor apply to the Log window.

Part V
Menu Commands

As described in the ImageJ User Interface, the menu bar lists all ImageJ commands. It is organized in eight menus:

- **File** - Basic file operations (opening, saving, creating new images). Most are self-explanatory.
- **Edit** - Editing and drawing operations as well as global settings.
- **Image** - Conversion and modification of images including geometric transformations.
- **Process** - Image processing, including point operations, filters and arithmetic operations.
- **Analyze** - Statistical measurements, profile and histogram plotting and other operations related to image analysis.
- **Plugins** - Commands for creating, editing and managing add-ons (see Extending ImageJ), listing all the user-installed Macros, Scripts and Plugins installed in the ImageJ/plugins/ directory.
- **Window** - Selection and management of open windows.
- **Help** - Updates, documentation resources and version information.

Window ⊲ Selection and management of open windows.
Help ⊲ Updates, documentation resources and version information.

VI Opening File Paths in the Log Window

In the Log Window, double click on a file path to have it open by ImageJ.

Part V
Organizing Commands in the Menu Bar

The Plugins menu can become easily cluttered after the installation of several plugins. Since Plugins reflects the hierarchy of directories in ImageJ/plugins (up to two subfolders), submenus (i.e., subfolders) can be created to keep the menu organized, preventing it from running off the bottom of the screen. E.g., to move the EPS Writer plugin into a Plugins ⊲ Input-Output ⊲ PDF submenu, one would move EPS_Writer.class into ImageJ/plugins/Input-Output/PDF/.

In addition, checking the Move isolated plugins to Misc. menu checkbox in Edit ⊲ Options ⊲ Misc... will compact the menu list by moving to Plugins ⊲ Miscellaneous all the plugins with only one command that try to install themselves in submenus.

Note that external plugins can be installed in any of the ImageJ menus. This is the case of plugins packaged in JAR files containing a configuration file (plugins.config) specifying the location of the new commands implemented by the plugin. You can rename, reorganize or move commands implemented by external plugins by editing their plugins.config file as described on the JAR demo documentation page. If you don’t know in which menu a plugin has been registered, use Show full information in the command Finder (Plugins ⊲ Utilities ⊲ Find Commands... [l]) to find out the location of the installed .jar files.

With Fiji, Scripts and Macros can be registered in any menu by saving into Fiji.app/plugins/Scripts/menu name/submenu name/. E.g., to have a certain macro installed in the File ⊲ Import submenu one would save it in Fiji.app/plugins/Scripts/File/Import/.

See also: ImageJ’s plugin architecture on the Fiji website
23  File &gt;

23.1 New &gt;

Contains commands for creating new images, stacks, hyperstacks or text windows.

See also: Plugins &gt; New &gt;

23.1.1 Image... [n]

Creates a new image window or stack. A dialog box allows you to specify the image title, type, dimensions and initial content.

Name is the title that will be used for the Window. Type is the image type: 8-bit grayscale, 16-bit grayscale (unsigned), 32-bit (float) grayscale or RGB color. Fill With (White, Black or Ramp) specifies how the image is initialized. Width and Height specify the image dimensions in pixels. Set Slices to a value greater than one to create a stack.

See also: Image &gt; Hyperstacks &gt; New Hyperstack..., Image Types and Formats

23.1.2 Hyperstack...

Alias for the Image &gt; Hyperstacks &gt; New Hyperstack... command.

23.1.3 Text Window [N]

Creates a new text window with the title ‘Untitled.txt’.

See also: Plugins &gt; New &gt; Text Window..., Macro, Table...

23.1.4 Internal Clipboard

Opens the contents of the internal ImageJ clipboard.

See also: Edit &gt; Copy [c], Cut [x], Paste Control...

23.1.5 System Clipboard [V]

Opens the contents of the operating system clipboard.

See also: Edit &gt; Copy to System, Cut [x], Paste Control...

23.2 Open...

Opens an image and displays it in a separate window. Image files must be in TIFF, GIF, JPEG, DICOM, BMP, PGM or FITS format, or in a format supported by a reader plugin. Also opens:

- ImageJ and NIH Image lookup tables (.lut extension).
- Tables in tab-delimited text format (.xls or .csv extension, see Results Table)
- Selections (.roi or .zip extension)
- Text files (.txt, .ijm, .js and .java extensions)

See also: File &gt; Import, Image Types and Formats, Virtual Stacks, VIII Opening Files: File &gt; Open, File &gt; Import and Drag & Drop

VIII Opening Files: File &gt; Open, File &gt; Import and Drag & Drop

While the File &gt; Open... command opens formats natively supported by ImageJ (images and non-images files), the File &gt; Import submenu provides access to plugins for additional file types (e.g., reading ‘raw’ files, images in ASCII format or loading images over the network). Most of ImageJ’s Input/Output plugins are installed on this submenu.

Note that almost every format known to ImageJ can be opened by dragging and dropping the file into the ImageJ Window. E.g., in the illustration below a remote macro file is opened by dragging its URL directly from a Web browser.

23.3 Open Next [O]

Closes the current image and opens the next image (if any) in its directory. Holding Alt opens the previous image (if any) in its directory.

23.4 Open Samples

Opens example images hosted on the ImageJ Web site. These sample images are useful for creating, testing and debugging macros since routines can be applied to the same image, regardless of where the macro is run. Among all, probably the most used is blobs.gif: Open Samples &gt; Blobs (25K) [B].

Sample images can be downloaded from http://imagej.nih.gov/ij/images/ or, in bulk, from http://imagej.nih.gov/ij/download/sample-images.zip. The ‘AutoRun’ macro in the Startup-Macros.txt file can be used to change the default path of sample images, allowing a complete off-line usage of the File &gt; Open Samples submenu:
23.5 Open Recent

The submenu shows a list of the 15 recently opened files. Click on a filename to open it.

23.6 Import

This submenu lists the installed image reader plugins.

See also: Non–native Formats, Acquisition plugins, Input/Output plugins, VirtualStackFrom-
List macro, VIII Opening Files: File ⊿ Import ⊿ Drag & Drop

23.6.1 Image Sequence...

Opens a series of images in a chosen folder as a stack. Images may have different dimensions and can be of any format supported by ImageJ (see Image Types and Formats and HandleExtraFileTypes plugin). Invisible files, Thumbs.db or RoSet.zip files created by the ROI Manager... are ignored. Information – width×height×depth (size) – of the stack to be created is displayed at the bottom of the dialog.

Number of Images Specifies how many images to open.

Starting Image If set to n, import will start with the nth image in the folder.

Increment If set to 2 ‘every other image will be opened, if set to 3 ‘every third image will be opened, etc.

File Name Contains Enter a string into this field and ImageJ will only open files whose name contains that string.

Enter Pattern Regular expressions (regex) can be typed here for advanced filtering (cf. Basic syntax of regular-expressions).

Scale Images Setting a value less than 100% will reduce memory requirements. E.g., entering 50 reduces the amount of memory needed to open a stack by 75%.

Regular-expressions basic syntax summary. For more information on regex filtering see http://download.oracle.com/javase/tutorial/essential/regex/.

<table>
<thead>
<tr>
<th>Regex Syntax (Character Classes)</th>
<th>Example</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>[]</td>
<td>Delimit the set of characters to match [aA]</td>
<td>Either lower or upper case A</td>
</tr>
<tr>
<td>-</td>
<td>Character ranges [0-9]</td>
<td>Any digit (from 0 through 9)</td>
</tr>
<tr>
<td>-</td>
<td>Any character [0-9]</td>
<td>A digit plus any other character</td>
</tr>
<tr>
<td>*</td>
<td>Zero or more of the preceding item *</td>
<td>Any character sequence</td>
</tr>
<tr>
<td>?</td>
<td>Zero or one of the preceding item [0-9]？</td>
<td>An optional digit</td>
</tr>
<tr>
<td>+</td>
<td>One or more of the preceding item [0-9]+</td>
<td>At least a digit</td>
</tr>
<tr>
<td>^</td>
<td>Negation [‘0-9]</td>
<td>Any character that is not a digit</td>
</tr>
<tr>
<td></td>
<td>OR (Alternation) [0-9]</td>
<td>A digit or lower or upper case letter</td>
</tr>
</tbody>
</table>

IX Reducing Memory Requirements When Importing Images

Since ImageJ 1.44d, the File ⊿ Import ⊿ Image Sequence... command no longer features the Convert to 8-bit Grayscale check box. This option was used to reduce memory requirements but used different scaling for each imported image.

As a replacement, use the Use virtual stack option and then convert to 8-bit using File ⊿ Type ⊿ 8-bit. Memory requirements can also be reduced by using the Scale Images (%) option.

See also: Edit ⊿ Options ⊿ Memory & Threads...
23.6.2 Raw...

Use this command to import images that are not in a file format directly supported by ImageJ. You will know to need to know certain information about the layout of the image file, including the size of the image, and the offset to the beginning of the image data.

Interleaved RGB images have pixels stored contiguously (rgrbgrbgr...) in a single image plane. Planar RGB images have the red, green and blue image data stored in separate 8-bit sample planes. ImageJ saves RGB images (both TIFF and raw) in interleaved format.

Image Type: There are fourteen choices depicted above. 16-bit signed integer images are converted to unsigned by adding 32,768. 1-bit Bitmap images are converted to 8-bit.

Image Width: The number of pixel in each row of image data.

Image Height: The number of rows in the image.

Offset to First Image: The number of bytes in the file before the first byte of image data.

Number of Images: The number of images stored in the file. If this value is greater than the actual number of images the resulting stack will get truncated to the actual size.

Gap Between Images: The number of bytes from the end of one image to the beginning of the next. Set this value to width x height x bytes-per-pixel x n to skip n images for each image read.

White is Zero: Should be checked if black pixels are represented using numbers that are less than the numbers used for white pixels. If your images look like photographic negatives, changing this field should fix the problem.

Little-Endian Byte Order: Probably needs to be checked when importing 16-bit or 32-bit grayscale images from little-endian machines such as Intel based PCs.

Open All Files in Folder: If checked, ImageJ will import all the images in the folder as a stack. The images must all be the same size and type.

Use Virtual Stack: Images are imported as virtual stacks.


See also: Image Types and Formats

23.6.3 LUT...

Opens an ImageJ or NIH Image lookup table, or a raw lookup table. The raw LUT file must be 768 bytes long and contain 256 reds, 256 blues and 256 greens. If no image is open, a 256x32 ramp image is created to display the LUT. Note that lookup tables with file names ending in .lut can also be opened using File ⊿ Import ⊿ Text Image...

23.6.4 Text Image...

Opens a text delimited text file as a 32-bit real image (see Text Images). The image’s width and height are determined by scanning the file and counting the number of words and lines. For text files with integer values no larger than 255, use Image ⊿ Type: 8-bit to convert to 8-bit.

Before converting, disable Scale When Converting in Edit ⊿ Options ⊿ Conversions... to prevent the image from being scaled to 0–255.

See also: OpenTextImagesAsStack macro, Save ⊿ As ⊿ Text Image...

23.6.5 Text File...

Opens a text file. Note that text files can also be opened using File ⊿ Open... or drag and drop.

23.6.6 URL...

Downloads and displays known formats to ImageJ specified by a URL. Other URLs ending with ‘/’ or ‘.html’ are opened in the user’s default browser. The Input URL is saved in the ImageJ preferences file and retrieved across IJ restarts.

With IJ 1.44g and later, it is possible to open zip archives, using a URL, that contain multiple DICOM images. Some example URLs are:

- file:///D:/images/neuron.tif

23.6.7 Results...

Opens an ImageJ table, or any tab or comma-delimited file (see Results Table). Note that .csv and .xls files can also be opened by drag and drop.

23.6.8 Stack From List...

Opens a stack, or virtual stack, from a text file or URL containing a list of image file paths [9]. The images can be in different folders but they must all be the same size and type. The Virtual Stack From List macro demonstrates how to generate a list of images and then use that list to open the images as a virtual stack. The OpenStackUsingURLs macro demonstrates how to open an image series from a remote server.

23.6.9 TIFF Virtual Stack...

Opens a TIFF file as virtual stack (see Virtual Stacks and III Opening Virtual Stacks by Drag & Drop).
23.6.10 AVI...

Uses a built-in version of the AVI reader plugin to open an AVI file (JPEG or PNG compressed, or uncompressed) as a stack or virtual stack (one slice per video frame). AVI files can also be opened using File ▹ Open... or drag and drop, but macros must use this command to gain access to the dialog box options.

Please note that ImageJ only supports a restricted number of AVI formats (cf. plugin source code).

Since version 1.41b an improved version of the AVI reader [16] retrieves animation speed from the Movie Properties dialog box. An option to convert to 8-bit grayscale, an option to open the movie as a virtual stack, along with many bug fixes.

23.7 Close [w]

Closes the active image.

23.8 Close All

Closes all open images. An alert is displayed if there are unsaved changes.

23.9 Save [s]

Saves the active image in TIFF format, the 'default' format of ImageJ (cf. II Image Types: Lossy Compression and Metadata). To save only a selected area, create a rectangular selection and use the Image ▹ Duplicate... [D] command. Note that Save [s] and File ▹ Save As ▹ Tiff... are redundant commands.

23.10 Save As:

Use this submenu to save the active image in TIFF, GIF, JPEG, or 'raw' format. Can also be used to save measurement results, lookup tables, selections, and selection XY coordinates.

23.10.1 TIFF

Saves the active image in TIFF format in redundancy with File ▹ Save [s]. TIFF is the only format (other than 'raw') that supports all ImageJ data types (8-bit, 16-bit, 32-bit float and RGB) and the only format that saves spatial and density calibration. In addition, with ImageJ 1.43 and later, selections and overlays are also saved in the TIFF header.

By default, 16-bit and 32-bit images are saved using big-endian byte order. Check Save TIFF and Read in Intel Byte Order in the Edit ▹ Options ▹ Input/Output... dialog box to save using little-endian byte order.

See also: Native Formats, II Image Types: Lossy Compression and Metadata, X Warning on JPEG compression

23.10.2 GIF...

Saves the active image in GIF format. RGB images must first be converted to 8-bit color using Image ▹ Type ▹ 8-bit Color. The value to be used as the transparent index (0–255) can be set in the Edit ▹ Options ▹ Input/Output... dialog box. Stacks are saved as animated GIFs. Use Image ▹ Stack ▹ Tools ▹ Animation Options... [Alt /] (or right-click on the on the play/pause icon that precedes the stack slider) to set the frame rate.

23.10.3 JPEG...

Saves the active image in JPEG format. Edit JPEG Quality ▹ Options ▹ Input/Output... dialog box to specify the JPEG compression level (0–100). This value is shown on the title of the save dialog prompt. Lower values produce smaller files but poorer quality. Larger values produce larger files but better quality. Color sub-sampling is disabled when the value is set to 100, reducing the likelihood of color artifacts. By default, the DPI in the JPEG header is set to 72. For a higher value, use a unit of inch in the Analyze ▹ Set Scale... dialog. E.g., setting Distance in Pixels to 300, Known Distance to 1 and Unit of Length to 'inch' will set the DPI to 300.

Since IJ 1.43 and later, overlays are embedded when saving in JPEG format (cf. Flatten [F]).

See also: II Image Types: Lossy Compression and Metadata, X Warning on JPEG compression

23.10.4 Text Image...

Saves the active image as a spreadsheet compatible tab-delimited text file. For calibrated images and floating-point images, the Decimal Places field in Analyze ▹ Set Measurements... determines the number of digits to the right of the decimal point. For RGB images, each pixel is converted to grayscale using the formula gray = [(red + green + blue) / 3] or the formula gray = 0.299 x red + 0.587 x green + 0.114 x blue if Weighted RGB to Grayscale Conversion is checked in Edit ▹ Options ▹ Conversions... (in IJ 1.43 and later).

See also: Import ▹ Text Image...

23.10.5 ZIP...

Saves the active image or stack as a TIFF file inside a compressed ZIP archive.

X Warning on JPEG compression

The JPEG format uses lossy compression that can result in artifacts. You should never use this format on images to be segmented or measured.
23.10.6 Raw Data...

Saves the active image or stack as raw pixel data without a header. 8-bit images are saved as unsigned bytes, unsigned 16-bit images are saved as unsigned shorts and signed 16-bit images (e.g., File > Open Samples > CT) are saved as signed shorts. 32-bit images are saved as floats and RGB images are saved in three bytes per pixel (24-bit interleaved) format. 16-bit and 32-bit (float) images are saved using big-endian byte order unless Export Raw in Intel Byte Order is checked in the Edit > Options > Input/Output... dialog box.

23.10.7 Image Sequence...

Saves a Stack or a hyperstack as an image sequence.

**Format**

Specifies the output format that can be set to either BMP, FITS, GIF, JPEG, PGM, PNG, Raw, Text Image, TIFF, or Zip (cf. Image Types and Formats). In IJ 1.44 and later, overlays are embedded when saving in JPEG or PNG format.

**Start At** (Stacks only)

Specifies the starting number of the sequence. Use slice labels as filenames (Stacks only) If checked, each slice will be saved with its own label (the image subtitle displayed above the image, see Remove Slice Labels) and no numeric sequence will be used.

**Digits (1–8)**

The number digits of the incremental sequence. File names are padded with leading zeroes.

**Use slice labels as filenames** (Stacks only) If checked, each slice will be saved with its own label (the image subtitle displayed above the image, see Remove Slice Labels) and no numeric sequence will be used.

With hyperstacks, images are saved using ‘Name_t_d_z_xd_c d’ in which d is the incremental number of specified Digits; t, the frame; z, the slice and c, the channel, so e.g., for the depicted snapshot the first image would be saved as ‘mitosis_001_t001_z001_c001.tif’.

23.10.8 AVI...

Exports a stack or hyperstack as an AVI file [10].

**Compression** JPEG, PNG or Uncompressed.

With IJ 1.44 and later, overlays are embedded when saving in JPEG or PNG format. The default compression is JPEG.

**Frame**

Specifies the frame frequency. The proposed value is read from Image > Stacks > Tools > Animation Options... [Alt/] and Image > Properties... [P], as long as the unit of Frame Interval is ‘sec’.

SEE ALSO: File > Import > AVI...

23.10.9 PNG...

Saves the active image in PNG (Portable Network Graphics) format. All image types, except RGB, are saved as 8-bit PNGs. 16-bit images are saved as 16-bit PNGs. With 8-bit images, the value to be used as the transparent index (0–255, -1 for "none") can be set in the Edit > Options > Input/Output... dialog box. With IJ 1.44 and later, overlays are embedded when saving in PNG format.

23.10.10 FITS...

Saves the active image in FITS (Flexible Image Transport System) format [11].

23.10.11 LUT...

Saves the active image’s lookup table to a file. The 768 byte file consists of 256 red values, 256 green values and 256 blue values.

23.10.12 Results...

Exports the contents of the ‘Results’ window as a tab-delimited or comma-delimited (.csv) text file. Prior to ImageJ 1.44b this command used to be named ‘Measurements...’.

23.10.13 Selection...

Saves the current area selection boundary to a file. Use File > Open... to restore the selection. Since IJ 1.43 active selections are saved in the TIFF header by default (cf. File > Save As > Tiff...).

23.10.14 XY Coordinates...

Exports the XY coordinates of the line selection or area selection boundary as a two column, tab-delimited text file. Coordinates of rectangular, oval and straight line selections cannot be exported. Use the Path Writer plugin to save coordinates at evenly spaced one pixel intervals.
23.11 Revert [r]

Reloads the active image, stack or hyperstack from disk, reverting it to its last saved state. It is actually a shortcut for closing the window without saving, and then reopening it.

See also: Undo and Redo

23.12 Page Setup...

The Page Setup dialog allows you to control the size of printed output, plus other printing options:

- **Scale**: Values less than 100% reduce the size of printed images and values greater than 100% increase the size. 100% corresponds to 72 pixels per inch (ppi), about the unzoomed screen size of the image. The size of the printed image is determined by the Scale value and the width and height of the image in pixels. Spatial calibration is ignored.

- **Draw border**: If checked, ImageJ will print a one pixel wide black border around the image.

- **Center on page**: If checked, the image will be printed in the center of the page instead of in the upper left corner.

- **Print title**: If checked, the title of the image will be printed at the top of the page.

- **Selection only**: If checked, current selection will be printed instead of the entire image.

- **Rotate 90°**: If checked, the image will be rotated 90° to the left before being printed.

- **Print actual size**: Considers the DPI information in the image header (typically 72, cf. .jpeg...). For a higher value, use a unit of inch in the Analyze ⊖ Set Scale... dialog. E.g., setting Distance in Pixels to 300, Known Distance to 1 and Unit of Length to ‘inch’ will set the DPI to 300.

23.13 Print... [p]

Prints the active image. The size of the printed image will normally be slightly less its size on the screen (unzoomed). Use the Page Setup... dialog to increase or decrease the size of printed images. Images larger than the page are scaled to fit. With IJ 1.44 and later, overlays are embedded when printing.

23.14 Quit

Prompts you to save all unsaved images and then exits. You can also exit ImageJ by clicking on the close button in its window’s title bar.

24 Edit

24.1 Undo [z]

Described in Undo and Redo.

24.2 Cut [x]

Copies the contents of the current image selection to the internal clipboard and fills it with the current background color.

See also: Edit ⊖ Copy to System, Paste Control...

24.3 Copy [c]

Copies the contents of the current image selection to the internal clipboard. If there is no selection, copies the entire active image. The amount of image data copied is shown in the status bar.

See also: File ⊖ Internal Clipboard, Paste Control...

24.4 Copy to System

Copies the contents of the current image selection to the system clipboard.

See also: File ⊖ New ⊖ System Clipboard [V], Copy [c], Paste Control...

24.5 Paste [v]

Inserts the contents of the internal clipboard (or from the system clipboard if the internal clipboard is empty) into the active image. The pasted image is automatically selected, allowing it to be dragged with the mouse. Click outside the selection to terminate the paste. Select Edit ⊖ Undo [z] to abort the paste operation.

See also: Paste Control...

24.6 Paste Control...

After pasting, use the Paste Control pop-up menu to control how the image currently being pasted is transferred to the destination image.

Except for Blend and Transparent, the Paste Control transfer modes are the same as those listed in the description of Process ⊖ Image Calculator... The Blend mode is the same as the Image Calculator Average mode. In Transparent mode, white/black pixels are transparent and all other pixels are copied unchanged.

See also: Image ⊖ Overlay ⊖ Add Image...
24.7 Clear

Erases the contents of the selection to the current background color. Backspace and Del keys are shortcuts to this command. With stacks, a dialog is displayed offering the option to clear the selection in all stack images. Clear by pressing Backspace to avoid this dialog.

See also: Clear Outside, Fill [f], Color Picker

24.8 Clear Outside

Erases the area outside the current image selection to the background color.

See also: Clear, Fill [f], Color Picker

24.9 Fill [f]

Fills the current selection with the current foreground color. With stacks, a dialog is displayed offering the option to fill the selection in all stack images. Fill the selection by pressing F to avoid this dialog.

See also: Clear, Draw [d], Color Picker

24.10 Draw [d]

Outlines the current selection using the current foreground color and line width. The foreground and background colors can also be set using the Edit>Options>Colors command. Use the Edit>Options>Line Width command, or double click on the line tool, to change the line width.

With stacks, a dialog is displayed offering the option to draw the selection in all stack images. Draw the selection by pressing F to avoid this dialog.

See also: Analyze>Label, Color Picker, XVII Embedding Color Annotations in Grayscale Images, XI Drawing Lines Wider Than One-Pixel

XI DRAWING LINES WIDER THAN ONE-Pixel

If the line width is an even number, the selection boundary is at the center of the line. If the line width is odd (1, 3, ...), the center of the line drawn is displaced from the selection edge by 1/2 pixel to the bottom right. Thus the line center (the line in case of line width = 1) is inside the selection at the top and left borders, but outside at the bottom and right borders. Rectangular selections (but not polygonal selections or traced selections that happen to be rectangular) are an exception to this rule. For rectangular selections, one-pixel wide outlines are always drawn inside the rectangle. Thicker lines are drawn as for the other selection types.

24.11 Invert [I]

Creates a reversed image, similar to a photographic negative, of the entire image or selection.

See also: Image>Lookup Tables> Invert LUT

24.12 Selection

ROI manipulations using the Edit>Selection> submenu commands.

24.12.1 Select All [a]

Creates a rectangular selection that is the same size as the image.

24.12.2 Select None [A]

Deactivates the selection in the active image.

24.12.3 Restore Selection [E]

Restores the previous selection to its original position. A selection is saved when you:

- Delete the selection by clicking outside of it
- Draw a new selection
- De-activate the image containing the selection
- Close the image containing the selection
- Use a command that deletes or modifies the selection

See also: Analyze>Tools>ROI Manager...

XII TRANSFERRING SELECTIONS BETWEEN IMAGES

You can transfer a selection from one image to another by activating the image with the selection, activating the destination image, then pressing Shift E (the keyboard shortcut for Edit>Selection>Restore Selection [E]).
24.12.4 Fit Spline

Fits a cubic spline curve to a polygon or polyline selection (see ROI manipulations).

24.12.5 Fit Circle

Fits a circle to a multipoint (with at least 3 points) or area selection [12] (see ROI manipulations). Composite selections are not supported. With open shapes (lines and points), the fitting algorithm (Newton-based Pratt fit) described in Pratt V, “Direct least-squares fitting of algebraic surfaces”, *Computer Graphics*, Vol. 21, pp 145–152 (1987) is used. With closed shapes, the command creates a circle with the same area and centroid of the selection.

24.12.6 Fit Ellipse

Replaces an area selection with the best fit ellipse (see ROI manipulations). The ellipse will have the same area, orientation and centroid as the original selection. The same fitting algorithm is used to measure the major and minor axis lengths and angle when *Fit Ellipse* is selected in *Analyze*›*Set Measurements*…

See also: *DrawEllipse macro*

24.12.7 Convex Hull

Replaces a polygon of freehand selection with its convex hull (see ROI manipulations), determined by the gift wrap algorithm. The convex hull can be thought of as a rubber band wrapped tightly around the points that define the selection.

See also: *Fit Ellipse, ConvexitySolidarity macro, Convex_Hull_Plus plugin*

24.12.8 Make Inverse

Creates an inverse selection (see ROI manipulations). What is ‘inside’ the selection will be ‘outside’, and vice versa.

24.12.9 Create Mask

Creates a new 8-bit image called ‘Mask’ whose pixels have a value of 255 inside the selection and 0 outside (see ROI manipulations). By default, this image has an inverting LUT, so black is 255 and white is 0 unless *Black Background in *Process*›*Binary*›*Options*… is checked.

See also: *Process*›*Binary*›*Convert to Mask, XX Creating Binary Masks, XXI Interpreting Binary Images*

24.12.10 Create Selection

Creates a selection from a thresholded image or a binary mask [13].

24.12.11 Properties… [y]

Opens a dialog box that allows the user to assign a contour color (Stroke Color) and a contour width (Width) to the active selection or a filling color. Note that selections can be either filled or contoured, but not both.

The nine default selection colors (black, blue, cyan, green, magenta, orange, red, white, yellow) can be typed textually. Any other color must be typed using hex notation (see *XIX Hexadecimal Color Values*).

With text selections (see *Text Tool*), it is also possible to specify the font size and text alignment. Note that while this command can only be applied to the active selection, the ROI Manager’s *Properties*… command (Analyze›Tools›ROI Manager…) can be applied to multiple ROIs.

See also: *Selections, Image*›*Overlay*›*Add Selection… [b]*

24.12.12 Rotate…

Rotates the selection by the specified number of degrees (negative number indicate counter-clockwise rotation). This command runs the *RotateSelection macro* in *ij.jar*.

See also: *FlipSelection macro*

24.12.13 Enlarge…

Grows an area selection by a specified number of pixels. Enter a negative value to shrink the selection. This command runs the *EnlargeSelection macro* in *ij.jar*. *ShrinkSelection* is a variation of this macro that does not shrink from the image edges.

XIII CONVERTING COMPOSITE SELECTIONS

Enter zero in the *Edit*›*Selection*›*Enlarge…* dialog box to convert a composite selection into a polygon selection. Note, however, that the conversion may fail if the composite ROI is composed of more than one piece and/or contains internal holes.

24.12.14 Make Band…

Takes an area selection and creates a band with a thickness of the specified number of pixels (see ROI manipulations). If you imagine the band as a doughnut shape, then the original selection corresponds to the hole (i.e. the band is made by growing out the original selection).

See also: *MakeSelectionBand, the macro that implemented this command in previous IJ versions.*
24.12.15 Specify...

Opens a dialog that allows the user to define a rectangular or elliptical selection. **Width** and **Height** are the dimensions of the selection. **X Coordinate** and **Y Coordinate** define the position of the selection. Check **Oval** to create an elliptical selection. If **Centered** is checked, the selection is positioned so **X Coordinate** and **Y Coordinate** define the center of the selection, otherwise they define the upper left corner. This command is also available through the ROI Manager **More** dropdown menu (see **Analyze** > Tools > ROI Manager...).

24.12.16 Straighten...

This command straightens a curved object in an image. The curved object must first be outlined using the segmented line tool. Use the **Image** > **Adjust** > **Line Width**... widget, opened by double clicking on the line tool icon, to adjust the width of the line selection. Check **Spline Fit** in the **Line Width** widget to fit a cubic spline curve to the points that define the line. With ImageJ 1.44k and later, it is not necessary to check the status of the **Spline Fit** checkbox since **Edit** > **Selection** > **Straighten**... will assess if the line has already been prepared for straightening by a `run("Fit Spline", "straighten")` call. Drag the points along the line selection to reposition them. Alt-click on a point to delete it. Shift-click on a point to duplicate it. Press `d` (**Edit** > **Selection** > **Restore Selection [E]**) to restore accidentally deleted lines. **Straighten**... also works with straight line selections. In this case, the object defined by the line selection is rotated to be horizontal.

24.12.17 To Bounding Box

Converts a non-rectangular selection to the smallest rectangle that completely contains it.

24.12.18 Line to Area

Converts a line selection to an area (traced) ROI. Straight lines must be wider than one pixel.

24.12.19 Area to Line

Converts a non-composite area selection to its enclosing outline (see ROI manipulations). The obtained line will have the width specified in the **Image** > **Adjust** > **Line Width**... widget. Note that by design **Area** > **Line** does not create closed paths. E.g., the converted outline of a rectangular selection will be composed of only three segments, with the first and fourth corner points of the rectangle being disconnected.

**SEE ALSO**: Composite Selections, Line to Area

24.12.20 Add to Manager [t]

Adds the current selection to the ROI Manager (**Analyze** > Tools > ROI Manager...). If there is no selection the ROI Manager is open.

24.13 Options

Use commands in this submenu to change various ImageJ user preference settings.

24.13.1 Line Width...

Displays a dialog box that allows to change the line width (in pixels) of line selections (see **Line Selection Tools**) and concomitantly the lines generated by the **Edit** > **Draw** [i] command. This legacy command has been superseded by the **Image** > **Adjust** > **Line Width**... widget, but required since the later is not recordable (see **Plugins** > **Macros** > **Record**...).

24.13.2 Input/Output...

**JPEG quality (0–100)** Specifies the compression level used by **File** > **Save As** > **Jpeg**... Requesting a higher degree of compression (a lower value) will result in smaller files, but poorer image quality. Note that lossy JPEG compression creates serious artifacts, see **II Image Types: Lossy Compression and Metadata**.

**GIF and PNG transparent index** Specifies the transparent color used for images saved in GIF and PNG formats. Use -1 for "none". Note that PNG and GIF transparency only works with 8-bit images.

**File extension for tables** Sets the default extension to be used when saving tables (see Results Table). Files with .txt and .xls extensions are saved in tab-delimited format and files with .csv extensions are saved in comma-delimited format.
Use JFileChooser to open/save Enables versions of File > Open and File > Save As that use the Java JFileChooser instead of the native OS file open and save dialogs. The main advantage of JFileChooser is the ability to open multiple files by shift-clicking to select multiple contiguous files and control-clicking to select more than one individual file. On the other hand, it is slower, uses more memory, and does not behave like the file open and save dialogs used in other applications.

Save TIFF and raw in intel byte order Specifies the byte order used when saving 16-bit and 32-bit images using File > Save As > Raw Data... or File > Save As > Image Sequence... when Raw is chosen as the format. Check this option to export images using the order used by Intel x86 based processors (little-endian). This Wikipedia article has more information.

Results Table Options Specifies if column headers and row numbers should be saved or copied from ImageJ tables such as the Results and Summarize windows (see Results Table).

24.13.3 Fonts...

Opens a small window with three pop-up menus for specifying the type face, size, style and antialiasing (Smooth checkbox) of the font used by the Text Tool and Image > Stacks > Label...

It is also possible to adjust the horizontal text alignment using the style drop-down menu: Left (the default), Right, or Centered. The widget is more easily opened by double clicking on the Text Tool.

24.13.4 Profile Plot Options...

Use this dialog to control how plots generated by ImageJ are displayed (Image > Stacks > Plot Z-axis Profile..., Analyze > Plot Profile [k], Analyze > Calibrate..., Analyze > Tools > Curve Fitting..., Multi Plot [Analyze > Tools > ROI Manager...], etc.).

Plot Width and Plot Height Specify the length (in pixels) of the X-axis (Plot Width) and Y-axis (Plot Height).

Fixed y-axis Scale If checked, the Y-axis range is fixed and the specified Minimum Y and Maximum Y values are used, otherwise, plots are scaled based on the minimum and maximum gray values.

Do not Save x-values If checked, ‘List’, ‘Save...’ and ‘Copy...’ buttons will appear in profile plot windows.

Auto-close If checked, profile plot windows will be automatically closed when ‘List’, ‘Save’ and ‘Copy’ are clicked on.

Vertical Profile If checked, row average plots of rectangular areas (or line selections wider than 1 pixel) will be generated instead of the default column average plots. Note that invoking Plot Profile [k] with will generate vertical profiles.

List values If checked, the list of values will be automatically opened. If Auto-close is also checked, the plot is closed and only the list of values remains open.

Interpolate line profiles If checked, profile values will be interpolated along the line selection

Draw grid lines If checked, gray grid lines will be drawn in the plot.


24.13.5 Rounded Rect Tool...

See Rounded Rectangular Selection Tool.

24.13.6 Arrow Tool...

See Arrow Tool.

24.13.7 Point Tool...

See Point Tool.

24.13.8 Wand Tool...

See Wand Tool.

24.13.9 Colors...

Displays a dialog box that allows you to set Foreground Color, Background Color and Selection Color.

See also: Color Picker, Image > Color > Color Picker... [k], Point Tool

24.13.10 Appearance...

This dialog contains options that control how images are displayed, an option to display better looking toolbar icons, and an option to set the menu font size.

Interpolate zoomed images Uses interpolation instead of pixel replication when displaying zoomed images.

Open Images at 100% Newly open images are displayed using 100% magnification (1 image pixel = 1 screen pixel).

Black Canvas Causes the image canvas (white by default) to be rendered in black. This is useful when looking at X-ray images in order to avoid high contrasting intensities at the image edges.
**No image border** Displays images without the default one pixel wide black border.

**Use inverting lookup table** Causes newly opened 8-bit images to have inverted pixel values, where white= 0 and black= 255. This is done by both inverting the pixel values and inverting the LUT. Use the Images ▷ Lookup Tables ▷ Invert LUT command to invert an image without changing the pixel values.

**Double Buffer Selections** Reduces flicker when working with complex selections but it also increases memory usage and slows screen updates. It is not needed on Mac OS X, which has built in double buffering.

**Antialiased tool icons** Smooths and darkens the tool icons in the ImageJ window. This option is enabled by default on all operating systems. On Windows XP, enable Clear Type sub-pixel anti-aliasing to improve the quality of text in menus.

**Menu font size** Specifies the size of the ImageJ window menu font. Use a size of 0 (zero) to use Java’s default menu font size. Changing the font size requires the restarting of ImageJ. This option is ignored on Mac OS X.


24.13.11 **Conversions...**

Use this dialog to set options that control how images are converted from one type to another.

**Scale When Converting** ImageJ will scale from min-max to 0-255 when converting from 16-bit or 32-bit to 8-bit or to scale from min-max to 0-65535 when converting from 32-bit to 16-bit. Note that Scale When Converting is always checked after ImageJ is restarted.

**Weighted RGB Conversions (0.30, 0.59, 0.11)** When checked, the formula γ = 0.299 × red + 0.587 × green + 0.114 × blue is used to convert RGB images to grayscale. If it is not checked, the formula γ = (red + green + blue)/3 is used. The default weighting factors (0.299, 0.587, 0.114), which are based on human perception, are the ones used to convert from RGB to YUV, the color encoding system used for analog television. The weighting factors can be modified using the `setRGBWeights()` macro function.

24.13.12 **Memory & Threads...**

Use this dialog to specify the maximum amount of memory available to ImageJ and the number of threads used by filters when processing stacks. Java applications such as ImageJ will only use the memory allocated to them (typically 640MB) but this dialog allows the user to allocate more than the default.

Note that specifying more than 75% of real RAM could result in virtual RAM being used, which may cause ImageJ to become slow and unstable. Also note that this dialog cannot be used to set the memory allocation if ImageJ is run from the command line or by double clicking on ij.jar.

**Maximum memory** 64-bit OS and a 64-bit version of Java are required to use more than 1700MB of memory. Windows users must be running a 64-bit version of Windows and must install a 64-bit version of Java. Mac users must be running OS X 10.5 or later and may need to use the Java Preferences utility in Applications ▷ Utilities ▷ Java to select a 64-bit version of Java. They may also need to switch to the ImageJ64 application. Linux users need to be running 64-bit versions of Linux and Java. The title of the Memory & Threads dialog box changes to Memory (64-bit) when ImageJ is running on a properly configured 64-bit system.

**Parallel threads for stacks** Defaults to the number of available processors determines the number of parallel threads used by commands in the Process ▷ Filters... and the Process ▷ Math... submenus when processing stacks.

**Keep multiple undo buffers** If checked, the undo buffer will be preserved when switching images. Edit ▷ Undo [z] remains restricted to the most recent operation, but is available for each opened image, as long as the buffer allows it. If Keep multiple undo buffers is unchecked, the undo buffer is reset every time the active (frontmost) image changes.

**Run garbage collector on status bar click** If checked, forces the Java garbage collector to run every time the user clicks on the ImageJ status bar, which may help to reclaim unused memory (cf. Status bar).


**See also:** FAQ’s on the ImageJ Documentation Wiki

24.13.13 **Proxy Settings...**

Use this dialog to modify the proxy settings of the Java Virtual Machine. This may be required for ImageJ to connect to the internet in certain machines running behind HTTP proxies. For example, proxy settings may be required to update ImageJ using the Help ▷ Update ImageJ... command or to open the images in the File ▷ Open Samples... submenu.

To use the system proxy settings enable the Or use system proxy settings option (this will set the `java.net.useSystemProxies` property to `true`). To configure your proxy settings manually specify the address of the HTTP proxy in `Proxy server` and the port the proxy listens on (normally 8080) in `Port`. Settings will be saved in the ImageJ preferences file (`IJ_Prefs.txt`).

24.13.14 **Compiler...**

Displays a dialog box with options for the Plugins ▷ Compile and Run... command.

**Target** Specifies the Java version of the class files. Plugins compiled with a Target of 1.6 will not run on earlier versions of Java. A Target of 1.4 should be used to create plugins capable of running on all ImageJ versions. Target cannot be set higher than the version of Java ImageJ is currently running on.
**Target** Specifies the Java version of the class files created by Plugins>Compile and Run. Plugins compiled with a Target of 1.6 will not run on earlier version Java. A Target of 1.4 should be used to create plugins capable of running on all versions ImageJ. Target cannot be set higher than the version of Java ImageJ is currently running on.

**Generate Debugging Info (javac -g)** If checked, information needed by Java debuggers will be included in the class files.


---

**24.13.15 DICOM...**

This dialog sets options related to the handling of DICOM images. Namely, if ImageJ should open DICOM images as 32-bit float, if voxel depth should be calculated (based on the distance between the first and last slice) and if coronal/transverse sections should be mirrored when using the Image>Stacks>Orthogonal Views [H] command. With IJ 1.45, the DICOM reader applies the Rescale Slope value when Open as 32-bit float is enabled and tag 0028,1053 is not 1.0.

**See also:** Image Types and Formats

---

**24.13.16 Misc...**

Displays a dialog box containing miscellaneous options.

**Divide by zero value** Specifies the value used when Process>Image Calculator... detects a divide by zero while dividing one 32-bit real image by another. The default is infinity. In addition to numeric values, ‘infinity’ (positive or negative infinity), ‘max’ (largest positive value) and ‘NaN’ (Not-a-Number) can be entered as the Divide by zero value.

**Use pointer cursor** If checked, ImageJ will use an arrow cursor instead of the default cross-hair that is sometimes difficult to see on grayscale images in areas of medium brightness. This option can also be used to work around a bug on Windows where the text cursor is sometimes used in place of the cross-hair.

**Hide "Process Stack?" dialog** If checked, ImageJ will suppress the dialog that asks ‘Process all xx slices?’ (only the current slice will be processed).

**Require control / command key for shortcuts** If checked, requires the Control key (Command key on Macs) to be pressed when using keyboard shortcuts for menu commands.

**Move isolated plugins to Misc. menu** This option can reduce the size of the Plugins menu, preventing it from running off the bottom of the screen. When this option is enabled, plugins that attempt install themselves in a submenu with only one command are instead installed in the Plugins>Miscellaneous submenu. An example of such a plugin is TurboReg, which normally creates a Plugins>TurboReg submenu that contains only one command.

**Run single instance listener** If checked, ImageJ starts each time an image is dragged and dropped on the ImageJ icon. It also prevents multiple instances when running ImageJ from the command line. Note that you may get a security alert the first time ImageJ starts with this option enabled. ImageJ does not require external socket access so it is okay to deny it access in the security alert. This option is set by default with new Windows installations.

**Debug mode** If checked, causes ImageJ to display debugging messages in the Log Window. Close the Log window to disable display of debugging messages.


---

The IJ User Guide — Booklet 36

Latest revision: 2011/12/27
25 Image

25.1 Type

Use this submenu to determine the type of the active image or to convert it to another type. An attempt to perform an unsupported conversion causes a dialog box to be displayed that lists the possible conversions.

Supported conversions in ImageJ (Image > Type > submenu).

<table>
<thead>
<tr>
<th></th>
<th>8-bit</th>
<th>16-bit</th>
<th>32-bit</th>
<th>8-bit color</th>
<th>RGB color</th>
<th>RGB stack</th>
<th>HSB stack</th>
</tr>
</thead>
<tbody>
<tr>
<td>8-bit</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td>I, S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16-bit</td>
<td>I, S</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32-bit</td>
<td>I, S</td>
<td>I, S</td>
<td>...</td>
<td>I, S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8-bit color</td>
<td>I, S</td>
<td>I, S</td>
<td>...</td>
<td>...</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RGB color</td>
<td>I, S</td>
<td>I, S</td>
<td>...</td>
<td>I, S</td>
<td>I, S</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RGB stack</td>
<td>I</td>
<td>...</td>
<td>...</td>
<td>I</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>HSB stack</td>
<td>I</td>
<td>...</td>
<td>...</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

I: Single images only; S: Stacks

8-bit Converts to 8-bit grayscale. ImageJ converts 16-bit and 32-bit images to 8-bit by linearly scaling from min–max to 0–255, where min and max are the two values displayed in the Image > Adjust > Brightness/Contrast...[C]. ImageJ > Show Info...[i] displays these two values as Display range. Note that this scaling is not done if Scale When Converting is not checked in Image > Adjust > Conversions...RGB images are converted to grayscale using the formula gray = (red + green + blue)/3 or gray = 0.299 × red + 0.587 × green + 0.114 × blue if Weighted RGB Conversions is checked in Image > Options > Conversions...

16-bit Converts to unsigned 16-bit grayscale.

32-bit Converts to signed 32-bit floating-point grayscale.

8-bit Color Converts to 8-bit indexed color using Heckbert’s median-cut color quantization algorithm. A dialog box allows the number of colors (2–256) to be specified. The active image must be RGB color.

RGB Color Converts to 32-bit RGB color.

RGB Stack Converts to a 3-slice (red, green, blue) stack. The active image must be RGB color.

HSB Stack Converts to a 3-slice (hue, saturation and brightness) stack. The active image must be RGB color.

25.2 Adjust

This submenu contains commands that adjust brightness/contrast, threshold levels and image size.

25.2.1 Brightness/Contrast [C]

Use this tool to interactively alter the brightness and contrast of the active image. With 8-bit images, brightness and contrast are changed by updating the image’s lookup table (LUT), so pixel values are unchanged. With 16-bit and 32-bit images, the display is updated by changing the mapping from pixel values to 8-bit display values, so pixel pixel values are also unchanged. Brightness and contrast of RGB images are changed by modifying the pixel values.

Histogram The line graph at the top of the window, which is superimposed on the image’s histogram, shows how pixel values are mapped to 8-bit (0–255) display values. The two numbers under the plot are the minimum and maximum displayed pixel values. These two values define the display range, or ‘window’. ImageJ displays images by linearly mapping pixel values in the display range to display values in the range 0–255. Pixels with a value less than the minimum are displayed as black and those with a value greater than the maximum are displayed as white.

Minimum and Maximum sliders Control the lower and upper limits of the display range. Holding down AUTO will simultaneously adjust all channels of a composite image (e.g., File > Open Samples > HeLa Cells (1.3 M, 48-bit RGB)).

Brightness slider Increases or decreases image brightness by moving the display range. Holding down AUTO will simultaneously adjust all channels of a composite image.

Contrast slider Increases or decreases contrast by varying the width of the display range. The narrower the display range, the higher the contrast. Holding down AUTO will simultaneously adjust all channels of a composite image.

Auto ImageJ will automatically optimize brightness and contrast based on an analysis of the image’s histogram. Create a selection, and the entire image will be optimized based on an analysis of the selection. The optimization is done by allowing a small percentage of pixels in the image to become saturated (displayed as black or white). Each additional click on Auto increases the number of saturated pixels and thus the amount of optimization. A run("Enhance Contrast", "saturated=0.35") macro call is generated if the command recorder is running.

Reset Restores the original brightness and contrast settings. The display range is set to the full pixel value range of the image. A reset MinAndMax() macro call is generated if the command recorder is running. Holding down AUTO restores original settings in all channels of a composite image.

Set Allows to enter the minimum and maximum display values in a dialog box. A set MinAndMax() macro call is generated if the command recorder is running. Check...
Propagate to all open images to apply these values to the rest of the images currently open.

A 16-bit image consists of 65,536 possible gray levels. Most of times, however, the relevant image information is contained only within a narrow range of the grayscale. This is the case, e.g., in low light microscopy, in which signal is restricted to the lower end of the grayscale. The Set Display Range dialog allows you to choose how to scale the range of gray levels of 16-bit images.

**Automatic:** Automatically selects the best range given the intensity values of the image based on the percentage of the total number of pixel values from the lowest to highest pixel value.

- **8-bit (0–255):** Gray level range of 0–255.
- **10-bit (0–1023):** Gray level range of 0–1023.
- **12-bit (0–4095):** Gray level range of 0–4095.
- **15-bit (0–32767):** Gray level range of 0–32767.
- **16-bit (0–65535):** Gray level range of 0–65535.

**Apply** Applies the current display range mapping function to the pixel data. If there is a selection, only pixels within the selection are modified. This option currently only works with 8-bit images and stacks and with RGB stacks. This is the only B&C option that alters the pixel data of non-RGB images.

See also: Window/Level... Enhance Contrast, XIV Applying Auto Brightness/Contrast to Entire Stacks, XV Display Range of DICOM Images

### 25.2.2 Window/Level...

This command and Brightness/Contrast... [C] (B&C) are redundant, but Window/Level... (W&L) behaves in a manner closer to that implemented on medical image terminals by interactively adjusting the Window – range of minimum and maximum (Contrast) – and Level – position of that range in the grayscale intensity space (Brightness). If the B&C window is opened, it will be closed and the W&L window will be opened at the same location.

#### XV Display Range of DICOM Images

With DICOM images, ImageJ sets the initial display range based on the Window Center (0028,1050) and Window Width (0028,1051) tags. Click Reset on the W&L (Image\(\rightarrow\)Adjust\(\rightarrow\)Window/Level...) or B&C (Image\(\rightarrow\)Adjust\(\rightarrow\)Brightness/Contrast... [C]) window and the display range will be set to the minimum and maximum pixel values.

As an example, the File\(\rightarrow\)Open Samples\(\rightarrow\)CT (420K, 16-bit DICOM) image has a Window Center of 50 and Window Width of 500, so the display range is set to -200 to 300 (center-width/2 to center-width/2). Click Reset and the display range is set to -719 to 1402. Press [H] (Analyze\(\rightarrow\)Histogram [h]) and you will see that the minimum pixel value in the image is -719 and the maximum is 1402.

To display the DICOM tags, press [I] (Image\(\rightarrow\)Show Info... [i]). Press [R] (File\(\rightarrow\)Revert [r]) to revert to the initial display range.

#### XVI Brightness/Contrast of High Bit-Depth Images

When displayed, the intensity of each pixel that is written in the image file is converted into the grayness of that pixel on the screen. How these intensities are interpreted is specified by the image type. From the ImageJ website:

"16-bit and 32-bit grayscale images are not directly displayable on computer monitors, which typically can show only display 256 shades of gray. Therefore, the data are mapped to 8-bit by windowing. The window defines the range of gray values that are displayed: values below the window are made black, while values above the window are white. The window is defined by minimum and maximum values that can be modified using Image\(\rightarrow\)Adjust\(\rightarrow\)Brightness/Contrast... [C]."

It may happen that the initial windowing performed by ImageJ on these high bit-depth (or HDR) images is suboptimal. Please note that windowing does not affect image data (cf. the HDRexplorerTool).

#### 25.2.3 Color Balance...

This panel makes adjustments to the brightness and contrast of a single color of a standard RGB image (8-bit per color channel). For multi-channels stacks and hyper-stacks it adjusts each of the color channels independently. Use the drop-down menu to specify which color channel will be adjusted (the histogram is drawn for the selected color).

Maximum and Minimum sliders, Auto, Set and Apply work as described for Image\(\rightarrow\)Adjust\(\rightarrow\)Brightness/Contrast... [C]. Similarly to the Window/Level... tool, if the B&C window is opened, it will be closed and the Color window will be opened at the same location.

NB: When switching from one color to another, the changes made to one color will be lost unless Apply
is clicked before. Also, note that for 48-bit color images that load as a stack, Brightness/Contrast... [C] works on single stack slices, i.e., colors, and the color settings of the Color panel are ignored.

See also: Brightness/Contrast... [C], Color ⊗ submenu

25.2.4 Threshold... [T]

Use this tool to automatically or interactively set lower and upper threshold values, segmenting grayscale images into features of interest and background. Use Analyze ⊗ Measure... [m] (with Limit to Threshold in Analyze ⊗ Set Measurements... checked) to measure the aggregate of the selected features. Use Analyze ⊗ Analyze Particles... to measure features individually. Use the WAND Tool to outline a single feature.

Upper slider Adjusts the minimum threshold value. Hold ⇪ while adjusting the minimum to move a fixed-width thresholding window across the range of gray values.

Lower slider Adjusts the maximum threshold value.

Method Allows any of the 16 different automatic thresholding methods to be selected [15]. These methods are described on Fiji’s Auto Threshold website. The Default method is the modified IsoData algorithm used by ImageJ 1.41 and earlier. Note that these are global thresholding methods that typically cannot deal with unevenly illuminated images (such as in brightfield microscopy). In these cases, local algorithms are more appropriate, by allowing the threshold to smoothly vary across the image. These are implemented by the Auto Local Threshold plugin, pre-installed in Fiji.

Display Selects one of three display modes:

Red Displays the thresholded values in red.

B&W Features are displayed in black and background in white. This mode respects the Black background flag set in Process ⊗ Binary ⊗ Options...
Pass If checked, values within range are thresholded and displayed (band-pass filter), otherwise, values outside the selected range are thresholded (band-reject filter).

Thresholding Method Allows any of the 16 different automatic thresholding methods to be selected (cf. Threshold... [T]).

Threshold Color Selects the threshold color: either Red, Black, White or Black & White (cf. Threshold... [T]).

Color space Selects the color space: HSB, RGB, CIE Lab or YUV.

Dark background To be checked when features are lighter than the background. With IJ 1.44i and later, the state of the checkbox is remembered across restarts.

Original Restores the original image and updates the buffer when switching to another image.

Filtered Shows the filtered image.

Select Creates a ROI selection based on the current settings. The selection is made according to the settings defined in the Process > Binary > Options... dialog.

Sample (Experimental) Sets the ranges of the filters based on the pixel value components in a user-defined ROI.

Stack Processes the rest of the slices in a stack (if any) using the current settings.

Macro Creates a macro based on the current settings which is sent to the Macro Recorder window (Plugins > Macros > Record...), if open.

Help Opens Color Threshold...’s built-in help.

See also: 3D Color Inspector / Color Histogram

25.2.6 Size... Scales the active image or selection to a specified Width and Height in pixels.

Check Constrain aspect ratio and ImageJ will adjust either the Height or the Width to maintain the original aspect ratio. When applicable, other dimensions can also be resized: Depth (images) in stacks, Depth (slices) and Time (frames) in hyperstacks.

Check the Average when downsizing checkbox for better results when scaling down images [16]. Two resampling methods are possible: Bilinear and Bicubic interpolation. The implementation of the bicubic method (Catmull-Rom interpolation) is derived from Burger and Burve, 2008 [51].

See also: Image > Scale... [E]
25.4 Properties... [P]

Use this command to display and set various properties of the current image or stack.

The number of Channels (c), Slices (z) and Frames (t) in the image can be changed as long as the product of \(c \times z \times t\) is equal to the number of images in the stack.

The Unit of Length (a string describing the measuring unit), Pixel Width, Pixel Height and Voxel Depth (all in the Unit of Length unit) can be set.

Width, Height and Depth are automatically converted if Unit of Length is changed from one known unit ('nm', 'um', 'µm', 'micron', 'mm', 'cm', 'meter', 'km' or 'inch') to another. With t–series stacks, the Frame Interval in seconds (reciprocal of the frame rate) can be viewed and set.

Since IJ 1.43, setting the Frame Interval sets the frame rate used by Animation Options... [Alt/] as long as the unit used is 'sec'.

Origin (always in pixels) is the reference point (0, 0) of the image coordinate system (see also Analyze ⊗ Set Measurements...).

Check Global to make the current settings global (i.e., apply to all images opened during the current session, cf. XXII Global Calibrations).

See also: Image ⊗ Show Info... [i], Image ⊗ Scale... [E], Analyze ⊗ Set Scale...

25.5 Color ⊗

This submenu contains commands that deal with color images.

25.5.1 Split Channels

Splits an RGB image (or stack) into three 8-bit grayscale images containing the red, green and blue components of the original. The window names have an appended (red), (green) and (blue). With composite images and/or hyperstacks (e.g., File ⊗ Open Samples ⊗ Organ of Corti (2.8M, 4D stack)) this command splits the stack into separate channels.

See also: Merge Channels...
25.5.7 Edit LUT...

Opens the ImageJ LUT (Lookup Table) Editor. A lookup table in ImageJ has up to 256 entries. The entry index, and the three values (red, green and blue) associated with it, are displayed in the ImageJ status bar as you move the cursor over the LUT Editor window. Click on an entry to edit the red, green and blue values for that entry using a Color Selector window (cf. Color Picker... [K]).

See also: Show LUT

25.5.8 Color Picker... [K]

The Color Picker tool [14] enables the user to select foreground and background colors, which affect Edit > Fill [f], Edit > Draw [d] and other color drawing commands. It displays current foreground and background colors in the selection boxes at the bottom of the window. It has two modes: Foreground and Background. To change modes, click on the desired selection box. Clicking on the Foreground/Background Switcher button sets the current foreground to the background and vice versa. The Black/White Reset button sets the foreground to black and the background to white.

The Color Picker... [K] tool.

The color palette is based on HSB (Hue, Saturation and Brightness) color model. Hue increases as you go down the palette while saturation and brightness values are split horizontally. The left half of the palette varies only in brightness while the right half varies only in saturation. At the center of the color ramp are enlarged red, green, blue, cyan, magenta, and yellow colors for quick selection. To the left of the color palette is a grayscale ramp that goes from pure black to pure white.

Double clicking on a color brings up one of the Color Selectors, shown on the right in the illustration. Use the sliders to specify the RGB values of the foreground or background color. To get precise colors, manually change the values in the text boxes. The title of the Color Selector window (Foreground Color or Background Color) indicates the current selection mode.

25.6 Stacks

This submenu contains commands that work with stacks.

25.6.1 Add Slice

Inserts a blank slice after the currently displayed slice (stacks) or channel (composite images). Holding ⌘ insert a blank slice before the current slice/channel.

25.6.2 Delete Slice

Deletes the currently displayed slice/channel.

25.6.3 Next Slice [>

Displays the slice that follows the currently displayed slice. Holding ⌘ will skip nine slices forward.

See also: Arrow Keys

25.6.4 Previous Slice [<]

Displays the slice that precedes the currently displayed slice. Holding ⌘ will skip nine slices backward.

See also: Arrow Keys

25.6.5 Set Slice...

Displays a specified slice. The user must enter a slice number greater than or equal to one and less than or equal to the number of slices in the stack.

See also: XVII Embedding Color Annotations in Grayscale Images, Draw [d], Fill [f], Clear, Clear Outside, Image Types and Formats

XVII EMBEDDING COLOR ANNOTATIONS IN GRAYSCALE IMAGES

Color marks are only available with color images or grayscale images that have been converted to RGB (Image > Type > submenu). For non-RGB images, background/foreground color will be drawn in equivalent gray levels, e.g.: For a 8-bit image, if the foreground color is red (RGB: 255, 0, 0) intensity of drawn selections will be (255 + 0 + 0) / 3 = 85.

Colored overlays (see Image > Overlay >), on the other hand, can be created on all image types becoming the easiest way to annotate grayscale images.
25.6.6 Images To Stack

Creates a new stack from images currently displayed in separate windows.

**Method** If images differ in size, a drop-down menu allows to choose a conversion method:

- **Copy (center)** and **Copy (top-left)**
  - Stack will have the width of the widest open image and the height of the highest open image. Smaller images will then be copied (either to the center or to the upper left corner) of the slice. Borders are filled with pixels that have a value of zero.

- **Scale (smallest)** and **Scale (largest)**
  - Stack will have the dimensions of the smallest/largest open image. Other images are scaled to the new slice dimensions. Bicubic interpolation is used if **Bicubic interpolation** is checked (cf. Images>Size... and Image>Scale... [E]).

**Name** Specifies the title of the stack to be created.

**Title Contains** Enter a string into this field and ImageJ will only convert to stack images whose name contains that string.

**Bicubic Interpolation** If checked, bicubic interpolation (cf. Adjust>Size...) will be used if any of the Scale methods was previously chosen.

**Use Title as Labels** If checked, image titles (without extension) will be used as stack labels. As described in Stacks>Tools>Remove Slice Labels, these labels (up to 60 characters) correspond to the image subtitle, the line of information above the image. These labels are part of the stack metadata, typically created by File>Import>Image Sequence... or Stacks>Images To Stack. If no slice metadata exists (the setMetadata("Label", string) macro function can be used to customize slice labels) images are labelled with slice numbers. Note that the Stacks>Label... command can be used to draw labels in stack slices.

**Use Foreground Color** If checked, borders and labels are drawn in the foreground color and blank areas of the panel are filled with the background color.

See also: Stacks>Tools>Montage to Stack..., Stacks>Tools>Remove Slice Labels, RC Montage plugin, Magic Montage — a macro toolset to reorder and manipulate images in the montage (a video tutorial can be found here)

25.6.7 Stack To Images

Converts the slices in the current stack to separate image windows.

See also: Stacks>Images To Stack

25.6.8 Make Montage

Produces a single image which contains the images from a stack displayed in a grid format. This can be useful for visual comparisons of a series of images stored in a stack and to create 'panel figures'. With hyperstacks - that are not directly supported --, instructions are displayed that explain how to create c, z or t montages. A dialog box allows you to specify the magnification level at which the images are copied, and to select the layout of the resulting grid.

Reconstructs one or more orthogonal slices through the image volume represented by the current stack or hyperstack [18].

The estimated size of the output stack and the amount of available memory are displayed at the bottom of the dialog. Increase Output spacing to reduce the size of the output stack.

A dialog allows you to specify the spacing of the reconstructed slices.

**Output spacing** Determines the number of orthogonal slices that will be reconstructed. Increasing Output spacing reduces the size of the output stack.

**Start at** Determines the image edge (top, left, bottom or right) from which reconstruction starts. Start at is replaced by Slice count if there is a line selection. With lines selections, a stack is created by shifting (by Output spacing) the line down and to the left to generate additional
slices for the output stack. In this case, the size of the output stack is determined by Slice count.

**Flip vertically** If checked, each slice in the output stack will be flipped vertically.

**Rotate 90 degrees** If checked, each slice in the output stack will be rotated 90°.

**Avoid interpolation** If checked, no interpolation will be done.


**SEE ALSO:** Dynamic Reslice and Radial Reslice plugins

**25.6.10 Orthogonal Views [H]**

Provides an orthogonal view display of the current stack or hyperstack [19]. E.g., if a stack displays sagittal sections, coronal (YZ projection image) and transverse (XZ projection image) will be displayed through the data-set.

The two extra planar views are displayed in ‘sticky’ panels next to original image and can be toggled using the command Shortcut, the command shortcut.

The intersection point of the three views follows the location of the mouse click and can be controlled by clicking and dragging in either the XY, XZ or YZ view. XY and XZ coordinates are displayed in the title of the projection panels. The mouse wheel changes the screen plane in all three views. Voxel dimensions can be adjusted in Image Properties... [P].

**SEE ALSO:** 3D Project... and 3D Viewer [13], Volume Viewer, Stack Slicer Display3_TP plugins, Edit>Options>DICOM...

**25.6.11 Z Project...**

Projects an image stack along the axis perpendicular to image plane (the so-called z axis) [18]. With hyperstacks, the projection s performed on the active time frame, or for all time points if All Time Frames is checked. Five different projection types are supported. The preferred projection method is stored in the preferences file.

**Average Intensity** projection outputs an image wherein each pixel stores average intensity over all images in stack at corresponding pixel location.

**Maximum Intensity** projection (MIP) creates an output image each of whose pixels contains the maximum value over all images in the stack at the particular pixel location.

**Sum Slices** projection creates a real image that is the sum of the slices in the stack.

**Standard Deviation** projection creates a real image containing the standard deviation of the slices.

**Median** projection outputs an image wherein each pixel stores median intensity over all images in stack at corresponding pixel location.

**SEE ALSO:** Grouped Z Project..., 3D Project..., Plot Z-axis Profile...

**25.6.12 3D Project...**

This command creates a sequence of projections of a rotating volume (stack or hyperstack) onto a plane using nearest-point (surface), brightest-point, or mean-value projection or a weighted combination of nearest point projection with either of the other two methods (partial opacity) [20]. The user may choose to rotate the volume about any of the three orthogonal axes (x, y, or z), make portions of the volume transparent (using thresholding), or add a greater degree of visual realism by employing depth cues.

Each frame in the animation sequence is the result of projecting from a different viewing angle. To visualize this, imagine a field of parallel rays passing through a volume containing one or more solid objects and striking a screen oriented normal to the directions of the rays.

Each ray projects a value onto the screen, or projection plane, based on the values of points along its path. Three methods are available for calculating the projections onto this plane: nearest-point, brightest-point, and mean-value. The choice of projection method and the settings of various visualization parameters determine how both surface and interior structures will appear.

**Projection Method** Select Nearest Point projection to produce an image of the surfaces visible from the current viewing angle. At each point in the projection plane, a ray passes normal to the plane through the volume. The value of the nearest non-transparent point which the ray encounters is stored in the projection image. Brightest Point projection examines points along the rays, projecting the brightest point encountered along each ray. This will display the brightest objects, such as bone in a CT (computed tomographic) study. Mean Value projection, a modification of brightest-point projection, sums the...
values of all transparent points along each ray and projects their mean value. It produces
images with softer edges and lower contrast, but can be useful when attempting to visualize
objects contained within a structure of greater brightness (e.g. a skull).

**Slice Spacing** The interval, in pixels, between the slices that make up the volume. ImageJ
projects the volume onto the viewing plane at each Rotation Angle Increment, beginning
with the volume rotated by Initial Angle and ending once the volume has been rotated by
Total Rotation.

**Lower / Upper Transparency Bound** Determine the transparency of structures in the volume.
Projection calculations disregarded having values less than the lower threshold
or greater than the upper threshold. Setting these thresholds permits making background
points (those not belonging to any structure) invisible. By setting appropriate thresholds,
you can strip away layers having reasonably uniform and unique intensity values and
highlight (or make invisible) inner structures. Note that you can also use Image>Adjust>Threshold... [T] to set the transparency bounds.

**Opacity** Can be used to reveal hidden spatial relationships, specially on overlapping objects of
different colors and dimensions. The (surface) Opacity parameter permits the display of
weighted combinations of nearest-point projection with either of the other two methods,
often giving the observer the ability to view inner structures through translucent outer
surfaces. To enable this feature, set Opacity to a value greater than zero and select either
Mean Value or Brightest Point projection.

**Surface / Interior Depth–Cueing** Depth cues can contribute to the three-dimensional qual-
ity of projection images by giving perspective to projected structures. The depth-cueing
parameters determine whether projected points originating near the viewer appear brighter,
while points further away are dimmed linearly with distance. The trade-off for this in-
creased realism is that data points shown in a depth-cued image no longer possess accurate
densitometric values. Two kinds of depth-cueing are available: Surface Depth-Cueing and
Interior Depth-Cueing. Surface Depth-Cueing works only on nearest-point projections
and the nearest-point component of other projections with opacity turned on. Interior
Depth-Cueing works only on brightest-point projections. For both kinds, depth-cueing is
turned off when set to zero (i.e. 100% of intensity in back to 100% of intensity in front) and
is on when set at 0 < a 100 (i.e. (100–a)% of intensity in back to 100% intensity in front). Having independent depth-cueing for surface (nearest-point) and interior (brightest-point)
allows for more visualization possibilities.

**Interpolate** Check Interpolate to generate a temporary z-scaled stack that is used to generate
the projections. Z-scaling eliminates the gaps seen in projections of volumes with slice
spacing greater than 1.0 pixels. This option is equivalent to using the Scale plugin from the
TransformJ package to scale the stack in the z-dimension by the slice spacing (in pixels).
This checkbox is ignored if the slice spacing is less than or equal to 1.0 pixels.

See also: Orthogonal Views [H], Z Project... , Grouped Z Project... and 3D Viewer [13], Volume
Viewer plugins

---

### 25.6.13 Plot Z-axis Profile...

Plots the ROI selection mean gray value versus slice number. Requires a point or area selection.
Coordinates of the upper left corner of the selection (or the bounding rectangle for non-
rectangular selections) are displayed in the graph title.

See also: Profile Plot Options... , Plot Profile [K]

---

### 25.6.14 Label...

Adds a sequence of numbers (e.g., timestamps) and/or a label
to a stack or hyperstack. Numbers and label are drawn in the
current foreground color (cf. Image>Colors>Color Picker... [K]).
The initial X, Y location, and Font size of the label are based on the existing rectangular selection, if any. Slices outside the Range are not affected.

**Format** Specifies the structure of the label. 0: Unpaddled sequence; 0000: Pads each number with leading zero(s); 00:00: Converts the label into a minutes:seconds timestamp; 00:00:00: Converts the label into a hours:minutes:seconds timestamp; Text: Stamps only the contents of the Text field.

**Starting value and Interval** Specify the first value and the numeric steps to be applied.
Note that with timestamps, metric time values must be used, e.g., an Interval of 3600 will
create 1 hour increments.

**Text** The string to be drawn after each number when the Format chosen is either 0 or Text
(label without numeric sequence).

**Use overlay** If checked, labels will be created as non-destructive image overlays. Note that
previously added overlays will be removed.

**Use text tool font** If checked, labels will be created using the type face and style specified in
the Fonts... widget.


See also: Make Montage, Stacks>Tools>Insert...
25.6.15 Tools

25.6.15.1 Combine...
Combines two stacks \([\text{Width} \times \text{Height} \times \text{Depth}]\) \((W_1 \times H_1 \times D_1)\) and \((W_2 \times H_2 \times D_2)\) to create a new \((W_1 + W_2 \times \max(H_1, H_2) \times \max(D_1, D_2))\) stack. E.g., a 256\(\times\)256\(\times\)40 and a 256\(\times\)256\(\times\)30 stack would be combined to create one 512\(\times\)256\(\times\)40 stack.

If Combine vertically is enabled, creates a new \(\max(W_1 + W_2) \times (H_1 + H_2) \times \max(D_1, D_2)\) stack.

Unused areas in the combined stack are filled with background color (cf. Color Picker... [K]).

See also: Concatenate...

25.6.15.2 Concatenate...
Concatenates two images or stacks that have the same width, height and data type.

See also: Combine...

25.6.15.3 Reduce...
Reduces the size of stacks and hyperstacks by the specified Reduction Factor. E.g., For a 30 slices stack and a Reduction Factor of 2, the reduced stack will be be composed of 15 slices with every second slice being removed. Virtual stacks/hyperstacks are supported. With Hyperstacks, the default reduction is performed in the T-Dimension, but a choice is available to Reduce in Z-Dimension instead.

See also: Hyperstacks> Reduce Dimensionality...

25.6.15.4 Reverse
Alias for the Image>Transform>Flip Z command.

25.6.15.5 Insert...
Inserts an image or stack into a stack at the specified X and Y Location. The Source Image or Stack must be of the same type as the Destination Stack.

See also: Image>Stacks>Label...

25.6.15.6 Montage to Stack...
Converts a montage image to an image stack based on the specified number of rows and columns, taking into account a Border width.

This is the opposite of what the Image>Stacks>Make Montage command does.

See also: Demontager plugin

25.6.15.7 Make Substack...
Extracts selected images from the active stack copying them to a new stack in the order of listing or ranging [21].

It takes one of three types of input: 1) a range of images (e.g. 2–14 [extract slices 2 through 14]); 2) a range of images with increment (e.g. 2–14–2 [extract slices 2 and 14 and every second slice in between]) or 3) a list of images (e.g. 2,4,7,9,14).

Extracted slices will be removed from the source stack if Deleted slices from original stack is checked. Currently, it does not work with hyperstacks.

See also: Image>Duplicate... [D]

25.6.15.8 Grouped Z Project...
Creates a substack of Stack size/Groupsize slices with each slice being the result of a Z Projection performed over the range of Groupsize. Groupsize must divide evenly into the stack size.

See also: Image>Stacks>Z Project...

25.6.15.9 Remove Slice Labels
Removes slice labels from stacks. The first line of a slice label (up to 60 characters) is displayed in parentheses in the image subtitle, the line of information above the image. The macro functions setMetadata("Label", string) and getMetadata("Label") can be use to set and retrieve the current slice label.

See also: Stacks>Label...

25.6.15.10 Start Animation [\]
Animations the active stack by repeatedly displaying its slices (frames) in sequence. It is run more easily by clicking on the play icon preceding stack sliders (see Stacks). To stop the animation, click on the slider pause icon, click on the image or use Stop Animation [], evoked by the same
shortcut. As such, stacks animation can be toggled using $\text{F}10$. The frame rate is displayed in the status bar. Open the Animation Options... $\text{[Alt/]}$ dialog box to specify the animation speed (pressing $\text{F}10$ or right-clicking on the on the slider play/pause icon opens the Animation Options... dialog). Note that more than one stack can be animated at a time.

25.6.15.11 Stop Animation $\text{[\]}$

Terminates animation of the active stack (see Start Animation $\text{[\]}$).

25.6.15.12 Animation Options... $\text{[Alt/]}$

Use this dialog to set the animation speed in frames per second, the starting and ending frame, or to enable ‘oscillating’ animations. Selecting Start Animation animates the stack as soon as the dialog is dismissed.

Note that setting the Frame Interval in Image $\text{⊿}$ Properties... $\text{[P]}$ sets the animation speed as long as the unit used is ‘sec’.

This dialog can also be accessed by right-clicking on the play/pause icon that precedes the slice slider in Stacks and frame slider in Hyperstacks (see Stacks and Hyperstacks).

See also: File $\text{⊿}$ Save As $\text{⊿}$ Gif... $\text{⊿}$ AVI...

25.7 Hyperstacks $\text{⊿}$

This submenu contains commands that work with Hyperstacks, images that have four (4D) or five (5D) dimensions.

25.7.1 New Hyperstack...

Creates a new hyperstack. Hyperstacks have Width, Height, Channels (c dimension), Slices (z dimension) and time Frames (t dimension).

Image Type (see Image $\text{⊿}$ Type $\text{⊿}$) and Display Mode (see Channels Tool... $\text{[Z]}$) can be specified.

Checking Label Images will draw the channel number, slice number and frame number on each image in the hyperstack.

File $\text{⊕}$ New $\text{⊕}$ Hyperstack... is an alias of this command.

25.7.2 Stack to Hyperstack...

Converts a stack into a hyperstack. RGB stacks are converted into 3 channel hyperstacks. Order is the order of the channels (c), slices (z) and frames (t) within the stack. ImageJ hyperstacks are always in czt order. Stacks not in czt order will be shuffled to be in czt order. The channel Display Mode can be Composite, Color or Grayscale (cf. Channels Tool... $\text{[Z]}$).

See also: Hyperstack to Stack

25.7.3 Hyperstack to Stack

Converts a hyperstack into a stack (in czt order).

See also: Stack to Hyperstack...

25.7.4 Reduce Dimensionality...

This command $\text{[Z]}$ reduces the dimensionality of an hyperstack by creating a new hyperstack with, for example, all the channels and time points at a given z position or all the z slices for the current channel and time point.

Uncheck Channels (n) to delete all but the current channel, Slices (n) to delete all but the current z slice and Frames (n) to delete all but the current time point. Check Keep Source and the original stack will not be deleted.

The expected dimensions and size of the reduced stack are displayed in the dialog.

See also: Hyperstack to Stack

25.7.5 Channels Tool... $\text{[Z]}$

Opens the Channels... widget, or brings it to the front if it is already open. $\text{Ctrl}+\text{F}10$ is the keyboard shortcut for this command. This tool allows to select the Display mode of composite images. In addition, several commands hosted in the Image $\text{⊿}$ Color $\text{⊿}$ submenu can easily be accessed through the More... drop-down menu. The same drop-down menu also provides a convenient list of primary colors (additive: red, green and blue, subtractive: cyan, magenta, yellow) that can be used to pseudocolor composite channels. Composite images are discussed with more detail in Color Composites.

25.8 Crop $\text{[X]}$

Crops the image or stack based on the current rectangular selection.
Channel manipulations in composite images using the **Image > Color > Channels** tool.

### 25.9 Duplicate... [D]

Creates a new window containing a copy of the active image or rectangular selection. For stacks and hyperstacks it is possible to specify the range of **Channels (c)**, **Slices (z)** and **Frames (t)** to be duplicated.

With single images, hold **Alt** to skip the dialog box.

### 25.10 Rename...

Renames the active image.

### 25.11 Scale... [E]

Resizes the image or current area selection by scale factors entered into a dialog box. As with **Image > Size...**, two resampling methods are possible: **Bilinear** and **Bicubic** interpolation.

For the best looking results, particularly with graphics and text, use integer scale factors (2, 3, 5, etc.) and check **Average when downsizing** with scale factors less than 1.0 [16]. Also, when downsizing, smoothing the source image prior to scaling may produce better looking results.

Scalable images can be copied to a new image named **Title** if **Create new window** is checked. If scaling a selection that will not be copied to a new image check **Fill with Background Color** to fill with the background color instead of zero.

Entire stacks (or hyperstacks in the Z Dimension) will be scaled if **Process entire stack** is checked.

### 25.12 Transform...

This submenu contains commands that perform geometrical image transformation on the active image or stack.

#### 25.12.1 Flip Horizontally

Replaces the image or selection with a x-mirror image of the original.

#### 25.12.2 Flip Vertically

Turns the image or selection upside down (y-mirror).

#### 25.12.3 Flip Z

Reverses the order of the slices in a stack (z-mirror).

#### 25.12.4 Rotate 90 Degrees Right

Rotates the entire image or stack clockwise 90°.

#### 25.12.5 Rotate 90 Degrees Left

Rotates the entire image or stack counter-clockwise 90°.

#### 25.12.6 Rotate...

Use this dialog to rotate the active image or selection clockwise the specified number of degrees.

Set **Grid Lines** to a value greater than zero to superimpose a grid on the image in **Preview** mode. Two resampling methods are possible: **Bilinear** and **Bicubic** interpolation (cf. **Image > Size...**).

With 8-bit and RGB images, check **Fill with Background Color** to fill with the background color instead of zero (cf. **Color Picker...** [K]). Check **Enlarge to Fit Result** and the image will be enlarged as needed to avoid clipping.

#### 25.12.7 Translate...

Translates (moves) the image in the x and y directions by a specified number of pixels. With stacks, you can translate either the current image or all the images in the stack. Two resampling methods are possible: **Bilinear** and **Bicubic** interpolation (cf. **Image > Size...**).

Check **Preview** to see how the translation will affect the image. The background at the edges of the image will be set to 0.
See also: Align_Slice and Align_RGB_planes plugins

25.13 Zoom

This submenu contains commands that control how the current image is displayed. The  and  or  and  keys are the preferred way to use the In and Out commands. When a selection exists, zooming with the arrow keys requires holding down either  or .

25.13.1 In [+]

Zooms in to next higher magnification level and, if possible, enlarges the window. There are 21 possible levels (shown in the title bar): 3.1, 4.2, 6.3, 8.3, 12.5, 16.7, 25, 33.3, 50, 75, 100, 150, 200, 300, 400, 600, 800, 1200, 1600, 2400 and 3200%.

25.13.2 Out [-]

Zooms out to next lower magnification level and, if needed, shrinks the window.

25.13.3 Original Scale [4]

Displays the image at the magnification used when the image was first opened. As a shortcut, double click on the magnifying glass tool.

25.13.4 View 100% [5]

Displays the image using 100% magnification (1 image pixel = 1 screen pixel). Enable Open Images at 100% in the Edit > Options > Appearance... dialog to have images automatically opened at 100% magnification.

25.13.5 To Selection

Zooms in based on the current selection. Note that in the absence of a selection, this command zooms the image to a ‘Fit to Screen’ level.

25.13.6 Set...

Zooms the active image to an exact value (e.g. 37.4%) overcoming the predefined zoom steps described in Image > Zoom > 25.13.1. The zoomed canvas will be centered at X, Y center (pixel coordinates) [23].

Non-destructive image overlays. Outputs from Grid_Overlay, MakeOverlay and ROI Color Coder, macros that exemplify the usage of most Image > Overlay > submenu commands.
Select Create image selection to create an overlay image that can be moved around the canvas. Opacity of image selections (ImageROIs) can be adjusted at any time using Edit ⊂ Selection ⊂ Properties... [y]. Use Edit ⊂ Selection ⊂ Restore Selection [E]) to recover the blending image after clicking outside its limits. Use Edit ⊂ Selection ⊂ Flatten [F]) to finally embed the imageROI.

Note that image selections behave only partially as regular selections (e.g., can be added to the ROI Manager list, can be moved beyond image boundaries but cannot be resized or rotated). In addition, image selections are not saved in the TIFF header.

See also: Paste Control... (Blend transfer mode), ROI Manager...

25.14.3 Hide Overlay

Causes ImageJ to stop displaying the overlay displayed by Show Overlay.

25.14.4 Show Overlay

Displays an overlay that was hidden by Hide Overlay.

25.14.5 From ROI Manager

Creates an overlay from the selections on the ROI Manager list (see ROI Manager...). Note that previously added overlays will be removed.

25.14.6 To ROI Manager

Copies the selections and images in the current overlay to the ROI Manager, where they can be edited (moved, resized or re-colored) (see ROI Manager...). Note that previous items in the ROI Manager list will be deleted.

25.14.7 Remove Overlay

Permanently clear the overlay so that it cannot be restored using Show Overlay.

25.14.8 Flatten [F]

Creates a new RGB image that has the overlay rendered as pixel data. The RGB image is the same size as the active image, unlike Plugins ⊂ Utilities ⊂ Capture Image, which creates a WYSIWYG (What You See Is What You Get) image that is the same size as its window.

25.15 Lookup Tables

This submenu contains a selection of color lookup tables that can be applied to grayscale images to produce false-color images. If no image is open, a 256×32 ramp image is created to display the color table. More than 100 additional lookup tables are available at imagej.nih.gov/ij/download/luts/or, as a ZIP archive, at http://imagej.nih.gov/ij/download/luts/luts.zip.

See also: Toolset Switcher

25.15.1 Invert LUT

Inverts the current lookup table. For 8-bit images, the value (v) of each entry in the table is replaced by 255 − v. With inverted LUTs, pixels with a value of zero are white and pixels with a value 255 are black. Unlike the Edit ⊂ Invert [I] command, pixels values are not altered, only the way the image is displayed on the screen.

25.15.2 Apply LUT

Applies the current lookup table function to each pixel in the image or selection and restores the default identity function. This modifies the gray values so that when the image is viewed using the default grayscale lookup table it will look the same as it did before. This command is equivalent to clicking on Apply in Image ⊂ Adjust ⊂ Brightness/Contrast... [C]. For thresholded images, it is equivalent to clicking on Apply in Image ⊂ Adjust ⊂ Threshold... [T].
XIX Hexadecimal Color Values

Hexadecimal (hex) notation is frequently used in computing to summarize binary code in a human-friendly manner. Here are some decimal/hexadecimal equivalents:

<table>
<thead>
<tr>
<th>Dec</th>
<th>Hex</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>00</td>
<td>Black</td>
</tr>
<tr>
<td>64</td>
<td>40</td>
<td>Cyan</td>
</tr>
<tr>
<td>127</td>
<td>7F</td>
<td>Gray</td>
</tr>
<tr>
<td>255</td>
<td>FF</td>
<td>White</td>
</tr>
<tr>
<td>1</td>
<td>01</td>
<td>Blue</td>
</tr>
<tr>
<td>2</td>
<td>02</td>
<td>Orange</td>
</tr>
<tr>
<td>3</td>
<td>03</td>
<td>Red</td>
</tr>
<tr>
<td>4</td>
<td>04</td>
<td>Yellow</td>
</tr>
<tr>
<td>7</td>
<td>07</td>
<td>Green</td>
</tr>
<tr>
<td>8</td>
<td>08</td>
<td>Magenta</td>
</tr>
<tr>
<td>9</td>
<td>09</td>
<td>Gray</td>
</tr>
<tr>
<td>10</td>
<td>0A</td>
<td>Yellow</td>
</tr>
</tbody>
</table>

Decimal RGB color values that typically range from 0 to 255 are succinctly represented by 6-digit hexadecimal numbers (hex triplet) in the form #RRGGBB. A hex color value is a 6-digit, three-byte hexadecimal number (hex triplet) in the form #RRGGBB, in which RR specifies the red, GG the green, and BB the blue value.

Opacity of hex triplets can be modified by an optional transparency (alpha) channel, giving rise to a 8-digit, four-byte hex number in the form #AARRGGBB with AA specifying the alpha blending value. In ImageJ, the alpha channel codes for opacity and ranges from 00 (fully transparent) to FF (solid color). Alpha values can be omitted for fully opaque colors. The table below provides some hexadecimal color values in 10% transparency increments.

<table>
<thead>
<tr>
<th>Color</th>
<th>RGB triplet</th>
<th>Opacity value (optional)</th>
<th>Hex triplet</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>0, 0, 255</td>
<td></td>
<td>#0000FF00</td>
</tr>
<tr>
<td>Cyan</td>
<td>255, 255, 0</td>
<td></td>
<td>#FF00FF00</td>
</tr>
<tr>
<td>Green</td>
<td>0, 255, 0</td>
<td></td>
<td>#00FFFF00</td>
</tr>
<tr>
<td>Magenta</td>
<td>255, 0, 255</td>
<td></td>
<td>#FF0000FF</td>
</tr>
<tr>
<td>Red</td>
<td>255, 0, 0</td>
<td></td>
<td>#FF000000</td>
</tr>
<tr>
<td>Orange</td>
<td>255, 150, 0</td>
<td></td>
<td>#FF6600FF</td>
</tr>
<tr>
<td>Yellow</td>
<td>255, 255, 0</td>
<td></td>
<td>#FFFF0000</td>
</tr>
<tr>
<td>White</td>
<td>255, 255, 255</td>
<td></td>
<td>#FFFFFFFF</td>
</tr>
<tr>
<td>Gray</td>
<td>127, 127, 127</td>
<td></td>
<td>#7F7F7F7F</td>
</tr>
<tr>
<td>Black</td>
<td>0, 0, 0</td>
<td></td>
<td>#00000000</td>
</tr>
</tbody>
</table>

Alpha blending values can be added to the beginning of hex triplets to modulate the color transparency: e.g., +7F FF 00 00 defines red at 50% opacity. In ImageJ the hash (#) prefix is optional when specifying overlay colors (see Image >> Overlay...).

The built-in macro function toHex() returns hexadecimal representations of decimal numbers and can be used to convert RGB color values into hex color notation (see RGBtoHEX macro). Several other macros (e.g., MakeOverlay) exemplify how to annotate images using hex colors.

26 Process

This menu lists all commands related to image processing, including point operations, filters, and arithmetic operations between multiple images [51]. The File >> Open Samples >> Blobs (25K) [B] image will be used in most of the illustrations of this section.

26.1 Smooth [S]

Blurs the active image or selection. This filter replaces each pixel with the weighted average of its 3×3 neighborhood.

26.2 Sharpen

Increases contrast and accentuates detail in the image or selection, but may also accentuate noise. This filter uses the following weighting factors to replace each pixel with a weighted average of the 3×3 neighborhood:

\[-1 \quad -1 \quad -1\]
\[ \quad 0 \quad 12 \quad -1\]
\[ -1 \quad -1 \quad -1\]

26.3 Find Edges

Uses a Sobel edge detector to highlight sharp changes in intensity in the active image or selection. Two 3×3 convolution kernels (shown below) are used to generate vertical and horizontal derivatives. The final image is produced by combining the two derivatives using the square root of the sum of the squares.

\[1 \quad 2 \quad 1\]
\[0 \quad 0 \quad 0\]
\[-1 \quad -2 \quad -1\]

26.4 Find Maxima . . .

Determines the local maxima in an image and creates a binary (mask-like) image of the same size with the maxima, or one segmented particle per maximum, marked [24]. Analysis is performed on the existing rectangular selection or on the entire image if no selection is present.

For RGB images, maxima of luminance are selected, with the luminance defined as weighted or unweighted average of the colors depending on how Weighted RGB to Grayscale Conversion is set in Edit >> Options >> Conversions . . .
Noise Tolerance. Maxima are ignored if they do not stand out from the surroundings by more than this value (calibrated units for calibrated images). In other words, a threshold is set at the maximum value minus noise tolerance and the contiguous area around the maximum above the threshold is analyzed. For accepting a maximum, this area must not contain any point with a value higher at than the maximum. Only one maximum within this area is accepted.

Output Type. Can be (see Process >> Find Maxima... outputs):

Single Points. Results in one single point per maximum.

Maxima Within Tolerance. All points within the Noise Tolerance for each maximum.

Segmented Particles. Assumes that each maximum belongs to a particle and segments the image by a watershed algorithm applied to the values of the image (in contrast to Process >> Binary >> Watershed, which uses the Euclidian distance map – EDM). See Process >> Binary >> Voronoi for EDM-based segmentation of binary images.

Point Selection. Displays a multi-point selection with a point at each maximum.

List. Displays the XY coordinates of each maximum in the Results window.

Count. Displays the number of maxima in the Results window.

Exclude Edge Maxima. Excludes maxima if the area within the noise tolerance surrounding a maximum touches the edge of the image (edge of the selection does not matter).

Above Lower Threshold. (Thresholded images only) Finds maxima above the lower threshold only. The upper threshold of the image is ignored. If Segmented Particles is selected as Output Type, the area below the lower threshold is considered a background. This option cannot be used when finding minima (image with light background and inverted LUT).

Light Background. To be checked if the image background is brighter than the objects to be found, as it is in the Cell Colony image in the illustration below.


Output is a binary image, with foreground 255 and background 0, using an inverted or normal LUT depending on the Black Background option in Process >> Binary >> Options... (see XXI Interpreting Binary Images).

The number of particles (as obtained by Analyze >> Analyze Particles...) in the output image does not depend on the selected Output Type. Note that Segmented Particles will usually result in particles touching the edge if Exclude Edge Maxima is selected. Exclude Edge Maxima applies to the maximum, not to the particle.

Find Maxima... does not work on stacks, but the FindStackMaxima macro runs it on all the images in a stack and creates a second stack containing the output images. The FindMaximaRoiManager macro demonstrates how to add particles found by Find Maxima... to the ROI Manager...

Enhance Contrast. Enhances image contrast by using either histogram stretching or histogram equalization. Both methods are described in detail in the Hypermedia Image Processing Reference – Contrast Stretching and Histogram Equalization.

This command does not alter pixel values as long as Normalize, Equalize Histogram or Normalize All n Slices (in the case of stacks) are not checked.

Saturated Pixels. Determines the number of pixels in the image that are allowed to become saturated. Increasing this value will increase contrast. This value should be greater than zero to prevent a few outlying pixel from causing the histogram stretch to not work as intended.

Normalize. If checked, ImageJ will recalculate the pixel values of the image so the range is equal to the maximum range for the data type, or 0-1.0 for float images. The contrast stretch performed on the image is similar to the ‘Auto’ option in the Brightness/Contrast... window, except that with stacks, each slice in the stack is adjusted independently, according to the optimal for that slice alone (if Use Stack Histogram is unchecked). The maximum range is 0-255 for 8-bit images and 0-65535 for 16-bit images.

With stacks another checkbox, Normalize All n Slices, is displayed. If checked, normalization will be applied to all slices in the stack. Note that normalization of RGB images is not supported, and thus this option will not be available on RGB images.

Equalize Histogram. If checked, ImageJ will enhance the image using histogram equalization [25]. Create a selection and the equalization will be based on the histogram of the selection. Uses a modified algorithm that takes the square root of the histogram values. Hold Alt to use the standard histogram equalization algorithm. The Saturated Pixels and Normalize parameters are ignored when Equalize Histogram is checked.
Use Stack Histogram If checked, ImageJ will use the overall stack histogram instead of individual slice histograms, that allow optimal adjustments for each slice alone. This option may be specially relevant when performing enhancements based on a ROI.

See also: Brightness/Contrast... [C], XIV Applying Auto Brightness/Contrast to Entire Stacks

26.6 Noise

Use the commands in this submenu to add noise to images or remove it.

26.6.1 Add Noise

Adds random noise to the image or selection. The noise is Gaussian (normally) distributed with a mean of zero and standard deviation of 25.

26.6.2 Add Specified Noise...

Adds Gaussian noise with a mean of zero and a chosen standard deviation.

26.6.3 Salt and Pepper

Adds salt and pepper noise to the image or selection by randomly replacing 2.5% of the pixels with black pixels and 2.5% with white pixels. This command only works with 8-bit images.

26.6.4 Despeckle

This is a median filter. It replaces each pixel with the median value in its 3×3 neighborhood. This is a time consuming operation because, for each pixel in the selection, the nine pixels in the 3×3 neighborhood must be sorted and the center pixel replaced with the median value (the fifth). Median filters are good at removing salt and pepper noise.

26.6.5 Remove Outliers...

Replaces a pixel by the median of the pixels in the surrounding if it deviates from the median by more than a certain value (the threshold). Useful for correcting, e.g., hot pixels or dead pixels of a CCD camera.

Radius Determines the area (uncalibrated, i.e., in pixels) used for calculating the median. Run Process>Filters>Show Circular Masks... to see how radius translates into an area.

Threshold Determines by how much the pixel must deviate from the median to get replaced, in raw (uncalibrated) units.

Which Outliers Determines whether pixels brighter or darker than the surrounding (the median) should be replaced.

See also: Despeckle

26.6.6 Remove NaNs...

This filter replaces NaN (Not-a-Number) pixels in 32-bit (float) images by the median of the neighbors inside the circular kernel area defined by Radius [26]. It does not remove patches of NaNs larger than the kernel size, however.

Note that some ImageJ filters, such as Process>Filters>Gaussian Blur..., Mean..., and Variance..., destroy the surrounding of NaN pixels by setting it also to NaN. Other filters may produce invalid results in the position of NaN pixels.

See also: NaNs.txt, a macro that demonstrates how to create, count and remove NaNs

26.7 Shadows

Commands in this submenu produce a shadow effect, with light appearing to come from a direction corresponding to the command name (East, North, Northeast, Northwest, South, Southeast, Southwest and West). The commands use Convolve 3×3, ImageJ’s 3×3 convolution function. The Shadows Demo command uses all eight kernels to demonstrate the speed of Convolve 3×3. The illustration below shows four of the Shadows convolution kernels.

See also: Shadows Demo, a macro that demonstrates how to create, count and remove Shadows...
26.8 Binary

This submenu contains commands that create or process binary (black and white) images. They assume that objects are black and background is white unless Black Background is checked in the Process > Binary > Options... dialog box (see XXI Interpreting Binary Images).

Summary of morphological operators (Process > Binary > submenu).

<table>
<thead>
<tr>
<th>ImageJ</th>
<th>Make Binary</th>
<th>Erode</th>
<th>Dilate</th>
<th>Open</th>
<th>Close-</th>
<th>Outline</th>
<th>Skeletonize</th>
<th>Adjust &gt; Threshold... [T]</th>
<th>Minimum... (grayscale)</th>
<th>Maximum... (gray scale)</th>
<th>Erode then Dilate</th>
<th>Dilate then Erode</th>
<th>1 pixel wide outline</th>
<th>1 pixel wide skeleton</th>
</tr>
</thead>
</table>

26.8.1 Make Binary

Converts an image to black and white. If a threshold has been set using the Image > Adjust > Threshold... [T] tool, the depicted dialog is displayed. The value of the Black foreground, white background checkbox reflects and sets the global Black Background value of Process > Binary > Options. ...

If a threshold has not been set, Make Binary will analyze the histogram of the current selection, or of the entire image if there is no selection is present and set an automatic threshold level to create the binary image (‘Auto-thresholding’ is displayed in the Status bar, cf. Threshold... [T]).

With stacks the Convert to Mask dialog box is displayed. Note that for non-thresholded images and stacks Make Binary and Convert to Mask behave similarly.

See also: Edit > Selection > Convert to Mask, XX Creating Binary Masks, XX Interpreting Binary Images

26.8.2 Convert to Mask

Converts an image to black and white. The mask will have an inverting LUT (white is 0 and black is 255) unless Black Background is checked in the Process > Binary > Options... dialog box. If a threshold has not been set, automatic threshold levels will be calculated (cf. Make Binary). Note that for non-thresholded images and stacks Make Binary and Convert to Mask behave similarly.

See also: Make Binary, Edit > Selection > Convert to Mask, XX Creating Binary Masks

26.8.3 Erode

Removes pixels from the edges of objects in a binary image. Use Filters > Minimum... to perform grayscale erosion on non-thresholded images.

See also: Binary > Options..., XX Interpreting Binary Images

26.8.4 Dilate

Adds pixels to the edges of objects in a binary image. Use Filters > Maximum... to perform grayscale dilation on non-thresholded images.

See also: Binary > Options..., XX Interpreting Binary Images

26.8.5 Open

Performs an erosion operation, followed by dilation. This smooths objects and removes isolated pixels.

See also: Binary > Options..., XX Interpreting Binary Images

26.8.6 Close–

Performs a dilation operation, followed by erosion. This smooths objects and fills in small holes. The command has a tailing hyphen to differentiate it from File > Close [w].

See also: Binary > Options..., XX Interpreting Binary Images

XX Creating Binary Masks

Four ImageJ commands can be used to create binary masks:

1. Edit > Selection > Make Mask
2. Process > Binary > Make Binary
3. Process > Binary > Convert to Mask
4. Image > Adjust > Threshold... [T] (Apply)

By default these commands will produce binary images with inverted LUTs, so that black is 255 and white is 0 (see Invert LUT). This behavior can be reversed by checking Black Background in Process > Binary > Options... before running the above commands (i.e., an inverting LUT will not be used: black will be 0 and white 255). This choice can be confirmed when running Make Binary and Convert to Mask on thresholded images. It can also be imposed at startup (see Settings and Preferences).

See also: XXI Interpreting Binary Images
26.8.7 Outline

Generates a one pixel wide outline of foreground objects in a binary image. The line is drawn inside the object, i.e., on previous foreground pixels.

26.8.8 Fill Holes

This command fills holes (4-connected background elements) in objects by filling the background [29].

26.8.9 Skeletonize

Repeatably removes pixels from the edges of objects in a binary image until they are reduced to single-pixel-wide shapes (topological skeletons). There are several skeletonization algorithms. The one implemented by ImageJ is based on a thinning algorithm by T. Y. Zhang and C. Y. Suen. 1984. A fast parallel algorithm for thinning digital patterns. Commun. ACM 27, 3 (March 1984), 236–239. DOI=10.1145/357994.358023. Enable debugging in Edit→Options→Misc... and the Skeletonize command will create an animation that shows how the thinning algorithm works.

See also: Skeletonize3D and AnalyzeSkeleton plugins, BinaryProcessor source code

26.8.10 Distance Map

Generates a Euclidian distance map (EDM) from a binary image [103]. Each foreground pixel in the binary image is replaced with a gray value equal to that pixel’s distance from the nearest background pixel (for background pixels the EDM is 0). The Ultimate Points, watershed and Voronoi operations are based on the EDM algorithm.

The output type (Overwrite, 8-bit, 16-bit or 32-bit) of this command can be set in the Binary→Options... dialog box. Note that when selecting ‘Overwrite’ or ‘8-bit output’, distances larger than 255 are labelled as 255.

26.8.11 Ultimate Points

Generates the ultimate eroded points (UEPs) of the Euclidian distance map (EDM, see Distance Map) from a binary image. Ultimate Eroded Points are maxima of the EDM. In the output, the points are assigned the EDM value, which is equal to the radius of the largest circle that fits into the binary particle, with the UEP as the center. The output type (Overwrite, 8-bit, 16-bit or 32-bit) of this command can be set in the Binary→Options... dialog box.

26.8.12 Watershed

Watershed segmentation is a way of automatically separating or cutting apart particles that touch. It first calculates the Euclidian distance map (EDM) and finds the ultimate eroded points (UEPs). It then dilates each of the UEPs (the peaks or local maxima of the EDM) as far as possible – either until the edge of the particle is reached, or the edge of the region of another (growing) UEP. Watershed segmentation works best for smooth convex objects that don’t overlap too much.

Enable debugging in Edit→Options→Misc... and the Watershed command will create an animation that shows how the watershed algorithm works (cf. online example).

See also: Find Maxima... (Segmented Particles output) for watershed segmentation of grayscale images.

26.8.13 Voronoi

Splits the image by lines of points having equal distance to the borders of the two nearest particles. Thus, the Voronoi cell of each particle includes all points that are nearer to this particle than any other particle. When particles are single points, this process is a Voronoi tessellation (also known as Dirichlet tessellation).

The output type (Overwrite, 8-bit, 16-bit or 32-bit) of this command can be set in the Process→Binary→Options... dialog box. In the output, the value inside the Voronoi cells is zero; the pixel values of the dividing lines between the cells are equal to the distance to the two nearest particles. This is similar to a medial axis transform of the background, but there are no lines in inner holes of particles.

See also: Find Maxima... (Segmented Particles output), Delaunay_Voronoi plugin
Black background If checked, binary images will be created without using an inverted LUT (cf. XX Creating Binary Masks) and commands in the Process⇒Binary⇒ submenu will assume that images contain white objects on a black background (see XX Interpreting Binary Images). Macros can set this option using setOption("BlackBackground", true); (see XX Interpreting Binary Images and Settings and Preferences).

Pad edges when eroding If checked, Binary⇒Erode does not erode from the edges of the image. This setting also affects Binary⇒Close–, which erodes from the edges unless this checkbox is selected.

Black background If checked, binary images will be created without using an inverted LUT (cf. XX Creating Binary Masks) and commands in the Process⇒Binary⇒ submenu will assume that images contain white objects on a black background (see XX Interpreting Binary Images). Macros can set this option using setOption("BlackBackground", true); (see XX Interpreting Binary Images and Settings and Preferences).

Pad edges when eroding If checked, Binary⇒Erode does not erode from the edges of the image. This setting also affects Binary⇒Close–, which erodes from the edges unless this checkbox is selected.

EDM output Determines the output type for the Binary⇒Distance Map, Ultimate Points and Voronoi commands. Set it to ‘Overwrite’ for 8-bit output that overwrites the input image; ‘8-bit’, ‘16-bit’ or ‘32-bit’ for separate output images. 32-bit output has floating point (subpixel) distance resolution.

Do This drop-down menu allows to test the chosen settings by previewing each binary operation (Erode, Dilate, Open, Close–, Outline, Fill Holes, Skeletonize) on the active image. This option is only available when the active image is binary.


26.9 Math

The commands in this submenu add (subtract, multiply, etc.) a constant to each pixel in the active image or selection. A ‘Preview’ option is available for most operations.

With stacks, the dialog depicted on the left is displayed. Choose ‘Yes’ to process entire stack or ‘No’ to process only the active slice. The dialog is not displayed if ‘Process Stack?’ dialog is checked in Edit⇒Options⇒Misc…

SEE ALSO: Memory & Threads…

26.9.1 Add…

Adds a constant to the image or selection. With 8-bit images, results greater than 255 are set to 255. With 16-bit signed images, results greater than 65,535 are set to 65,535.

26.9.2 Subtract…

Subtracts a constant from the image or selection. With 8-bit and 16-bit images, results less than 0 are set to 0.

26.9.3 Multiply…

Multiplies the image or selection by the specified real constant. With 8-bit images, results greater than 255 are set to 255. With 16-bit signed images, results greater than 65,535 are set to 65,535.

26.9.4 Divide…

Divides the image or selection by the specified real constant. Except for 32-bit (float) images, attempts to divide by zero are ignored. With 32-bit images, dividing by zero results in Infinity, -Infinity or NaN (0/0) pixels when the source pixels are positive, negative or zero. The divide-by-zero value can be redefined using Edit⇒Options⇒Misc…

26.9.5 AND…

Does a bitwise AND of the image and the specified binary constant.
26.9.6 OR...

Does a bitwise OR of the image and the specified binary constant.

26.9.7 XOR...

Does a bitwise XOR of the image and the specified binary constant.

26.9.8 Min...

Pixels in the image with a value less than the specified constant are replaced by the constant.

26.9.9 Max...

Pixels in the image with a value greater than the specified constant are replaced by the constant.

26.9.10 Gamma...

Applies the function \( f(p) = \left( \frac{p}{255} \right)^\gamma \times 255 \) to each pixel \( p \) in the image or selection, where \( 0.1 \leq \gamma \leq 5.0 \). For RGB images, this function is applied to all three color channels. For 16-bit images, the image min and max are used for scaling instead of 255.

**See also:** GammaCorrectionTool macro

26.9.11 Set...

Fills the image or selection with the specified value.

26.9.12 Log

For 8-bit images, applies the function \( f(p) = \ln(p) \times 255 / \ln(255) \) to each pixel \( p \) in the image or selection. For RGB images, this function is applied to all three color channels. For 16-bit images, the image min and max are used for scaling instead of 255. For float images, no scaling is done. To calculate \( \log_{10} \) of the image, multiply the result of this operation by 0.4343 \( (1/\ln(10)) \).

26.9.13 Exp

Performs an exponential transform on the active image or selection.

26.9.14 Square

Performs a square transform on the active image or selection.

26.9.15 Square Root

Performs a square root transform on the active image or selection.

---

26.9.16 Reciprocal

Generates the reciprocal (multiplicative inverse) of the active image or selection, transforming each pixel \( p \) into \( 1/p \). Requires 32-bit float images (see Image Types and Formats).

26.9.17 NaN Background

Sets non-thresholded pixels in 32-bit float images to the NaN (Not a Number) value. For float images, the Apply option in Image>Adjust>Threshold... [T] runs this command. Pixels with a value of Float.NaN (0f/0f), Float.POSITIVE_INFINITY (1f/0f) or Float.NEGATIVE_INFINITY (-1f/0f) are ignored when making measurements on 32-bit float images.

26.9.18 Abs

Generates the absolute value of the active image or selection. Works only with 32-bit float or signed 16-bit image images.

26.9.19 Macro...

This command performs image arithmetic using an expression specified by the user [27]. It can be used to create fully-synthetic images or to perform precise pixel manipulations on existing images. The MathMacroDemo macro demonstrates the usage of this command.

**See also:** Expression plugin

26.10 FFT

The commands in this submenu support frequency domain display, editing and processing. They are based on an implementation of the 2D Fast Hartley Transform (FHT) contributed by Arlo Reeves, the author of the ImageFFT spinoff of NIH Image.¹

¹Bob Dougherty’s 3D Fast Hartley Transform plugin performs 3D FHTs.
If the mouse is over an active frequency domain (FFT) window, its location is displayed in polar coordinates. The angle is expressed in degrees, while the radius is expressed in pixels per cycle (p/c). The radius is expressed in [units] per cycle (e.g., mm/c) if the spatial scale of the image was defined using image Properties. This command allows you to start over after mis-editing the 8-bit power spectrum image.

### 26.10.4 FFT Options...
Displays the FFT Options dialog box. The first group of checkboxes specifies which image(s) are created by the FFT command:

- **Display FFT Window** The standard output. It consists of an 8-bit image of the power spectrum and the actual data, which remain invisible for the user. The power spectrum image is displayed with logarithmic scaling, enhancing the visibility of components that are weakly visible. The actual data are used for the Inverse FFT command.

- **Display Raw Power Spectrum** The power spectrum without logarithmic scaling.

- **Display Fast Hartley Transform** The internal format used by the command, which is based on a Hartley transform rather than Fourier transform.

- **Display Complex Fourier Transform** A stack with two slices for the real and imaginary parts of the FFT.

- **Do Forward Transform** If checked, the current image is transformed immediately when closing the FFT Options dialog.

### 26.10.5 Bandpass Filter...
Removes high spatial frequencies (blurring the image) and low spatial frequencies (similar to subtracting a blurred image). It can also suppress horizontal or vertical stripes that were created by scanning an image line by line [28].

The Bandpass Filter uses a special algorithm to reduce edge artifacts (before the Fourier transform, the image is extended in size by attaching mirrored copies of image parts outside the original image, thus no jumps occur at the edges).

- **Filter Large Structures Down to** Smooth variations of the image with typical sizes of bright or dark patches larger than this value are suppressed (background).

- **Filter Large Structures Up to** Determines the amount of smoothing. Objects in the image smaller than this size are strongly attenuated. Note that these values are both half the spatial frequencies of the actual cutoff. The cutoff is very soft, so the bandpass will noticeably attenuate even spatial frequencies in the center of the bandpass unless the difference of the two values is large (say, more than a factor of 5 or so).

- **Suppress Stripes** Select whether to eliminate horizontal or vertical stripes. Removal of horizontal stripes is similar to subtracting an image that is only blurred in the horizontal direction from the original.

- **Tolerance of Direction** This is for Suppress Stripes: higher values remove shorter stripes and/or stripes that are running under an angle with respect to the horizontal (vertical) direction.

### 26.10.2 Inverse FFT
Computes the inverse Fourier transform. You can filter or mask spots on the transformed (frequency domain) image and do an inverse transform to produce an image which only contains the frequencies selected or which suppresses the frequencies selected. Use ImageJ’s selection tools and fill/clear commands to draw black or white areas that mask portions of the transformed image. Black areas (pixel value = 0) cause the corresponding frequencies to be filtered (removed) and white areas (pixel value = 255) cause the corresponding frequencies to be passed. It is not, however, possible to both filter and pass during the same inverse transform.

Note that areas to be filtered in the frequency domain image must be zero filled and areas to be passed must be filled with 255. You can verify that this is the case by moving the cursor over a filled area and observing that the values displayed in the status bar are either 0 or 255.

With off-center selections, the same spatial frequency appears twice in the power spectrum, at points opposite from the center. It is sufficient to fill/clear only one of these.

### 26.10.3 Redisplay Power Spectrum
Recomputes the power spectrum from the frequency domain image (32-bit FHT). This command allows you to start over after mis-editing the 8-bit power spectrum image.
**Autoscale After Filtering** If checked, puts the lowest intensity to 0 and the highest intensity to 255, preserving all intensities.

**Saturate Image when Autoscaling** If checked, allows some intensities to go into saturation, and produces a better visual contrast. **Saturate Image when Autoscaling** only has an effect when **Autoscale After Filtering** is enabled.

**Display Filter** If checked, shows the filter generated. Note that this disables Undo of the filter operation on the original image.

### 26.10.6 Custom Filter...

This command does Fourier space filtering of the active image using a user-supplied spatial domain (non-FFT) image as the filter.

This image will be converted to 8-bit. For pixels that have a value of 0, the corresponding spatial frequencies will be blocked. Pixel with values of 255 should be used for passing the respective spatial frequencies without attenuation. Note that the filter should be symmetric with respect to inversion of the center: Points that are opposite of the center point (defined as \(x = \text{width}/2, y = \text{height}/2\) should have the same value. Otherwise, artifacts can occur. For some examples, see the `FFTCustomFilterDemo` and `FFTRemoveStreaks` macros.

### 26.10.7 FD Math...

This command correlates, convolves or deconvolves two images.

It does this by converting **Image1** and **Image2** to the frequency domain, performing conjugate multiplication or division, then converting the result back to the space domain. These three operations in the frequency domain are equivalent to correlation, convolution and deconvolution in the space domain.

Refer to the `DeconvolutionDemo` and `MotionBlurRemoval` macros for examples.

### 26.10.8 Swap Quadrants

This command transforms between the ‘user friendly’ display of Fourier transforms with the lowest frequencies at the center and the ‘native’ form with the lowest frequencies at the four corners.

**Swap Quadrants** swaps quadrants I with III and II with IV (counter-clockwise starting from ‘Northeast’!) so that points near the center are moved towards the edge and vice versa. Another way to see this command is to imagine that the image is periodically repeated and the origin is shifted by width/2 in x and by height/2 in y direction.

For Fourier transforms, **Swap Quadrants** affects only the image displayed, not the actual FHT data. Therefore, editing an image with swapped quadrants for filtering or masking may lead to undesired results.

### 26.11 Filters>

This submenu contains miscellaneous filters [30] (including those installed by the **Utilities** > **Install Plugin…** command).

More information on image filters can be obtained by looking up related keywords (correlation, Gaussian, median, mean, erode, dilate, unsharp, etc.) on the Hypermedia Image Processing Reference index.

SEE ALSO: Memory & Threads…

### 26.11.1 Convolv...

Does spatial convolution using a kernel entered into a text area.

A kernel is a matrix whose center corresponds to the source pixel and the other elements correspond to neighboring pixels. The destination pixel is calculated by multiplying each source pixel by its corresponding kernel coefficient and adding the results. If needed, the input image is effectively extended by duplicating edge pixels outward. There is no arbitrary limit to the size of the kernel but it must be square and have an odd width.

Rows in the text area must all have the same number of coefficients, the rows must be terminated with a carriage return, and the coefficients must be separated by one or more spaces. Kernels can be pasted into the text area using Ctrl + C, Ctrl + V.

Checking **Normalize Kernel** causes each coefficient to be divided by the sum of the coefficients, preserving image brightness.

The kernel shown is a 9 × 9 “Mexican hat”, which does both smoothing and edge detection in one operation. Note that kernels can be saved as a text file by clicking on the ‘Save’ button, displayed as an image using File > Import > Text Image…, scaled to a reasonable size using Image > Adjust > Size… and plotted using Analyze > Surface Plot…

SEE ALSO: ConvolutionDemo macro
26.11.2 Gaussian Blur...

This filter uses convolution with a Gaussian function for smoothing [31].

\[ \text{Sigma} \] is the radius of decay to \( e^{-0.5} \) (≈ 61%), i.e., the standard deviation (\( \sigma \)) of the Gaussian (this is the same as in Adobe® Photoshop®, but different from ImageJ versions till 1.38q, in which \( \text{radius} \) was 2.5\( \times \sigma \) (cf. GaussianBlur.java).

Like all ImageJ convolution operations, it assumes that out-of-image pixels have a value equal to the nearest edge pixel. This gives higher weight to edge pixels than pixels inside the image, and higher weight to corner pixels than non-corner pixels at the edge. Thus, when smoothing with very high blur radius, the output will be dominated by the edge pixels and especially the corner pixels (in the extreme case, with a blur radius of e.g. 10, the image will be replaced by the average of the four corner pixels).

For increased speed, except for small blur radii, the lines (rows or columns of the image) are downscaled before convolution and upscaled to their original length thereafter.

**See also:** Accurate Gaussian Blur plugin, AnimatedGaussianBlur macro

26.11.3 Median...

Reduces noise in the active image by replacing each pixel with the median of the neighboring pixel values.

26.11.4 Mean...

Smoothes the current image by replacing each pixel with the neighborhood mean.

26.11.5 Minimum...

This filter does grayscale erosion by replacing each pixel in the image with the smallest pixel value in that pixel’s neighborhood.

**See also:** Binary ⊲ Erode

26.11.6 Maximum...

This filter does grayscale dilation by replacing each pixel in the image with the largest pixel value in that pixel’s neighborhood.

**See also:** Binary ⊲ Dilate

26.11.7 Unsharp Mask...

Sharpenes and enhances edges by subtracting a blurred version of the image (the unsharp mask) from the original.

Unsharp masking subtracts a blurred copy of the image and rescales the image to obtain the same contrast of large (low-frequency) structures as in the input image. This is equivalent to adding a high-pass filtered image and thus sharpens the image.

**Radius** The standard deviation (\( \sigma \) blur radius, cf. Gaussian Blur...) of the Gaussian blur that is subtracted. Increasing the Gaussian blur radius will increase contrast.

**Mask Weight** Determines the strength of filtering, whereby MaskWeight = 1 would be an infinite weight of the high-pass filtered image that is added. Increasing the Mask Weight value will provide additional edge enhancement.

26.11.8 Variance...

Highlights edges in the image by replacing each pixel with the neighborhood variance.

26.11.9 Show Circular Masks...

Generates a stack containing examples of the circular masks used by the Median..., Mean..., Minimum..., Maximum..., and Variance... filters for various neighborhood sizes.

26.12 Batch>

This submenu allows the execution of commands in a series of images without manual intervention.

**Batch** commands are non-recursive, i.e., they are applied to all the images of the chosen Input folder but not its subfolders. Nevertheless a directory hierarchy can be traversed using ImageJ macro language (cf. BatchProcessFolders macro).

Three critical aspects to keep in mind when performing batch operations that modify processed images:

- Files can be easily overwritten since the batch processor will silently override existing files with the same name.
- The destination Output folder should have adequate disk space to receive the created images.
- In the case of non-native formats, batch operations will be influenced by the behavior of the reader plugin or library (cf. Non–native Formats).
26.12.1 Measure...

This command measures all the images in a user-specified folder, by running the Analyze ▶ Measure... [m] command in all images of the chosen directory.

Note that measurements are performed on non thresholded images. In the case of TIFF images saved with active selections measurements are performed on the ROI and not the whole image.

SEE ALSO: Analyze ▶ Set Measurements..., Batch ▶ Macro...

26.12.2 Convert...

Batch converts and/or resizes multiple images from a specified folder.

Input... Selects the source folder containing the images to be processed.

Output... Selects the destination folder where the processed images will be stored.

Output Format Specifies the output format that can be set to TIFF, 8-bit TIFF, JPEG, GIF, PNG, PGM, BMP, FITS, Text Image, ZIP or Raw (cf. Image Types and Formats and File ▶ Save As ▶ submenu).

Interpolation The resampling method to be used in case Scale Factor is not 1.00 (see Image ▶ Size... and Image ▶ Scale... [E]). For better results, Average when downsizing is automatically selected when scaling down images.

Scale Factor Specifies if images should be resized (see Image ▶ Scale... [E]).

26.12.3 Macro...

Runs a macro over all the images in a specified folder. The macro is stored in the /ImageJ/macros/batchmacro.ijm file.

Input... Selects the source folder containing the images to be processed.

Output... Selects the destination folder where the processed images will be stored.

Output Format Specifies the output format that can be set to TIFF, 8-bit TIFF, JPEG, GIF, PNG, PGM, BMP, FITS, Text Image, ZIP or Raw (cf. Image Types and Formats and File ▶ Save As ▶ submenu).

Add Macro Code This drop-down menu contains macro snippets that can be combined to create the processing macro. Other statements can be pasted from the macro recorder or ImageJ’s editor while the dialog box is opened [32]. Previously written macros can be imported using Open... When editing the macro beware of any statements that may interfere with the normal operation of the batch processor (such as Close() or Open() calls).

Test Tests the macro on the first image of the Input... folder (the processed image will be displayed).

Save... Saves the assembled macro.


SEE ALSO: Plugins ▶ Macros ▶ Record..., Batch ▶ Virtual Stack...

26.12.4 Virtual Stack...

This command, that shares the same interface of Batch ▶ Macro... (cf. BatchProcessor.java), allows virtual stack manipulations. E.g., Cropping a virtual stack can be performed by executing the following steps:

1. Open a virtual stack
2. Run Process ▶ Batch ▶ Virtual Stack...
3. Select an Output folder and Output format
4. Select ‘Crop’ from the Add Macro Code drop-down menu
5. Edit the macro code as needed and press the Test button to verify the macro
6. Click Process to create the cropped virtual stack

Note that cropped images are not loaded into memory but are saved to disk as they are cropped (see Virtual Stacks).

26.13 Image Calculator...

Performs arithmetic and logical operations between two images selected from popup menus. Image1 or both Image1 and Image2 can be stacks. If both are stacks, they must have the same number of slices. Image1 and Image2 do not have to be the same data type or the same size.

With 32-bit (float) images, pixels resulting from division by zero are set to Infinity, or to NaN (Not a Number) if a zero pixel is divided by zero.

Option Selects one of the thirteen available operators (see Image Calculator... operations).
Create New Window If checked, a new image or stack will be created to hold the result. Otherwise, the result of the operation replaces some or all of Image1.

32-bit (float) Result If checked, the source images will be converted to 32-bit floating point before the specified operation is performed.


Image Calculator... operations. On these examples source and destination images (8-bit grayscale) are displayed with inverted LUTs (White= 0; Black= 255) (cf. Lookup Tables-> submenu). Note that calculations between images can also be performed using copy and paste and the Edit-Paste Control... command.

<table>
<thead>
<tr>
<th>Source image (img1):</th>
<th>Destination image (img2):</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add: img1 = img1 + img2</td>
<td>Min: img1 = min(img1, img2)</td>
</tr>
<tr>
<td>Subtract: img1 = img1 - img2</td>
<td>Max: img1 = max(img1, img2)</td>
</tr>
<tr>
<td>Multiply: img1 = img1 × img2</td>
<td>Average: 1 = (img1 + img2)/2</td>
</tr>
<tr>
<td>Divide: img1 = img1 ÷ img2</td>
<td>Difference: 1 =</td>
</tr>
<tr>
<td>AND: img1 = img1 ∧ img2</td>
<td>Copy: 1 = img2</td>
</tr>
<tr>
<td>OR: img1 = img1 ∨ img2</td>
<td>Transparent–zero</td>
</tr>
<tr>
<td>XOR: img1 = img1 ⊕ img2</td>
<td></td>
</tr>
</tbody>
</table>

### 26.14 Subtract Background...

Removes smooth continuous backgrounds from gels and other images.

Based on the ‘rolling ball’ algorithm by Stanley Sternberg (see Sternberg S, Biomedical image processing, IEEE Computer, Jan 1983). Imagine a 3D surface with the pixel values of the image being the height, then a ball rolling over the back side of the surface creates the background. If Sliding Paraboloid is checked, the command will use a more robust implementation of the algorithm that uses an approximation of a paraboloid of rotation instead of a ball.

Rolling Ball Radius The radius of curvature of the paraboloid. As a rule of thumb, for 8-bit or RGB images it should be at least as large as the radius of the largest object in the image that is not part of the background. Larger values will also work unless the background of the image is too uneven. For 16-bit and 32-bit images with pixel value ranges different from 0–255, the radius should be inversely proportional to the pixel value range (e.g., for 16-bit images (pixel values 0–65535), typical values of the radius are around 0.2 to 5).

Light Background Allows the processing of images with bright background and dark objects.

Separate Colors (RGB images only) If unchecked, the operation will only affect the brightness, leaving the hue and saturation untouched.

Create Background (Don’t Subtract) If checked, the output is not the image with the background subtracted but rather the background itself. This option is useful for examining the background created (in conjunction with the Preview option). Create Background can be also used for custom background subtraction algorithms where the image is duplicated and filtered (e.g., removing ‘holes’ in the background) before creating the background and finally subtracting it with Process> Image Calculator... command.

Sliding Paraboloid If checked, the ‘rolling ball’ is replaced by a paraboloid that has the same curvature at the apex as a ball of that radius. This option allows any value of the radius> 0.0001. (The ‘rolling ball’ algorithm requires a radius of at least 1). The ‘sliding paraboloid’ typically produces more reliable corrections since the ‘rolling ball’, a legacy algorithm, is prone to edge artifacts. E.g., to reduce the computing time the ‘rolling ball’ algorithm downscales the image in a way that is not really consistent. The ‘sliding paraboloid’, typically produces more reliable corrections since the ‘rolling ball’, a legacy algorithm, is prone to edge artifacts. E.g., to reduce the computing time the ‘rolling ball’ algorithm downscales the image in a way that is not really consistent. The ‘sliding paraboloid’ is also an approximation, since it does not really use a paraboloid (an exact implementation would require a great computing effort) but it rather slides parabolas in different directions over the image.

Disable Smoothing For calculating the background (‘rolling the ball’), images are maximum-filtered (3×3 pixels) to remove outliers such as dust and then smoothed to reduce noise (average over 3×3 pixels). With Disable Smoothing checked, the unmodified image data are used for creating the background. Check this option to make sure that the image data after subtraction will never be below the background.

See also: How to correct background illumination in brightfield microscopy by G. Landini,
Auto Local Threshold, Background subtractor, Rolling Ball Background Subtraction
(the plugin that implemented this command in versions up to 1.39e)

26.15 Repeat Command [R]

Reruns the previous command. The Edit ⊿ Undo and File ⊿ Open commands are skipped.

See also: Undo and Redo

27 Analyze ⊿

This menu contains commands related to statistical measurements on image data, profile and histogram plotting and plugins related to image analysis.

27.1 Measure... [m]

Based on the selection type, calculates and displays on the Results Table either area statistics, line lengths and angles, or point coordinates. Performed measurements can be specified in the Set Measurements... dialog box.

Area statistics are calculated for the complete image if there is no selection or for a selected subregion defined by one of the first four tools in the toolbar (cf. Area Selection Tools). For linear selections (Straight, Segmented and Freehand lines, cf. Line Selection Tools) length and angle (straight lines only) are also calculated. For Point selections (cf. Point Tool and Multi-point Tool), the X and Y coordinates are recorded. Note that Measure... [m] will paint (invasively) a mark over the measured point in foreground color unless Mark Width in the Point Tool options dialog box is set to zero (cf. Point Tool).

With RGB images, results are calculated using brightness values. RGB pixels are converted to brightness values using the formula:

\[
\text{value} = \frac{(\text{red} + \text{green} + \text{blue})}{3}
\]

If Weighted RGB Conversions is checked in Edit ⊿ Options ⊿ Conversions, the following conversion formulas are used:

\[
\begin{align*}
\text{value} &= 0.299 \times \text{red} + 0.587 \times \text{green} + 0.114 \times \text{blue} \\
\text{value} &= 0.299 \times \text{red} + 0.587 \times \text{green} + 0.114 \times \text{blue}
\end{align*}
\]

Intensity statistics (Mean, Modal, Median, Min. & Max. Gray Value, Standard Deviation and Integrated Density) can be performed on area, line and multi-point selections.

With area selections, the following parameters can be recorded: Area, Center of Mass, Centroid, Perimeter, Bounding Rectangle, Shape Descriptors, Fitted Ellipse, Feret’s Diameter, Skewness, Kurtosis and Area Fraction.

With line selections, the following parameters can be recorded: Length, Angle (straight lines only), and Bounding Rectangle. The mean, standard deviation, etc. are calculated from the values of the pixels along the line.

See also: Results Table, Analyze Particles..., Summarize, Distribution..., Set Measurements..., Batch ⊿ Measure...
Particle Analyzer (Analyze > Analyze Particles...). Features of thresholded images can be extracted by specifying suitable Size and Circularity ranges and/or by choosing if particles should be traced by their outer edge or by flood filling (Include Holes checkbox).

**Size** Particles with size (area) outside the range specified in this field are ignored. Values may range between 0 and ‘Infinity’. For spatial scaled images (cf. Set Scale...) values are expressed in physical size square units or in pixels if Pixel Units is checked. Enter a single value and particles smaller than that value will be ignored.

**Circularity** Particles with size circularity values outside the range specified in this field are also ignored. Circularity \(4\pi \frac{Area}{Perimeter^2}\) ranges from 0 (infinitely elongated polygon) to 1 (perfect circle).

**Show** This drop-down menu specifies which image (or overlay) should ImageJ display after the analysis (see Display options of Particle Analyzer). Note that with IJ1.44e and later, the particle analyzer will display a blank image when the count of detected particles is zero and Show is not Nothing. The font size and line width used can be change in a macro by using call("ij.plugin.filter.ParticleAnalyzer.setFontSize", size); and call("ij.plugin.filter.ParticleAnalyzer.setLineWidth", width); in a macro or ParticleAnalyzer.setFontSize(size); ParticleAnalyzer.setLineWidth(width); in a script or plugin.

**Nothing** Neither images nor overlays will be displayed.

**Outlines** 8-bit image containing numbered outlines of the measured particles (gray levels: Outlines:0; Labels:1; Background:255). If In situ Show is checked, the original image will be replaced by this image.

**Bare Outlines** 8-bit image containing simple outlines of the measured particles without labels (gray levels: Outlines:0; Background:255). If In situ Show is checked, the original image will be replaced by this image.

**Masks** 8-bit binary image containing filled outlines of the measured particles (gray levels: Masks:0; Background:255). If In situ Show is checked, the original image will be replaced by this image.

**Ellipses** 8-bit binary image containing the best fit ellipse (cf. Edit > Selection > Fit Ellipse) of each measured particle (gray levels: Ellipses:0; Background:255). If In situ Show is checked, the original image will be replaced by this image.

**Count Masks** 16-bit image containing filled outlines of the measured particles painted with a grayscale value corresponding to the particle number. If In situ Show is checked, the original image will be replaced by this image.

**Overlay Outlines** Displays outlines of the measured particles in the image overlay, removing previously added overlays will be removed.

**Overlay Masks** Displays filled outlines of the measured particles in the image overlay, removing previously added overlays will be removed.

**Display Results** If checked, the measurements for each particle will be displayed in the Results Table.

**Clear Results** If checked, any previous measurements listed in the Results Table will be cleared.

**Summarize** If checked, the particle count, total particle area, average particle size, area fraction and the mean of all parameters listed in the Set Measurements... dialog box will be displayed in a separate Summary table. Note that while single images 'Summaries' are output to the same Summary table, stack Summaries are printed in dedicated tables (named Summary of [stack title]). Also, note that descriptive statistics on Results measurements can be obtained at any time using the Summarize command.

**Add to Manager** If checked, the measured particles will be added to the ROI Manager...

**Exclude on Edges** If checked, particles touching the edge of the image (or selection) will be ignored.

**Include Holes** If checked, interior holes will be included. Disable this option to exclude interior holes and to measure particles enclosed by other particles. When this option is enabled, ImageJ finds the extent of each particle by tracing the outer edge. When it is disabled, ImageJ finds the extent by flood filling.

**Record Starts** This option allows plugins and macros to recreate particle outlines using the doWand(x,y) macro function. The CircularParticles macro demonstrates how to use this feature.

**In situ Show** If checked, the original image will be replaced by the binary mask specified in the Show drop-down menu. Note that this option does not apply to Overlay Outlines and Overlay Masks that are always displayed as non-destructive image overlays on the measured image.


**SEE ALSO:** Particle Remover plugin, 4/8-Connected Particle Analysis
27.3 Summarize

For each column in the Results Table, calculates and displays the mean, standard deviation, minimum and maximum of the values in that column. This command is also available by right-clicking on the Results Table.

<table>
<thead>
<tr>
<th>Label</th>
<th>Area</th>
<th>Mean</th>
<th>Mode</th>
<th>Min</th>
<th>Max</th>
<th>Perim</th>
<th>Circ</th>
<th>Feret</th>
<th>Long</th>
<th>Width</th>
<th>IntDen</th>
<th>Median</th>
<th>Major</th>
<th>Minor</th>
</tr>
</thead>
<tbody>
<tr>
<td>63 bbs.gif</td>
<td>5.100E1</td>
<td>1.884E2</td>
<td>1.360E2</td>
<td>1.280E2</td>
<td>2.480E2</td>
<td>3.200E2</td>
<td>3.000E2</td>
<td>2.480E2</td>
<td>1.600E1</td>
<td>1.600E1</td>
<td>1.600E1</td>
<td>1.884E2</td>
<td>1.884E2</td>
<td>1.884E2</td>
</tr>
</tbody>
</table>

Mean: 347.547, 187.227, 337.175, 128, 258.737, 67.902, 0.834, 24.875, 673.750, 100

50: 217.666, 19.042, 32.933, 0, 26.966, 26.560, 0.044, 9.516, 460.225, 10.311

Min: 1, 128, 128, 128, 128, 28.828, 0.046, 1.414, 128, 128, 128, 100

Max: 902, 235.915, 248, 248, 248, 132.225, 1, 52.292, 1765.020, 248, 100

27.4 Distribution... (See also: Analyze Particles..., Distribution...)

This command labels the active selection with the current measurement counter value, i.e., the number of rows present in the Results Table. Selection outline and label (at the selection centroid) are drawn invasively using current foreground/background colors. As for Edit ⊲ Draw [d], Use the Edit ⊲ Options ⊲ Line Width... command, or double click on the line tool, to change the width of selection's outline.

Selections can be labelled if they were previously analyzed (Analyze Particles... or Measure... [m] commands) and the parameter Centroid (cf. Set Measurements...) extracted in the Results table.

See also: Color Picker, XVII Embedding Color Annotations in Grayscale Images

27.6 Clear Results

Erases the results table and resets the measurement counter. This command is also available by right-clicking on the Results Table.

27.7 Set Measurements...

Use this dialog box to specify which measurements are recorded by Analyze ⊲ Measure... [m], ROI Manager's Measure command (cf. ROI Manager...) and Analyze ⊲ Analyze Particles... Measurements are performed on the current selection, the entire active image if no selection is present. For thresholded images, measurements can be restricted to highlighted pixels if Limit to Threshold is checked.

This command is also available by right-clicking on the Results Table.

The dialog contains two groups of checkboxes: The first group controls the type of measurements that are printed to the Results table. The second group controls measurement settings.
The eighteen checkboxes of the first group are:

- **Area**: Area of selection in square pixels or in calibrated square units (e.g., mm², pm², etc.) if Analyze⇒Set Scale... was used to spatially calibrate the image.

- **Mean gray value**: Average gray value within the selection. This is the sum of the gray values of all the pixels in the selection divided by the number of pixels. Reported in calibrated units (e.g., optical density) if Analyze⇒Calibrate... was used to calibrate the image. For RGB images, the mean is calculated by converting each pixel to grayscale using the formula gray = (red + green + blue)/3 or gray = 0.299 × red + 0.587 × green + 0.114 × blue if Weighted RGB Conversions is checked in Edit⇒Options⇒Conversions.

- **Standard deviation**: Standard deviation of the gray values used to generate the mean gray value. Uses the Results Table heading StdDev.

- **Modal gray value**: Most frequently occurring gray value within the selection. Corresponds to the highest peak in the histogram. Uses the heading Mode.

- **Min & max gray level**: Minimum and maximum gray values within the selection.

- **Centroid**: The center point of the selection. This is the average of the x and y coordinates of all of the pixels in the image or selection. Uses the X and Y headings.

- **Center of mass**: This is the brightness-weighted average of the x and y coordinates of all pixels in the image or selection. Uses the XM and YM headings. These coordinates are the first order spatial moments.

- **Perimeter**: The length of the outside boundary of the selection. Uses the heading Perim.. With IJ 1.44c and later, the perimeter of a composite selection is calculated by decomposing it into individual selections. Note that the composite perimeter and the sum of the individual perimeters may be different due to use of different calculation methods.

- **Bounding rectangle**: The smallest rectangle enclosing the selection. Uses the headings BX, BY, Width and Height, where BX and BY are the coordinates of the upper left corner of the rectangle.

- **Fit ellipse**: Fits an ellipse to the selection. Uses the headings Major, Minor and Angle. Major and Minor are the primary and secondary axis of the best fitting ellipse. Angle is the angle between the primary axis and a line parallel to the X-axis of the image. The coordinates of the center of the ellipse are displayed as X and Y if Centroid is checked. Note that ImageJ cannot calculate the major and minor axis lengths if Pixel Aspect Ratio in the Analyze⇒Set Scale... dialog is not 1.0. There are several ways to view the fitted ellipse:
  1. The Edit⇒Selection⇒Fit Ellipse command replaces an area selection with the best fit ellipse.
  2. The DrawEllipse macro draws (destructively) the best fit ellipse and the major and minor axis.
  3. Select Ellipses from the Show: drop-down menu in the particle analyzer (Analyze⇒Analyze Particles...) and it will draw the ellipse for each particle in a separate window.

- **Shape descriptors**: Calculates and displays the following shape descriptors:
  - **Circularity**: 4π × Area / π × MajorAxis^2 with a value of 1.0 indicating a perfect circle. As the value approaches 0.0, it indicates an increasingly elongated ellipse. Values may be valid for very small particles. Uses the heading Circ.
  - **Aspect ratio**: The aspect ratio of the particle’s fitted ellipse, i.e., MajorAxis / MinorAxis. If Fit Ellipse is selected the Major and Minor axis are displayed. Uses the heading AR.
  - **Roundness**: 4 × MinorAxis / (MajorAxis)^2 or the inverse of Aspect Ratio. Uses the heading Round.
  - **Solidity**: 4π × Area / π × ConvexArea. Note that the Edit⇒Selection⇒Convex Hull command makes an area selection convex.

- **Feret’s diameter**: The longest distance between any two points along the selection boundary, also known as maximum caliper. Uses the heading Feret. The angle (0-180 degrees) of the Feret’s diameter is displayed as FeretAngle, as well as the minimum caliper diameter (MinFeret). The length of the object’s projection in the X (FeretX) and Y (FeretY) direction is also displayed (see also Feret’s Diameter macro and Chamfer distances and Geodesic diameters plugin).

- **Integrated density**: The sum of the values of the pixels in the image or selection. This is equivalent to the product of Area and Mean Gray Value. With IJ 1.44c and later, Raw integrated density (sum of pixel values) is displayed under the heading RawIntDen when Integrated density is enabled. The Dot Blot Analysis tutorial demonstrates how to use this option to analyze a dot blot assay.

- **Skewness**: The third order moment about the mean. The documentation for the Moment Calculator plugin explains how to interpret spatial moments. Uses the heading Skew.

- **Kurtosis**: The fourth order moment about the mean. Uses the heading Kurt.

- **Area fraction**: For thresholded images is the percentage of pixels in the image or selection that have been highlighted in red using Image⇒Adjust⇒Threshold...⇒[T]. For non-thresholded images, the percentage of non-zero pixels. Uses the heading %Area.

- **Stack position**: The position (slice, channel and frame) in the stack or hyperstack of the selection. Uses the headings Slice, Ch and Frame.

N.B.: For line selections the heading Length is created. For straight line selections, Angle is recorded even if Fit Ellipse is unchecked. Also, note that measurements that do not apply to certain selection types may be listed as NaN, Infinity or -Infinity.

The second part of the dialog controls measurement settings:

- **Limit to threshold**: If checked, only thresholded pixels are included in measurement calculations. Use Image⇒Adjust⇒Threshold...⇒[T] to set the threshold limits. This setting affects only thresholded images (see Settings and Preferences).
Display label If checked, the image name and slice number (for stacks) are recorded in the first column of the Results Table, e.g., mri-stack.tif:9. For renamed selections (Edit ➤ Selection ➤ Properties... [y]) or selections measured via ROI Manager’s measure command (see ROI Manager...), the selection label is appended, e.g., blobs.gif:0339-0163 or blobs.gif:mySelection.

Invert Y coordinates If checked, the XY origin is assumed to be the lower left corner of the image window instead of the upper left corner (see also Image ➤ Properties... [P]).

Scientific notation If checked, measurements are displayed in scientific notation, e.g., 1.48E2.

Add to Overlay If checked, measured ROIs are automatically added to the image overlay. Each measured selection will be displayed with an accompanying numeric label, matching its row in the Results Table. Selections color can be changed in Edit ➤ Options ➤ Colors..., or by double clicking on the Point Tool. The numeric label is defined by the “Show All” color in ROI Manager’s More ➤ Options... widget.

Redirect to The image selected from this popup menu will be used as the target for statistical calculations done by Analyze ➤ Measure... [m] and Analyze ➤ Analyze Particles... commands. This feature allows you to outline a structure on one image and measure the intensity of the corresponding region in another image.

Decimal places This is the number of digits to the right of the decimal point in real numbers displayed in the Results Table and in Histogram windows (Analyze ➤ Histogram [h]).

27.8 Set Scale...

Use this dialog to define the spatial scale of the active image so measurement results can be presented in calibrated units, such as mm or µm. Before using this command, use the straight line selection tool to make a line selection that corresponds to a known distance. Then, bring up the Set Scale... dialog, enter the Known Distance and unit of measurement, then click ‘OK’. ImageJ will have automatically filled in the Distance in Pixels field based on the length of the line selection.

Setting Pixel Aspect Ratio to a value other than 1.0 enables support for different horizontal and vertical spatial scales, e.g., 100 pixels/cm horizontally and 95 pixels/cm vertically. To set the Pixel Aspect Ratio:

1. Measure the width and height (in pixels) of a digitized object with a known 1:1 aspect ratio.
2. Enter the measured width (in pixels) in Distance in Pixels. Enter the known width in Known Distance.
3. Calculate the aspect ratio by dividing the width by the height and enter it in Pixel Aspect Ratio.

When Global is checked, the scale defined in this dialog is used for all opened images during the current session instead of just the active image, see XXII Global Calibrations.

Click to Remove Scale resets Distance in Pixels field and Known Distance to zero and the Unit of Length to ‘pixel’.

See also: Three tutorials showing how to use this command: Examples of Image Analysis Using ImageJ by Larry Reinking, Measuring DNA Contour Lengths and Spatial Calibration (Fiji). The Copy_Pixel_Size plugin

27.9 Calibrate...

Use this dialog box to calibrate an image to a set of density standards, for example radioactive isotope standards or a calibrated optical density step tablet.

Note that to create a calibration curve, the left column must contain a list of measured mean pixel values and the right column must contain the same number of calibration standard values.

The ImageJ web site has a tutorial on Optical Density Calibration explaining how to calibrate an image to an optical density step tablet.

1. Before using this command, use Analyze ➤ Clear Results to reset the measurement counter and use one of the selection tools and Analyze ➤ Measure... [m] to record the mean gray value of each of the standards.
2. When finished making the measurements, select Analyze ➤ Curve Fitting... to display the Calibrate dialog box. To calibrate the image, enter the known standard values in the right column. The left column will be already populated with the measured mean gray values. Select a curve fitting method from the popup menu, enter the unit of measurement, and click ‘OK’ ImageJ will then display the calibration function on a separate window.
3. If the calibration function is not satisfactory, bring up the Calibrate... dialog box again and select a different curve fitting method.

In addition to the fourteen functions that can be chosen from the drop-down menu (described in Curve Fitting...) two other functions are available that do not require any measurement of OD standards:
Uncalibrated OD Causes ImageJ to convert gray values from 8-bit images to uncalibrated optical density values using the function \( \text{Unc. OD} = \log_{10}(255/\text{Pixel value}) \).

Pixel Inverter Linear function defined by \( \text{Inverted pixel} = \text{Bit-depth} - 1 - \text{Pixel value} \), with Bit-depth being 255 for 8-bit images or 65535 for 16-bit images.

See also: Global Calibrations, Image Types and Formats, Curve Fitting...

XXII GLOBAL CALIBRATIONS

Calibration settings related to spatial (pixel width, height and voxel depth), temporal (frame interval) and luminance (brightness) information can be set globally, i.e., can be applied to all images opened during the current session instead of just the active image. The Global flag can be set in three dialog prompts:

1. Image > Properties... [P] (pixel width, height, voxel depth, frame interval)
2. Analyze > Set Scale... (pixel width and height)
3. Analyze > Calibrate... (pixel intensity)

Once Global calibration is set, a ‘G’ is displayed in all image titles until ImageJ is closed. A warning message is displayed when a calibrated image with conflicting calibration is opened and the Global option is enabled.

Choose Disable Global Calibration to stop using global settings or Disable these Messages to keep respecting global settings, ignoring the calibration of the newly open image.

27.10 Histogram [h]

Calculates and displays a histogram of the distribution of gray values in the active image or selection.

The X-axis represents the possible gray values and the Y-axis shows the number of pixels found for each gray value. The horizontal LUT bar below the X-axis is scaled to reflect the display range of the image \([34]\). The total pixel Count is also calculated and displayed, as well as the Mean, standard deviation (Std Dev), minimum (Min), maximum (Max) and modal (Mode) gray value.

Use the List or Copy buttons to save the histogram data. Click on Log to display a log-scaled version of the histogram (overlaid in gray).

With any image type, an options dialog can be called with \( \text{Hist} \) or by holding \( \text{Alt} \) while clicking on Analyze > Histogram [h].

- **Bins**: Specifies the number of bins.
- **Use min/max**: If checked, the X-axis range is determined by the minimum and maximum values in the image or selection. If unchecked, \( X \text{ Min} \) and \( X \text{ Max} \) values can be or specified to fix the X-axis range.
- **Y Max**: Fixes the Y-axis range. Type ‘Auto’ to have the range determined by the largest bin count.

The getHistogram() and Plot.getValues() macro functions can be used to get the ‘value’ and ‘Count’ data displayed when you click the List button (cf. (6) Obtaining Histogram Lists).

27.11 Plot Profile [k]

Displays a two-dimensional graph of the intensities of pixels along a line or rectangular selection. The X-axis represents distance along the line and the Y-axis is the pixel intensity. NaNs values in 32-bit images (see Image Types and Formats) are ignored.

For rectangular selections or line selections wider than one pixel, displays a ‘column average plot’, where the X-axis represents the horizontal distance through the selection and the Y-axis the vertically averaged pixel intensity.
To average horizontally, hold Alt K or check Vertical Profile in Edit ⊗ Options ⊗ Profile Plot Options...

To obtain profiles of several selections in a single plot use the ROI Manager’s Multi Plot command (Analyze ⊗ Tools ⊗ ROI Manager...). Other types of area selections such as oval or freehand ROIs can be profiled by first running Edit ⊗ Selection ⊗ Area to Line, which will convert these ROIs to line selections.

Use the List, Save... or Copy... buttons to view and save the profile data. Use Edit ⊗ Options ⊗ Profile Plot Options... to adjust how plots are generated.

See also: Rectangular Selection Tool, Line Selection Tools, Plot Z-axis Profile..., Surface Plot..., Dynamic Profiler, Oval Profile Plot, Radial Profile Plot, Radial Profile Extended plugins, StackProfilePlot macro

27.12 Surface Plot...

Displays a three-dimensional graph of the intensities of pixels in a grayscale or pseudo color image (non-RGB images). The plot is based on the existing rectangular selection or on the entire image if no selection is present. A stack of plots can be produced when the source image is a stack or hyperstack. In this case, closing the plot stack window will abort the plotting process.

Polygon Multiplier Adjusts the number of profiles used to generate the plot.

Draw Wireframe If checked, the outline of each profile will be drawn in black.

Shade If checked, a shaded plot will be generated using the LUT of source image.

Draw Axis If checked, the three axis will be drawn and labelled.

Source Background is Lighter If checked, lighter areas in the source image will represent lower elevations (valleys) while darker areas in the source image will represent higher elevations (peaks).

Fill Plot Background with Black If checked, the plot is drawn with a black background, otherwise white will be used.

One Polygon Per Line If checked, all polygons will be drawn.

Smooth If checked, sharp fluctuations will be smoothed. Note that some plots can be further improved by adjusting the contrast of the source image or smoothing it.

See also: Plot Profile [k], Interactive 3D Surface Plot plugin (it works with all image types and viewing angle, perspective, scale, lighting and smoothing can be interactively adjusted), 3D Color Inspector/Color Histogram

27.13 Gels

Use the commands in this submenu to analyze one-dimensional electrophoretic gels. These commands use a simple graphical method that involves generating lane profile plots, drawing lines to enclose peaks of interest, and then measuring peak areas (i.e., definite integrals) using the Wand Tool... Note that this technique cannot be used to compare bands on different gels unless gels are calibrated to known standards.

The commands listed in the this submenu are:

Select First Lane Requires a rectangular selection. Note that lanes are assumed to be vertical unless the width of the initial selection is at least twice its height.

Select Next Lane To be used after the first rectangular ROI is moved over the adjacent lanes. Note that all selections must have the same dimensions.

Plot Lanes Generates the lane profile plots. ImageJ assumes that only one plot is created per analysis. As a consequence, re-running this command more than once within the same analysis will cause an error message: “You must first use the ‘Select First Lane’ command”. To recreate plotted profiles use the Re-plot Lanes command.

Re-plot Lanes Recreates the lane profile plots. If Plot Lanes has not yet been run an error message is displayed: “The data needed to re-plot the lanes is not available”.

Reset Resets the analysis.

Label Peaks Uses the area measurements obtained with the Wand Tool to label lane peaks (see Gel Analyzer Options...).
Gel Analyzer Options... Use this dialog to control the behavior of the Gel Analyzer.

**Vertical / Horizontal scale factor** Specifies the scale factor at which the lane profile plots are displayed.

**Uncalibrated OD** If checked, ImageJ will convert gray values to uncalibrated optical density values using the function: \( \text{Unc. OD} = \log_{10}(255/\text{pixel value}) \). Note that images can be calibrated to, e.g., a calibrated optical density step tablet using the Analyze\>Calibrate... command.

**Label With Percentages** If checked, the Label Peaks command will print to the Results table the peak percentage and use it to label the plot. The percentage value is obtained by dividing the area of each peak by the sum of all measured peaks from all lanes.

**Invert Peaks** If checked, peaks will be inverted, i.e., bands darker than background will have positive peaks, bands lighter than background will have negative peaks. This setting does not change the analysis (see Image\>Lookup Tables\>Invert LUT) command.

For practice, refer to the video tutorial on the ImageJ wiki page and use the File\>Open Samples\>Gel sample image (1-D gel) to perform the following steps. Note that a copy of the gel image with the lane outlines can be created at any point using the Image\>Overlay\>Flatten [F] command.

1. Use the rectangular selection tool to outline the first lane. This should be the left most lane if the lanes are vertical or the top lane if the lanes are horizontal.
2. Select Gels\>Select First Lane (F1) and the lane will be outlined and ‘Lane 1 selected’ displayed in the status bar.
3. Move the rectangular selection right to the next lane (or down if the lanes are horizontal) and select Gels\>Select Next Lane (F2). The selected lane is outlined and labelled, and ‘Lane n selected’ is displayed in the status bar.
4. Repeat the previous step for each remaining lane.
5. Select Gels\>Plot Lanes (F1) to generate the lane profile plots.
6. Use the Straight Line Selection Tool to draw base lines and/or drop lines so that each peak of interest defines a closed area (ImageJ will automatically switch to the Straight Line tool). Note that you can hold Shift to constrain lines to be either horizontal or vertical. To access to all the lanes, it may be necessary to scroll the image vertically using the ScrollBar (Hold down the space bar to temporarily switch to this tool).
7. For each peak, measure the size by clicking inside the peak with the Wand Tool. If necessary, scroll the image vertically by holding down the space bar and dragging.
8. Select Gels\>Label Peaks to label each measured peak with its size as a percent of the total size of the measured peaks.

See also: Calibrate..., SinglePanelGelAnalyzer macro, Video tutorial on ImageJ wiki, Luke Miller’s tutorial, Dot Blot Analysis, Dot Blot Analyzer toolset

### 27.14 Tools

This submenu provides access to various image analysis plugins.

#### 27.14.1 Save XY Coordinates...

Writes to a text file the XY coordinates and pixel value of all non-background pixels in the active image. Background is assumed to be the value of the pixel at the upper left corner of the image. For grayscale images, writes three values per line \((x, y, \text{and value})\), separated by spaces. For RGB images, writes five values per line \((x, y, \text{red, green and blue})\). The origin of the coordinate system is at the lower left corner of the image.

The number and percentage of non-background pixels is printed to the Log Window if Suppress Log output is not checked.

#### 27.14.2 Fractal Box Count...

This command is used to estimate the fractal dimension \((D)\) of a binary image. \(D\) can be used as a measure of pattern complexity (cell shape, vascularization, textures, etc.) and is specially relevant in cases in which Euclidean measures such as diameter or length are not good descriptors of complexity.

The command counts the number of boxes of an increasing size needed to cover a one pixel binary object boundary and implements the method described in T. G. Smith, Jr., G. D. Lange and W. B. Marks, Fractal Methods and Results in Cellular Morphology, *J Neuroscience Methods*, 69:1123–126, 1996.

A plot is generated with the log of size on the X-axis and the log of count on the Y-axis and the data is fitted with a straight line. The slope \((S)\) of the line is the negative of the fractal dimension, i.e., \(D = -S\). ‘Size’ \((S)\) and ‘count’ \((C)\) are printed to the Results table. Refer to the source code for additional information.

See also: Fractal Dimension and Lacunarity plugin

#### 27.14.3 Analyze Line Graph

ImageJ can be used to recover numeric coordinate data from scanned line graphs using the following procedure. Steps 2 and 3 are not necessary for binary (black and white) graphs. For practice, use the File\>Open Samples\>Line Graph sample image.
1. Open the image containing the graph.
2. Open the Threshold... [T] tool (Shift T). Adjust the threshold so the graph is highlighted in red.
3. Click on Apply (make sure foreground is black and background is white).
4. Use the Elliptical Selection Tool as an eraser (press and hold the mouse button) to isolate a single curve (NB: background color must be white, cf. Color Picker... [K]).
5. Select the curve by clicking to the left of it with the Wand Tool.
6. Use Edit Clear Outside to erase everything but the curve.
7. Use Analyze Tools Analyze Line Graph to get the XY coordinates.

ImageJ’s curve fitter (Analyze Tools Curve Fitting...) – ImageJ 1.44i.

27.14.4 Curve Fitting...

ImageJ’s curve fitter provides a very simple tool for fitting various functions to X- and Y-data. The typical usage of this command is listed below.

1. Tabular data is entered or copied in the input window or alternatively, a two column text file is opened by clicking on the Open button. Values may be separated by spaces, tabs, commas or semicolons.
2. The function to be fit is selected from the drop-down menu. Fourteen built-in functions are available. User defined functions with up to six parameters are also possible by choosing "User-defined". In this case, Formula and Fitting Options must be specified by the user.
3. Once the Fit button is pressed, ImageJ displays a graph of the data with the fitted curve as well as a log window containing information about the fit and the values of the fitted parameters if Show Settings is checked.


<table>
<thead>
<tr>
<th>Function</th>
<th>Formula</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Straight Line</td>
<td>( y = a + bx )</td>
<td>cf. Pixel Inverter (Calibrate...)</td>
</tr>
<tr>
<td>2nd Degree Polynomial</td>
<td>( y = a + bx + cx^2 )</td>
<td></td>
</tr>
<tr>
<td>3rd Degree Polynomial</td>
<td>( y = a + bx + cx^2 + dx^3 )</td>
<td></td>
</tr>
<tr>
<td>4th Degree Polynomial</td>
<td>( y = a + bx + cx^2 + dx^3 + ex^4 )</td>
<td></td>
</tr>
<tr>
<td>5th Degree Polynomial</td>
<td>( y = a + bx + cx^2 + dx^3 + ex^4 + fx^5 )</td>
<td>Via the &quot;User-defined&quot; option</td>
</tr>
<tr>
<td>Exponential</td>
<td>( y = a \times e^{bx} )</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>( y = ax^b )</td>
<td></td>
</tr>
<tr>
<td>Log</td>
<td>( y = a \times \ln(bx) )</td>
<td></td>
</tr>
<tr>
<td>Gamma Variate</td>
<td>( y = a \times (x - h)^c \times e^{-(x-h)^c} )</td>
<td></td>
</tr>
<tr>
<td>Rodbard</td>
<td>( y = \frac{d}{1+e^{(x-a)/b}} )</td>
<td>[35]</td>
</tr>
<tr>
<td>Exponential with Offset</td>
<td>( y = a \times e^{-(x+b)} + c )</td>
<td></td>
</tr>
<tr>
<td>Gaussian</td>
<td>( y = a + (b - a) \times e^{-\frac{(x-c)^2}{2a^2}} )</td>
<td>[35]</td>
</tr>
<tr>
<td>Exponential Recovery</td>
<td>( y = a \times (1 - e^{-(x+k)}) + c )</td>
<td>cf. FRAP_Profiler plugin</td>
</tr>
</tbody>
</table>

4. Click Apply to create a 32-bit copy of the current image transformed with the chosen function.

See also: Profile Plot Options..., CurveFittingDemo, RodbardSigmoidFit and PlotSigmoid-Derivatives macros

27.14.5 ROI Manager...
The ROI Manager (Analyze»Tools»ROI Manager…) – ImageJ 1.45i.

Delete Deletes the selected ROIs from the list. Deletes all the ROIs if none is selected.

Rename… Renames the selected ROI. The chosen string will be used as Edit Mode label if Use ROI names as labels is checked in the More»Options… dialog. The selected ROI can also be renamed using the Properties… button.

Measure Measures the selected ROIs, or if none is selected, all ROIs on the list. Use Analyze»Set Measurements… to specify the parameters to measure.

Deselect Deselects any selected ROIs on the list. Delete, Measure, More»Save…, and More»Combine work with all ROIs on the list when none are selected.

Properties… Opens a dialog box (depicted in ROI Manager) in which is possible to assign a contour color (Stroke color) of a certain Width or a Filling color. With text selections (see Text Tool), it is also possible to specify the Font size and Justification. As explained for Edit»Selection>Properties…, selections can be either filled or contoured, but not both. The nine default selection colors (black, blue, cyan, green, magenta, orange, red, white, yellow) can be typed textually. Any other color must be specified using hex notation (see XIX Hexadecimal Color Values). If multiple ROIs have been selected from the Manager’s list (see XXIII Selecting Multiple ROIs in the ROI Manager), properties will be applied to the specified Range of selections.


Show All Toggles a non-destructive overlay that outlines all ROI Manager selections. If Edit Mode is active selections will also be labelled. In this case, click on a label (selection number) in the overlay to activate the corresponding selection. That selection can then be moved or edited and the overlay will be dynamically updated. The color and behavior of the Show All overlay can be changed in the More»Options… dialog box.

Edit Mode Toggles selection labels displayed by Show All. As mentioned, clicking on a label activates its selection allowing edit operations.

More» Displays a drop-down menu with several additional commands (this menu is also available when right-clicking on the ROI Manager’s list area):

Open... Opens a .roi file and adds it to the list or opens a ZIP archive (.zip file) and adds all the selections contained in it to the list. Use the Open All macro to add all the .roi files in a folder.

Save... Saves the selected ROI as a .roi file. If no ROIs are selected, saves all the ROI Manager selections in a ZIP archive.

Fill Alias for Edit»Fill [f].

Draw Alias for Edit»Draw [d].

AND Uses the conjunction operator on the selected ROIs to create a composite selection. All ROIs are considered if none is selected.

OR (Combine) Uses the union operator on the selected ROIs to create a composite selection. Combines all ROIs if none is selected.

XOR Uses the exclusive or operator on the selected ROIs to create a composite selection [36]. All ROIs are considered if none is selected.

Split Splits the current selection (it must be a composite selection) into its component parts and adds them to the ROI Manager.

Add Particles Adds objects segmented by the particle analyzer to the ROI Manager. Requires that Record Starts be checked in the Analyze»Add to Manager dialog box. Particle analyzer objects can also be added to the ROI Manager by checking Add to Manager in the Analyze Particles dialog box.

Multi Measure Measures all the ROIs on all slices in the stack, creating a Results table with either one row per slice (if One Row Per Slice is checked in the dialog) or one row per measurement [37].

Multi Plot Runs Analyze»Plot Profile [k] on the selected ROIs on a single graph [38]. All selections are plotted if none is selected. When plotting less than seven selections colored lines are drawn: blue (ROI1), green (ROI2), magenta (ROI3), red (ROI4), cyan (ROI5) and yellow (ROI6). Profiles with more selections are drawn in gray tones. While Analyze»Plot Profile [k] requires a line or rectangular selection, Multi Plot accepts all types of selections by first running Edit»Selection»Area to Line, which converts oval and freehand ROIs to line selections.

Sort Sorts the list in alphanumerical order.

Specify… Alias for Edit»Selection»Specify…

Remove Slice Info Removes the information in the ROI names that associates them with particular stack slices (see ROI Manager).


Options… Displays a dialog box (depicted in ROI Manager) that allows you to set several ROI Manager settings:
Logical operations using the ROI Manager (Analyze ⊂ Tools ⊂ ROI Manager...).

"Show All" Color... Defines the color in which the ROIs are highlighted when Show All is pressed in ROI Manager panel.

Associate "Show All" ROIs with slices If checked, Show All will only reveal ROIs when browsing their respective slice. If unchecked, ROIs are shown in all stack slices.

Restore ROIs centered If checked, ROIs opened by More ⊂ Open... are centered on the image canvas. This option avoids loaded ROIs to be displayed out of boundaries when the image has been resized.

Use ROI names as labels If checked, ROI names are used as selection labels when in Edit Mode. If unchecked, the ROI position in the Manager’s list is used. Selections can be renamed using either Rename or Properties...

See also: Analyze ⊂ Set Scale..., Image ⊂ Properties... [P], XXII Global Calibrations

27.14.6 Scale Bar...

Draws a labelled spatial calibration bar.

Location Adjusts the position of the calibration bar. If there is a selection, the bar is initially drawn at the selection.

Bold Text/ Serif Font Specify if label should be typeset in boldface/serif typeface.

Hide Text If checked the bar is drawn without label.

Overlay If checked the bar is created as a non-destructive image overlay (see Image ⊂ Overlay submenu). If unchecked, the scale bar is drawn invasively. Note that previously added overlays are removed when using this option.

Number of Labels Adjusts the total number of values displayed.

Decimal Places Adjust the number of decimal places present in the labels.

Font Size Adjusts labels font size (labels are drawn bold if Bold Text is checked).

Zoom Factor Magnifies the entire calibration bar canvas. Enter a value less than 1 to reduce the bar size.

The Calibration Bar Macros can be used to add a calibration bar to a stack or to all the images and stacks in a folder.

See also: Calibrate..., XXII Global Calibrations
28 Plugins

28.1 Macros

This submenu contains commands for installing, running and recording macros, as well as any macro commands added by Plugins>Macros>Install... Macros contained in a file named StartupMacros.txt, in the macros folder, are automatically added to this submenu when ImageJ starts up. By design, only one set of macros can be installed at a time. As such, the last set of macros installed by Plugins>Macros>Install... (or by the Toolset Switcher) will always replace previously installed macros.

28.1.1 Install...

Adds one or more macros contained in a file to the bottom of this submenu. To install a set of macros, and at the same time view their source code, open the macro file with File>Open and use ImageJ Editor’s Macros>Install Macros command. Macros in the file ImageJ/macros/StartupMacros.txt are automatically installed when ImageJ starts up. Similarly, with ImageJ 1.44f and later, newly opened macro sets with two or more macros are also automatically installed in this menu.

See also: Toolset Switcher

28.1.2 Run...

Loads and runs a macro without opening it in ImageJ Editor. To run a macro, and at the same time view its source code, open it with File>Open and use the editor’s Macros>Run Macro command.

28.1.3 Startup Macros...

Opens ImageJ/macros/StartupMacros.txt. The same file can be opened by holding \(\text{Shift}\) while selecting Startup Macros from the \(\text{Plugins} ⊲ \text{Shortcuts} ⊲ \text{Macros}⊙ \text{Toolset Switcher}.\)

28.1.4 Record...

Opens the ImageJ command recorder. To create a macro, open the recorder, use one or more ImageJ commands, then click \(\text{Create}.\) When the recorder is open, each menu command you use generates a macro run() function call. The run() function has one or two string arguments. The first is the command name. The optional second argument contains dialog box parameters. Examples:

- Create a rectangular, oval or line selection and the recorder will generate a makeRectangle(), makeoval() or makeLine() function call.
- Click on Auto or Set in the ImageJ>Adjust>Threshold \(\text{T}\) window to generate a setThreshold() call, and on Reset to generate a resetThreshold() call.
- Select an image from the Window menu to generate a selectWindow() call.

Click in the ImageJ>Color>Color Picker... \(\text{K}\) window to generate call.

Note that you can interact with the recorder window by deleting or commenting lines of code or pasting text from ImageJ Editor. This may be specially useful when writing your own macros or to generate simple ‘Session Logs’. In this case, you would start the Recorder and let ImageJ keep track of the performed actions by generating macro code.


28.2 Shortcuts

This submenu contains commands for creating keyboard shortcuts and for installing and removing plugins.

28.2.1 List Shortcuts...

This command generates a table with the ImageJ keyboard shortcuts in one column and the commands they call in another. Commands prefixed by ‘*’ refer to shortcuts created with Create Shortcuts... Commands prefixed by ‘ ’ refer to installed macros (listed in Plugins>Macros>submenu) and override default ImageJ hot-keys.

Note that, as mentioned previously, you do not have to hold down \(\text{Shift}\) to use a keyboard shortcut. E.g., to open an image press \(\text{Ctrl} + \text{O}\). See also: Keyboard Shortcuts, Create Shortcuts...

28.2.2 Create Shortcuts...

Assigns a keyboard shortcut to an ImageJ menu command and lists the shortcut in the Shortcuts submenu. Select the command from the popup menu and enter the shortcut in the text field. A shortcut can be a lower or uppercase letter or ‘F1’ through ‘F12’. Use Plugins>Utilities>List Shortcuts... to get a list of shortcuts that are already being used.
28.2.3 Install Plugin...

Installs a plugin in a user-specified submenu. Plugins with a showAbout() method are also automatically added to the Help> About Plugins> submenu.

Use the first popup menu to select the plugin and the second to select the submenu it is to be installed in. The command must be different from any existing ImageJ command. Shortcut (optional) must be a single letter or 'F1' through 'F12'. Argument (optional) is the string that will passed to the plugin's run method.

28.2.4 Remove...

Removes commands added to the Shortcuts submenu by Create Shortcuts... Also removes commands added by Install Plugin... and removes plugins installed in the Plugins menu. The menus are not updated until ImageJ is restarted.

28.3 Utilities

28.3.1 Control Panel... [U]

This command [19] opens a window containing ImageJ commands in a hierarchical tree structure. Click on a leaf node to launch the corresponding ImageJ command (or plugin). Double click on a tree branch node (folder) to expand or collapse it. Click and drag on a tree branch node (folder) to display its descendants in a separate (child) window. In a child window, click on 'Show Parent' to re-open the parent window.

28.3.2 Find Commands... [L]

The quickest way to find a command without having to navigate through all the menus [10]. Evoke the prompt by pressing (as in 'command Launchers', or 'Locator'). If you type part of a command name, the list will only show commands that match that substring. If only a single command matches then that command can be run by pressing Enter. If multiple commands match, click with the mouse to select a command to run. Alternatively pressing the up or down keys will move keyboard focus to the list and the selected command can be run by pressing Enter. Pressing (or 'Escape') switches focus back to the prompt. Double-clicking on a command will run that command. Pressing Esc closes the window.

Show full information If checked, the Command Finder will display the location of the listed menu entries.

Fuzzy matching (Fiji only) Activates approximate string matching. Useful if you are not sure about the command spelling.

Close when running If checked, the Command Finder will dismiss after choosing Run or pressing Enter.

Export Prints the filtered list of commands to an ImageJ table.

See also: Control Panel... [U], Search..., Finding Commands

28.3.3 Search...

Searches for macros (.txt, .ijm), scripts (.js, .py, .rb, .clj, .bsh), plugins source (.java) and .html files containing a particular string.

Search is performed recursively (subdirectories are included) and results displayed in the Log Window. In the Log window, double click on a file path to have it open.

Search contents Specifies if the search should be restricted to filenames or extended to file contents. If checked, the line number where the string was found is displayed.

Ignore case Specifies if the search should be case-insensitive.

Search macros folder Extends the search scope to ImageJ/macros/.

Search plugins folder Extends the search scope to ImageJ/plugins/.

Search scripts folder Extends the search scope to ImageJ/scripts/ (if present).


Note that you can perform searches in other directories by choosing none of the folders above mentioned. In this case, you will be asked to choose a target directory on a second dialog prompt.

See also: Search.txt, the macro in ij.jar implementing this command, Find Commands... [L], Finding Commands

28.3.4 Monitor Events...

By implementing the IJEventListener, CommandListener and ImageListener interfaces, this command is able to monitor foreground and background color changes, tool switches, Log window closings, command executions and image window openings, closings and updates.

See also: Debug mode (Edit>Options>Misc...)
28.3.5 **Monitor Memory...**

Displays a continuously updated graph of ImageJ's memory utilization, which can be useful for detecting memory leaks. Memory usage and running threads are displayed above the graph. Clicking on the window will reclaim unused memory by running the Java garbage collector (cf. Status bar).

Ideally you should be able to open several images, process them, close them, and the amount of memory used will be the same as when you started.

28.3.6 **Capture Screen [g]**

Copies the screen to an RGB image and displays that image a new window. Holding `Ctrl` and `Shift` together will capture the screen while a modal dialog box is active if the dialog is based on ImageJ's `GenericDialog` class.

28.3.7 **Capture Image**

Copies a WYSIWYG version of active image to an RGB image and displays that image a new window.

**See also:** Flatten [F]

28.3.8 **ImageJ Properties...**

This command displays various ImageJ properties (Java version, OS name and version, path separator, location of directories, screen size, etc.) in a text window. Holding `Alt` lists all Java properties.

**See also:** Status bar, Help> About ImageJ...

28.3.9 **Threads...**

This command lists, in a text window, the currently running threads and their priorities.

28.3.10 **Benchmark**

Runs 62 image processing operations on the current image and displays the elapsed time in the ImageJ status bar. Additional benchmarks, test results, and source code are available in the `Benchmarks` package of plugins.

**See also:** FAQ's on the ImageJ Documentation Wiki

28.3.11 **Reset...**

Use this command to unlock a locked Image, or to reclaim memory used by the clipboard and undo buffers (cf. Undo and Redo).

### New

This submenu contains commands opening editor windows that can be used to edit and run macros, scripts and plugins. It also has a command that opens a text window of a specified size and a command that opens a table that macros can write to. The editor windows opened by `Plugin`, `Plugin Filter` and `Plugin Frame` contain prototype Java code for the three types of plugins supported by ImageJ.

**See also:** ImageJ Editor, Extending ImageJ

28.4.1 **Macro**

Opens a blank editor window with the title 'Macro.txt'.

**See also:** Macros, ImageJ Editor, Text Window..., File> New> Text Window [N]

28.4.2 **JavaScript**

Opens a blank editor window with the title 'Script.js'.

**See also:** Scripts, ImageJ Editor

28.4.3 **Plugin**

Opens an editor window containing a prototype plugin that implements the `PlugIn` interface. Plugins of this type open, capture or generate images. The prototype displays "Hello world!" in the ImageJ window. Press `Ctrl` and `F` (File> Run Macro) to compile and run it. Note that the name you choose for the plugin should include at least one underscore. Another example is the Step Maker plugin.

28.4.4 **Plugin Filter**

Opens an editor window containing a prototype plugin that implements the `PlugInFilter` interface. Plugins of this type process the active image. The prototype inverts the active image twice. Another example is the Image Inverter.

28.4.5 **Plugin Frame**

Opens an editor window containing a prototype plugin that extends the `PlugInFrame` class. Plugins of this type displays a window containing controls such as buttons and sliders. The prototype opens a window containing a text area. Another example is the IP Demo plugin.
28.4.6  Text Window...

Opens a text window of a specified size that macros can write to. PrintToTextWindow, Clock and ProgressBar are examples of macros that write to a text window.

SEE ALSO: Plugins ⊿ New ⊿ Macro, File ⊿ New ⊿ Text Window [N]

28.4.7  Table...

Opens a blank table, similar to the Results table, that macros can write to. SineCosineTable2 is an example of such a macro.

SEE ALSO: Plugins ⊿ New ⊿ Text Window

28.5  Compile and Run...

Compiles and runs a plugin. Runs a plugin if the name of the selected file ends in .class. Requires that ImageJ be running on a Java Virtual Machine that includes the javac compiler, which is contained in the Tools.jar archive. Tools.jar is included with the Windows and Linux versions of ImageJ bundled with Java, and it is pre-installed on Mac OS X. Troubleshooting information can be found under 'Compiling Plugins' in the Linux and Windows release notes.

The Edit ⊿ Options ⊿ Compiler... command can be used to configure the javac compiler. Since ImageJ 1.44c and later, Compile and Run... adds the Bio-Formats plugin (loci_tools.jar) to the Java compiler's classpath.

29  Window

This menu contains four commands plus a list of open ImageJ windows. The currently active image will have a checkmark next to its name. To activate a window, pull down this menu and select the window by name.

29.1  Show All [ ]

Makes all the windows associated with ImageJ visible.

29.2  Put Behind [tab]

Displays the next open image. Repeatedly press the tab key to cycle through all open images. Note that pressing [Enter] on any image will bring the ImageJ window to the foreground.

SEE ALSO: I Frontmost Window and Windows Activation

29.3  Cascade

Moves all open images to the left side of the screen, slightly offset from each other, and displayed in the order they are listed at the bottom of this menu.

29.4  Tile

 Shrinks all open image windows and repositions them to fit on the screen without overlapping.
30.1 ImageJ Website...
Opens the ImageJ home page.

30.2 ImageJ News...
Opens the News section of the ImageJ website.

30.3 Documentation...
Opens the Documentation section of the ImageJ website.

30.4 Installation...
Opens the Installation section of the ImageJ website specifically dedicated to the OS in which ImageJ is running, i.e., either Linux, Mac OS 9, Mac OS X or Windows. Worth reading are the sections Known Problems and Troubleshooting.

30.5 Mailing List...
Opens the ImageJ Interest Group page on the NIH LISTSERV facility. Here you can search the mailing list archives, post a message to the list, join or leave the list, or update options.

30.6 Dev. Resources...
Opens the Developer Resources section of the ImageJ website.

30.7 Plugins...
Opens the Plugins page on the ImageJ website, which lists more than 500 ImageJ plugins.

30.8 Macros...
Opens the macros directory on the ImageJ website, which contains more than 400 ImageJ macros.

30.9 Macro Functions...
Opens the Macro Functions reference page, an indispensable guide to the built in functions that can be called from the ImageJ macro language.

See also:

30.10 Update ImageJ...

See also: Installing and Maintaining ImageJ

30.11 Refresh Menus
Use this command to update ImageJ’s menus after adding (or removing) plugins or macros to the plugins folder. Prior to ImageJ 1.44b this command was named ‘Update Menus’.

30.12 About Plugins
This submenu displays information about some of the plugins in the ImageJ plugins folder. To be included in this submenu, a plugin must be packaged as a JAR file. There is an example at rsb.info.nih.gov/ij/plug-ins/jar-demo.html.

30.13 About ImageJ...
Opens an image containing information about the ImageJ version, the author, the website, Java version and memory available. Note that clicking in the status bar is a quicker way to show this information.

See also:

See also: Macros ⊥ Utilities ⊥ ImageJ Properties... ⊥ Status bar

The IJ User Guide — Booklet 147
Latest revision: 2011/12/27
### Part VI

#### Keyboard Shortcuts

The following table summarizes the keyboard shortcuts built into ImageJ. You can create additional shortcuts, or override built-in ones, by creating simple macros and adding them to the StartupMacros.txt. You can also assign a function key to a menu command using Plugins > Shortcuts > Create Shortcuts...

Several of these shortcuts accept key modifiers as described in Key Modifiers. Also note that, except when using the text tool, you do not need to hold down the control key to use a keyboard shortcut (cf. Edit > Options > Misc...).

See also: Using Keyboard Shortcuts, Finding Commands, Tools Shortcuts, KeyboardShortcuts.txt macro, demonstrating how assign shortcuts to custom macros

**List of ImageJ 1.45m built-in shortcuts.** This table can be obtained within ImageJ using the Plugins > Shortcuts > List Shortcuts... command.

<table>
<thead>
<tr>
<th>Command / Operation</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>New &gt; Image... [n]</td>
<td>F11</td>
<td>Create new image or stack</td>
</tr>
<tr>
<td>New &gt; Text Window [N]</td>
<td>F11</td>
<td>Create new text window</td>
</tr>
<tr>
<td>New &gt; System Clipboard [V]</td>
<td>F11</td>
<td>Create image from system clipboard</td>
</tr>
<tr>
<td>Open...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Next... [O]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Samples &gt; Blobs (25K)</td>
<td>F11</td>
<td>Open next image in folder</td>
</tr>
<tr>
<td>Close [w]</td>
<td></td>
<td>Close the active window</td>
</tr>
<tr>
<td>Save [s]</td>
<td></td>
<td>Save active image in Tiff format</td>
</tr>
<tr>
<td>Revert [r]</td>
<td>Return or [p]</td>
<td>Revert to saved version of image</td>
</tr>
<tr>
<td>Print... [p]</td>
<td></td>
<td>Print active image</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Undo [z]</td>
<td>F7</td>
<td>Undo last operation</td>
</tr>
<tr>
<td>Cut [x]</td>
<td>F2</td>
<td>Copy selection to internal clipboard and clear</td>
</tr>
<tr>
<td>Copy [c]</td>
<td></td>
<td>Copy selection to internal clipboard</td>
</tr>
<tr>
<td>Paste [v]</td>
<td></td>
<td>Paste contents of internal clipboard</td>
</tr>
<tr>
<td>Clear</td>
<td>F9</td>
<td>Erase selection to background color</td>
</tr>
<tr>
<td>Fill [f]</td>
<td></td>
<td>Fill selection in foreground color</td>
</tr>
<tr>
<td>Draw [d]</td>
<td></td>
<td>Draw selection</td>
</tr>
<tr>
<td>Invert [l]</td>
<td></td>
<td>Invert image or selection</td>
</tr>
<tr>
<td>Selection &gt; Select All [a]</td>
<td>F8</td>
<td>Select entire image</td>
</tr>
<tr>
<td>Selection &gt; Select None [A]</td>
<td>F8</td>
<td>Remove selection</td>
</tr>
<tr>
<td>Selection &gt; Restore Selection [E]</td>
<td>F8</td>
<td>Restore previous selection</td>
</tr>
<tr>
<td>Selection &gt; Properties... [y]</td>
<td>F8</td>
<td>Defines selection properties</td>
</tr>
<tr>
<td>Selection &gt; Add to Manager [t]</td>
<td>F8</td>
<td>Add selection to ROI Manager</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Adjust &gt; Brightness/Contrast... [C]</td>
<td>F4</td>
<td>Adjust brightness and contrast</td>
</tr>
<tr>
<td>Adjust &gt; Threshold... [T]</td>
<td>F4</td>
<td>Adjust threshold levels</td>
</tr>
</tbody>
</table>

**List of ImageJ 1.45m built-in shortcuts.** This table can be obtained within ImageJ using the Plugins > Shortcuts > List Shortcuts... command.

<table>
<thead>
<tr>
<th>Command / Operation</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Info... [i]</td>
<td></td>
<td>Display information about active image</td>
</tr>
<tr>
<td>Properties... [P]</td>
<td></td>
<td>Display image properties</td>
</tr>
<tr>
<td>Color &gt; Color Picker... [K]</td>
<td>F5</td>
<td>Open Color Picker</td>
</tr>
<tr>
<td>Stacks &gt; Next Slice [&gt;]</td>
<td>F5</td>
<td>Go to next stack slice</td>
</tr>
<tr>
<td>Stacks &gt; Previous Slice [&lt;]</td>
<td>F5</td>
<td>Go to previous stack slice</td>
</tr>
<tr>
<td>Stacks &gt; Reslice... [r]</td>
<td>F5</td>
<td>Reslice stack</td>
</tr>
<tr>
<td>Stacks &gt; Orthogonal Views [H]</td>
<td>F5</td>
<td>Toggle orthogonal view display</td>
</tr>
<tr>
<td>Stacks &gt; Tools &gt; Start Animation [L]</td>
<td>F5</td>
<td>Start/stop stack animation</td>
</tr>
<tr>
<td>Hyperstacks &gt; Channels Tool... [Z]</td>
<td>F5</td>
<td>Open the ‘Channels’ tool</td>
</tr>
<tr>
<td>Hyperstacks &gt; Hyperstacks</td>
<td>F5</td>
<td>Next hyperstack channel</td>
</tr>
<tr>
<td>Hyperstacks &gt; Hyperstacks</td>
<td>F5</td>
<td>Previous hyperstack channel</td>
</tr>
<tr>
<td>Crop [X]</td>
<td></td>
<td>Crop active image or selection</td>
</tr>
<tr>
<td>Duplicate... [D]</td>
<td>F8</td>
<td>Duplicate active image or selection</td>
</tr>
<tr>
<td>Scale... [S]</td>
<td></td>
<td>Scale image or selection</td>
</tr>
<tr>
<td>Zoom &gt; In [+]</td>
<td></td>
<td>Make image larger</td>
</tr>
<tr>
<td>Zoom &gt; Out [-]</td>
<td></td>
<td>Make image smaller</td>
</tr>
<tr>
<td>Zoom &gt; Original Scale [4]</td>
<td>F8</td>
<td>Revert to original zoom level</td>
</tr>
<tr>
<td>Zoom &gt; View 100% [5]</td>
<td>F8</td>
<td>Zoom to 1:1</td>
</tr>
<tr>
<td><strong>Process</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Smooth [S]</td>
<td>F10</td>
<td>3×3 unweighted smoothing</td>
</tr>
<tr>
<td>Repeat Command [R]</td>
<td>F9</td>
<td>Repeat previous command</td>
</tr>
<tr>
<td><strong>Analyze</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Measure... [m]</td>
<td>F11</td>
<td>Display statistics of active image / selection</td>
</tr>
<tr>
<td>Histogram [h]</td>
<td>F11</td>
<td>Display histogram of active image / selection</td>
</tr>
<tr>
<td>Plot Profile [p]</td>
<td>F11</td>
<td>Display density profile plot of active selection</td>
</tr>
<tr>
<td>Gels &gt; Select First Lane</td>
<td>F10</td>
<td>Select first gel lane</td>
</tr>
<tr>
<td>Gels &gt; Select Next Lane</td>
<td>F10</td>
<td>Select next gel lane</td>
</tr>
<tr>
<td><strong>Plugins</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Utilities &gt; Control Panel... [U]</td>
<td>F10</td>
<td>Open Control Panel</td>
</tr>
<tr>
<td>Utilities &gt; Capture Screen [q]</td>
<td>F10</td>
<td>Grab screenshot</td>
</tr>
<tr>
<td>Utilities &gt; Find Commands... [l]</td>
<td>F10</td>
<td>List, find and launch commands</td>
</tr>
<tr>
<td><strong>Window</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show All [J]</td>
<td>F12</td>
<td>Make all windows visible</td>
</tr>
<tr>
<td>Put Behind [tab]</td>
<td>F12</td>
<td>Switch to next image window</td>
</tr>
<tr>
<td>ImageJ window</td>
<td>F12</td>
<td>Bring ImageJ window to front</td>
</tr>
</tbody>
</table>
31 Key Modifiers

31.1 Alt Key Modifications
- File ⊿ Open Next: Open previous
- File ⊿ Revert: Don’t show dialog
- Edit ⊿ Copy: Copy to system clipboard
- Image ⊿ Color ⊿ Split Channels: Keep original image
- Image ⊿ Stacks ⊿ Add Slice: Insert before current slice
- Image ⊿ Stacks ⊿ Next Slice: Skip nine slices
- Image ⊿ Stacks ⊿ Previous Slice: Skip nine slices
- Image ⊿ Stacks: Start Animation: Show options dialog
- Image ⊿ Duplicate: Don’t show dialog
- Image ⊿ Overlay ⊿ Add Selection: Don’t show dialog
- Process ⊿ Equalize: Do classic histogram equalization
- Analyze ⊿ Histogram: Show dialog
- Analyze ⊿ Plot Profile: For rectangular selections, generate row average plot
- Analyze ⊿ Plot Profile: For wide straight lines, display rotated contents
- Analyze ⊿ Gels: Select First Lane: Assume lanes are horizontal
- Analyze ⊿ Tools: Analyze Line Graph: Show intermediate image
- Analyze ⊿ Tools: Roi Manager(Add): Name and add selection
- Plugins ⊿ Utilities ⊿ ImageJ Properties: List all Java properties
- Any user plugin: Load using new class loader
- Area selection tools: Subtract current selection from the previous one
- Rectangle and Oval selection tools: Current aspect ratio is maintained while resizing
- Polygon selection tool: Alt-click on a node to delete it
- Straight line tool: Keeps the line length fixed while moving either end of the line. Forces the two points that define the line to have integer coordinate values when creating a line on a zoomed image
- Segmented line tool: Alt-click on a node to delete it
- Point tool: Alt-click on a point to delete it
- Color picker tool: Alt-click to ‘pick-up’ background color
- All tools: Show location and size in pixels

31.2 Shift Key Modifications
- Image: Adjust: Threshold: Adjusting Min also adjusts Max
- Image: Adjust: Brightness/Contrast: Apply adjustments to all channels of a composite image
- Installed Macros and Scripts: Open instead of run
- Rectangle and Oval selection tools: Forces 1:1 aspect ratio
- Area selection tool: Add this selection to previous one
- Polygon selection tool: Shift-click on a node to duplicate it
- Straight line tool: Forces line to be horizontal or vertical
- Segmented line selection tool: Shift-click on a node to duplicate it
- Point selection tool: Shift-click to add a point

31.3 Ctrl Key (or Cmd) Modifications
- Rectangle and Oval selection tools: (With Alt) Current aspect ratio is maintained while resizing
- Rectangle and Oval selection tools: Selection is resized around the center
- Straight line tool: Rotate/resize the line about its center

31.4 Space Bar
- Any Tool: Switch to the hand tool

31.5 Arrow Keys
- Moving Selections: The four arrow keys move selection outlines one pixel at a time
- Resizing Selections: Rectangular and oval selections are resized by holding while using the arrow keys
- Stacks Navigation: The and keys substitute for and for moving through a stack. If there is a selection, you must also hold while moving through a stack
- Hyperstacks Navigation: The and keys change the channel. Hold to move through the slices and to move through the frames
- Zooming: The and keys zoom the image in and out. If there is a selection, you must also hold either or

32 Tools Shortcuts

Keyboard shortcuts cannot be used directly to activate tools in the ImageJ toolbar (with the exception of the Magnifying Glass and the Scrolling Tool). However, shortcuts can be assigned to macros that use the setTool() function. Once copied to the to the ImageJ/macros/Startup-Macros.txt file ImageJ will automatically install them at start-up.

The set of macros listed below (taken from the Rename and Save ROI Sets toolset) exemplify the use of the setTool() function by assigning the numeric keys 1–4 to the first four area selection Area Selection Tools. The macro ‘Refine selection’ activates temporarily the brush tool when is pressed. Once the mouse is released the previously selected tool is restored.

```java
/* This set of macros exemplifies how to use the setTool() function to assign hotkeys to ImageJ tools. */
macro "Rectangle [1]" (setTool("rectangle");)
macro "Ellipse [2]" (setTool("elliptical");)
macro "Polygon [3]" (setTool("polygon");)
macro "Freehand [4]" (setTool("freehand");)
macro "Refine Area Selection [5]" {
    tool = IJ.getToolName();
    setTool("brush");
    while (true) {
        if((flags & 16) != 0) {
            setTool(tool); exit();
        }
    }
}
```
This approach, however, requires the user to memorize as many shortcuts as the number of tools in the toolbar. In addition, it may be difficult to assign so many hot-keys without conflicting with previously defined ones (see List Shortcuts...). Probably a more efficient way to control the toolbar using the keyboard is to create macros that can cycle through all the tools in the ImageJ toolbar. The next example demonstrates such an approach. It is composed of two macros activated by F1 and F2 that iterate through the toolbar items from left to right (forward cycle) and right to left (reverse cycle).

```java
/* These two macros loop through the tools listed in an array using "F1" and "F2" as keyboard shortcuts (forward and reverse cycling). */


macro "Cycle Tools Fwd [F1]" {
    var tIndx = 0;
    setTool(tools[tIndx]);
    if (tIndx == tools.length) {
        tIndx = 0;
    }
}

macro "Cycle Tools Rwd [F2]" {
    var tIndx = tools.length - 1;
    setTool(tools[tIndx]);
    if (tIndx == 0) {
        tIndx = tools.length - 1;
    }
}
```

Credits

[C1] The ImageJ installer for Windows is created using the Inno Setup installer generator. ImageJ.exe was contributed by George Silva.
[C2] Support for ZIP-compressed TIFFs was contributed by Jason Newton in IJ 1.45g.
[C3] The macro editor’s Function Finder (Macros→Find Functions...) was written by Jérôme Mutterer.
[C4] The Elliptical Selection Tool was contributed by Norbert Vischer.
[C5] The Brush Selection Tool is based on the ROI Brush Tool plugin from Tom Larkworthy and Johannes Schindelin.
[C6] Jean-Yves Tinevez and Johannes Schindelin (authors of the Fiji Arrow Tool) contributed code to the Arrow Tool.
[C7] Michael Schmid, added 4-connected and 8-connected tracing with tolerance to the Wand Tool.
[C8] In IJ 1.43l and earlier, the File→Import→Results... command was based on Jérôme Mutterer’s Import_Results_Table macro.
[C9] Marcel van Herk added URLs support to the File→Import→Stack From List... command in IJ 1.45f.
[C11] Karen Collins contributed improvements to the FITS_Reader (File→Save As→FITS... command).
[C12] The Edit→Selection→Fit Circle command, based on a MATLAB script by Nikolai Chernov, was contributed by Michael Doube and Ved Sharma.
[C13] The Edit→Selection→Create Selection command is based on the Threshold_To_Selection plugin written by Johannes Schindelin.
[C14] The Color Picker (Image→Color Picker... [K]) was written by Gali Baler, a 2003–2004 intern from Bethesda-Chevy Chase High School.
[C15] The 16 different thresholding methods available in the Image→Adjust→Threshold... [T] tool were implemented by Gabriel Landini.
[C16] Michael Schmid contributed improvements to the downsizing kernel used by Image→Adjust→Size... and Image→Enhance Contrast... as well as undo support for Image→Scale... [E].
[C17] The Image→Adjust→Color Threshold... command implements Gabriel Landini’s Threshold Colour plugin.
[C18] The Reslice and the ZIProject plugin (Image→Stacks→Reslice... [J]) and Z Project... commands) were contributed by Patrick Kelly and Harvey Karten of the University of California, San Diego.
[C19] The Image→Stacks→Orthogonal Views [H] command is based on Dimitr Prodanov’s StackSlicer plugin and Albert Cardona’s Updater class. Michael Doube added support for XZ and YZ view control as well as mouse wheel control.
[C20] The Image→Stacks→3D Project... tool was written by Michael Castell and Janice Keller of the University of Michigan Mental Health Research Institute (MHRI). Bill Mohler added support for hyperstacks and 16-32-bit images in IJ 1.44m.
[C21] The Image→Stacks→Tools→Make Substack... command is based on the Substack Maker plugin by Anthony Padua, Daniel Barboriak and Ved Sharma.
[C22] The Image→Hyperstacks→Reduce Dimensionality... command is based on Jérôme Mutterer’s Reduce HyperStack macro.
[C23] The Image→Zoom→Set... command is based on Albert Cardona’s Zoom Exact plugin.
[C24] The Process→Find Maxima... command is based on a plugin contributed by Michael Schmid.
[C25] The equalization code implemented in Process→Enhance Contrast was contributed by Richard Kirk.
To reference ImageJ one of the following citations is possible:


The following references are a small sample of the bibliography directly related to ImageJ, the standard in scientific image analysis. These publications include: 1) technical articles and books describing routines implemented in ImageJ. 2) research articles that have made extensive use of ImageJ as a scientific tool or 3) reviews that discuss ImageJ pertinently. This list appears in chronological order rather than alphabetical and is particularly biased towards the life sciences:


## List of Abbreviations and Acronyms

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt</td>
<td>Alt, Option or Meta key;</td>
</tr>
<tr>
<td>API</td>
<td>Application Programming Interface;</td>
</tr>
<tr>
<td>ASCII</td>
<td>American Standard Code for Information Interchange;</td>
</tr>
<tr>
<td>bit</td>
<td>Binary digit;</td>
</tr>
<tr>
<td>BMP</td>
<td>Bitmap Image File (Device Independent Bitmap, DIB);</td>
</tr>
<tr>
<td>bpp</td>
<td>Bits per pixel;</td>
</tr>
<tr>
<td>CCD</td>
<td>Charge-Coupled Device;</td>
</tr>
<tr>
<td>CP</td>
<td>Color Picker;</td>
</tr>
<tr>
<td>CSV</td>
<td>Comma-Separated Values;</td>
</tr>
<tr>
<td>CT</td>
<td>Computed Tomography;</td>
</tr>
<tr>
<td>Ctrl</td>
<td>Control key. In this guide also the Command key in Apple keyboards;</td>
</tr>
<tr>
<td>DICOM</td>
<td>Digital Imaging and Communications in Medicine;</td>
</tr>
<tr>
<td>DPI</td>
<td>Dots Per Inch;</td>
</tr>
<tr>
<td>FAQ</td>
<td>Frequently Asked Questions;</td>
</tr>
<tr>
<td>FFT</td>
<td>Fast Fourier Transform;</td>
</tr>
<tr>
<td>FHT</td>
<td>Fast Hartley Transform;</td>
</tr>
<tr>
<td>FIJI</td>
<td>Fiji Is Just ImageJ;</td>
</tr>
<tr>
<td>FTTS</td>
<td>Flexible Image Transport System;</td>
</tr>
<tr>
<td>gif</td>
<td>Frames Per Second;</td>
</tr>
<tr>
<td>GIF</td>
<td>Graphics Interchange Format;</td>
</tr>
<tr>
<td>GUI</td>
<td>Graphical User Interface;</td>
</tr>
<tr>
<td>HDR</td>
<td>High Dynamic Range;</td>
</tr>
<tr>
<td>HEX</td>
<td>Hexadecimal;</td>
</tr>
<tr>
<td>HIPR</td>
<td>Hypermedia Image Processing Reference;</td>
</tr>
<tr>
<td>HSB</td>
<td>Hue Saturation Brightness;</td>
</tr>
<tr>
<td>HTML</td>
<td>HyperText Markup Language;</td>
</tr>
<tr>
<td>IJ</td>
<td>ImageJ;</td>
</tr>
<tr>
<td>JAR</td>
<td>Java ARChive;</td>
</tr>
<tr>
<td>JPEG</td>
<td>Joint Photographic Experts Group;</td>
</tr>
<tr>
<td>LUT</td>
<td>Lookup table;</td>
</tr>
<tr>
<td>LZW</td>
<td>Lempel-Ziv-Welch;</td>
</tr>
<tr>
<td>MIP</td>
<td>Maximum Intensity Projection;</td>
</tr>
<tr>
<td>MP</td>
<td>Motion-JPEG;</td>
</tr>
<tr>
<td>NaN</td>
<td>Not a Number;</td>
</tr>
<tr>
<td>OS</td>
<td>Operating System;</td>
</tr>
<tr>
<td>p/c</td>
<td>Pixels per cycle;</td>
</tr>
<tr>
<td>PBM</td>
<td>Portable BitMap;</td>
</tr>
<tr>
<td>PGM</td>
<td>Portable GrayMap;</td>
</tr>
<tr>
<td>pixel</td>
<td>Picture element;</td>
</tr>
<tr>
<td>PNG</td>
<td>Portable Network Graphics;</td>
</tr>
<tr>
<td>ppm</td>
<td>Pixels per inch;</td>
</tr>
<tr>
<td>PPM</td>
<td>Portable PixMap;</td>
</tr>
<tr>
<td>RAM</td>
<td>Random-Access Memory;</td>
</tr>
<tr>
<td>rgb</td>
<td>RGB Color Space;</td>
</tr>
<tr>
<td>ROI</td>
<td>Region Of Interest;</td>
</tr>
<tr>
<td>Shift</td>
<td>Shift key;</td>
</tr>
<tr>
<td>TIFF</td>
<td>Tagged Image File Format;</td>
</tr>
<tr>
<td>UEPs</td>
<td>Ultimate Eroded Points;</td>
</tr>
<tr>
<td>URL</td>
<td>Uniform Resource Locator;</td>
</tr>
<tr>
<td>voxel</td>
<td>Volumetric pixel;</td>
</tr>
<tr>
<td>WYSIWYG</td>
<td>What You See Is What You Get;</td>
</tr>
<tr>
<td>NaN</td>
<td>Not a Number;</td>
</tr>
<tr>
<td>RAM</td>
<td>Random-Access Memory;</td>
</tr>
<tr>
<td>RGB</td>
<td>Red-Green-Blue Color Space;</td>
</tr>
<tr>
<td>ROI</td>
<td>Region Of Interest;</td>
</tr>
<tr>
<td>Shift</td>
<td>Shift key;</td>
</tr>
<tr>
<td>TIFF</td>
<td>Tagged Image File Format;</td>
</tr>
<tr>
<td>UEPs</td>
<td>Ultimate Eroded Points;</td>
</tr>
<tr>
<td>URL</td>
<td>Uniform Resource Locator;</td>
</tr>
<tr>
<td>voxel</td>
<td>Volumetric pixel;</td>
</tr>
<tr>
<td>WYSIWYG</td>
<td>What You See Is What You Get;</td>
</tr>
</tbody>
</table>

## Index

### A
- **Acceptable manipulation**, 5
- **ActionBar**, 22
- **Add see Math**, 102
- **Add images see Image calculator**, 113
- **Alpha blending value see Blend**, 92
- **Analyzer**, 117
- **AND see Logical operations**, 114, 135
- **Angle tool**, 30
- **Area under the curve** see **Integral integral**, 129
- **Arrows**, 29
- **AspectRatio**, 26, 27, 70, 123
- **AutoRun**, 19, 41
- **AVI**, 11, 46, 49
- **Background** see **Subtract**, 114
- **Background pixels**, 131
- **Batch processing**, 111, 138
- **BeanShell**, 22
- **Benchmark**, 142
- **Bicubic interpolation see Interpolation**, 70
- **Binarization see Interpolation**, 70
- **Binary**, 58, 59
- **Bin67**, 4
- **Bioformats see LOCI**, 11
- **Bitwise operations**, 103, 104
- **Black background**, 68, 59, 102
- **Blend**, 89, 92
- **Bounding box**, 33, 56
- **Brightness/Contrast**, 65–67, 114
- **Brush selection tool**, 27
- **Bug (reporting)** see **Debug**, 7

### B
- **Background** see **Subtract**, 114
- **Background pixels**, 131
- **Batch processing**, 111, 138
- **BeanShell**, 22
- **Benchmark**, 142
- **Bicubic interpolation see Interpolation**, 70
- **Binarization see Interpolation**, 70
- **Binary**, 58, 59
- **Bin67**, 4
- **Bioformats see LOCI**, 11
- **Bitwise operations**, 103, 104
- **Black background**, 68, 59, 102
- **Blend**, 89, 92
- **Bounding box**, 33, 56
- **Brightness/Contrast**, 65–67, 95
- **Brush selection tool**, 27
- **Bug (reporting)** see **Debug**, 7

### C
- **Calibration**, 126
- **Optical density**, 125, 137
- **Spatial**, 72, 124, 136
- **Calibration bar**, 137
- **Caliper length see Feret**, 123
- **Canvas**, 71
- **Capture image**, 142
- **Cartoon-Roma see Interpolation**, 70
- **CCD**, 14, 97
- **Cell Counter plugin**, 30, 31
- **CellProfiler Interoperability**, 24
- **Center of mass**, 122
- **Centroid**, 122
- **Channels**, 72, 85
- **CIE**, 70
- **CIE Lab**, 69
- **Color**
  - **Background**, 32, 74
  - **Balance**, 67
  - **Blindness**, 15
  - **Color components**, 17
  - **Deconvolution**, 15
  - **Foreground**, 32, 74
  - **Models**, 14
  - **Quantization**, 64
  - **Separation see Color Deconvolution**, 15
  - **Settings**, 17, 19, 52, 59, 124
  - **Threshold**, 69
  - **Color palette see LUT**, 14
  - **Color Picker**, 32
  - **Combine**, 82
  - **Command key**, 8
  - **Command launcher**, 9, 37, 39, 140, 141, 149, 154
  - **Compile**, 61, 144
  - **Concatenate**, 82
  - **Contextual Menu**, 34
  - **Control Panel**, 140
  - **Conversions**, 45, 47, 60, 64, 93, 112, 117, 122, 127
  - **Convex hull**, 54
  - **Convolution**, 93, 97, 108, 109
  - **Coordinates**, 25, 30, 49, 94, 124, 131
  - **Coronal see Orthogonal views**, 78
  - **Counting objects**, 30, 93
  - **Crop**, 85, 113
  - **CSV**, 35, 45, 49
  - **CT**, 67, 79
  - **Curve fitting**, 132

### D
- **Data mining see TrakEM2**, 3
- **Dead pixels**, 97
- **Debug**, 37, 62, 63, 100, 101, 141
- **Deconvolution see Convolution**, 93
- **Deflate see Zip compression**, 10
- **Delays** see **Drosophilaetrofit**, 96
- **Developer resources**, 146
- **DICOM**, 11, 62, 67
- **Dilation**, 99
- **Dirichlet see Voronoi**, 101
- **Display range**, 64
- **Distribution**, 121
- **Divide see Math**, 103
- **Divide images see Image calculator**, 113
- **Dot blot analysis**, 123
- **Downsampling**, 70, 86
- **DPI**, 47, 50
- **Drag & Drop**, 41
- **Duplicate**, 83, 86

### E
- **Editor**, 36
- **EDM see Euclidian distance map**, 100
- **Elliptical selection**, 27
- **Eroded points**, 100
- **Erosion**, 99
- **Ethics see Acceptable manipulation, hyperpage**, 5
- **Euclidian distance map**, 94, 100, 101
- **Exponential transformation**, 104
- **Eye dropper**, 32

### F
- **Fast Fourier transform**, 105
- **Fast Hartley Transform**, 105
- **Feret**, 123
- **Fiji**, 2, 3, 3, 5, 15, 21, 22, 42
- **Filters**, 107, 109–111
- **Find see Search**, 140
- **Fit**
  - **Circle**, 54
  - **Cubic spline**, 54, 56
  - **Curve see Curve fitting**, 132
Colophon

The initial contents of this guide have been retrieved in 2009 from the ImageJ website using html2text. Since then, it has been complemented and updated using information posted on the ImageJ mailing list, ImageJ website, ImageJ Documentation Portal, Fiji webpage or Tony Collins ImageJ for Microscopy manual. Nevertheless, because there has never been accompanying documentation for some of the 300+ described commands, several sections have been written from scratch based on the relevant ImageJ source code and authors own experience. Legacy nomenclature that became obsolete with version 1.45m has been intentionally omitted.

The guide was typeset with TEXLive2011 on Mac OS 10.6.8. All illustrations were created with Grab1.5 and Fiji/ImageJ1.43–1.45m, loaded with G. Landini’s IJ Robot and J. Schindelin’s Tutorial Maker plugins.

The HTML version was produced with eLyXer 1.2 and formatted using CSS code from Alex Fernández and Michael Hüneburg, JavaScript code from Stuart Langridge and Ciarán O’Kelly and icons from the Tango Desktop Project.

Getting Involved

Your help is needed to improve ImageJ. Even if you are not a programmer, your participation is important:

– Are you a skilled ImageJ user?

You might want to help out with the documentation effort: Write a FAQ, How-To, Tutorial or Video Tutorial on the ImageJ Documentation Portal; Help us updating the ImageJ User Guide; Share the add-ons you may have created with the community; Subscribe the mailing list and help answering the questions raised by other users.

– Are you knowledgeable in image processing?

Please join the mailing list and participate in the discussions. You could also write a Tutorial on the ImageJ Documentation Portal.

– Do you have a strong scientific background?

Frequently, the most demanding tasks in scientific image processing relate to experimental design. Even if you do not have special expertise in image processing your experience may be valuable to others.

– Do you want ImageJ to improve?

You can report bugs or request new features using the mailing list.

– Do you have experience in graphic/web design?

If you are able to improve the look and feel of the guide we welcome your skills.

The ImageJ Icon

The Hartnack microscope (ca. 1870’s) depicted on the front page inspired the ImageJ icon for Mac OS X. It is based on a photograph by Tom Grill at arsmachina.com.

Edmund Hartnack (1826–1891) was a renowned microscope manufacturer that pioneered the use of correction collars in water-immersion lenses and the adoption of the substage condenser\(^1\). The precision and robustness of Hartnack optics played a pivotal role in the groundbreaking research by the Nobel laureates Robert Koch\(^2\), Camillo Golgi\(^3\) and Santiago Ramón y Cajal\(^4\).

\(^2\)Brock, TD. Robert Koch, A life in medicine and bacteriology. ASM, 1999
\(^3\)Brenni P. Gli strumenti di fisica dell’Istituto Tecnico Toscano – Ottica. IMSS, 1995
Document Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>01 September 2011</td>
<td>Updated for v1.45 &lt;br&gt;Deeply revised edition with several new sections in Parts I-IV &lt;br&gt;Available as printable booklets &lt;br&gt;HTML version completely redesigned</td>
</tr>
<tr>
<td>31 January 2011</td>
<td>Updated for v1.44 &lt;br&gt;New sections on advanced ImageJ usage, Fiji Scripting, command line usage and interoperability with other software packages</td>
</tr>
<tr>
<td>13 May 2010</td>
<td>First HTML version</td>
</tr>
<tr>
<td>17 April 2010</td>
<td>First edition covering v1.43</td>
</tr>
</tbody>
</table>

Acknowledgments

We are extremely grateful to Alex Fernández for his wonderful eLyXer and Johannes Schindelin for fruitful discussions and assistance with the Git repository. We are also thankful to all of those who submitted material, criticisms, suggestions and encouragement to update this edition. But above all, our thanks go to the extraordinary ImageJ community for its dedication to the project.