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This is the users manual for the MRIAnalysisPak plugin collection 
for ImageJ for the analysis of MRI and fMRI data. Please contact 
the author with any questions regarding this software. This 
package is maintained by members of the Center for Comparative 
Neuroimaging (CCNI) at the University of Massachusetts Medical 
School and The Small Animal MRI Laboratory at Harvard Medical 
School/Brigham & Women’s Hospital.
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1.0 About the plugins, getting the source, and getting 
involved in development

The MRIAnalysisPak is a collection of utilities designed to facilitate analysis of MRI 
and fMRI data using the open source image analysis platform ImageJ (Rasband W, 
http://rsb.info.nih.gov/ij/) . The package has evolved from needs based development of 
custom analysis tools across two laboratories, the Small Animal MRI Laboratory at 
Harvard Medical School / Brigham & Women’s Hospital (http://splweb.bwh.har-
vard.edu:8000/pages/projects/animal_mri/) and the Center for Comparative Neuroimag-
ing (CCNI) at the University of Massachusetts Medical School (http://
www.umassmed.edu/ccni/). 

The MRIAnalysisPak source code is open source, maintained under the IJ-Plugins 
project (hosted by Jarek Sacha) at SourceForge. Developers who have contributed to 
this work include:

• Karl Schmidt (CCNI)
• Sameer Doshi (Small Animal MRI Laboratory)
• David Hotchkiss (Small Animal MRI Laboratory)
• Herve Barjat (GlaxoSmithKline)

Interested developers should contact Jarek Sacha to be included in this project, all help 
is welcome and valued. Some relevant links include:

• The IJ Plugins project at SourceForge: http://sourceforge.net/projects/ij-plugins
• Launch the MRIAnalysisPak from the web:                                                                

http://www.quickvol.com
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2.0 Installing the MRIAnalysisPak

The MRIAnalysisPak plugin can be used in one of two ways. It may be downloaded and 
installed locally, or it may be launched via JavaWebStart from the Quickvol.com web-
site.

2.1 LAUNCHING FROM 
WWW.QUICKVOL.COM

The launch page from www.quickvol.com contains buttons to deploy ImageJ with the 
installed plugins via JavaWebStart. This system has been verified on Windows 2000 and 
Windows XP with java version 1.4.1 installed. Simply navigate to this site and follow 
the instructions:

http://www.quickvol.com

NOTE: Pop-up windows must be enabled in order for the program to launch properly.

2.2 INSTALLING 
MRIANALYSISPAK 
LOCALLY

The MRIAnalysisPak.zip file contains the files for local installation of the plugin and 
can be downloaded from the SourceForge project page or the Quickvol website:

• http://sourceforge.net/projects/ij-plugins or,
• http://www.quickvol.com

Once downloaded, the zip archive should be opened, and expanded into the “plugins” 
directory of the local ImageJ installation. NOTE: if expanding these files manually, 
copy the entire MRIAnalysisPak folder into the plugins folder. The final directory struc-
ture should resemble:

• [local imagej folder]/plugins/MRIAnalysisPak/(plugin class files and directories)

When ImageJ is launched, a submenu appears under the Plugins menu called MRIAnal-
ysisPak, and contained within are the individual utilities described in the next section. 
The Correctly configured menu will resemble Figure 1. 

FIGURE 1. The MRIAnalysisPak plugin menu
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3.0 Overview of plugins

Several utilities are included in the MRIAnalysisPak, a more detailed description of 
each follows. 

Unless otherwise noted, these plugins are designed to work with multi-slice time series 
data. Users are prompted for anatomical dimensionality when needed.

• CCNI Open SDT & CCNI Save As SDT (p. 6): Open and save data to the STIMU-
LATE file format, supporting 4D dimensions, used primarily by the CCNI

• CCNI Split Into BOLD CBF (p. 7): Split repetitive CASL acquisitions into alter-
nate BOLD and CBF series, again, primarily relevant for analysis at the CCNI

• Calc Davis CMRO2 (p. 8): Calculate CMRO2 maps from calibration and stimula-
tion scans

• Calc Davis CMRO2 Manually (p. 9): Davis CMRO2 map calculation using ratio 
images, rather than raw scan series data

• Calc_Pct_Change (p. 10): Calculate a % change map (M/Mo-1) 
• Calc_Ratio (p. 12): Calculate a ratio map (M/Mo)
• Calc_T1 (p. 12): Pixelwise, multislice calculation of T1 from multiple TR images
• Calc_T2 (p. 12): Pixelwise, multislice calculation of T2 from multiple TE images
• GLM Analyzer (p. 13): Plugin for Generalized Linear Model analysis of time series 

fMRI data
• Image Overlay (p. 16): A plugin for producing color visualization of map data 

overlaid on anatomical images 
• Manually Register Images (p. 17): A simple tool for aligning (co-registering) data 

sets
• Time Project ROI (p. 21): Used with multi-slice time series data, project a time 

course of average amplitude for the current ROI
• OLD MRI Analysis Calc (p. 22): This is the original MRI analysis calculator (June 

2002), provided for backward compatibility
• Truncate Time Series (p. 24): Remove repetitions from multi-slice time course data
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3.1 A NOTE ON 
DIMENSIONALITY

When needed, you will be prompted for the number of anatomical slices and the organi-
zation of the time series. In the example below, two stacks are shown with different time 
series organizations, each stack has 3 anatomical slices repeated at different time points 
with different TE’s for a T2 calculation. 

The first stack is grouped and ordered first by anatomical slice, then by time point, the 
second stack is grouped and ordered first by time points, then by anatomical slice. The 
appropriate selections are shown in the Time Series Organization dialog to the left.
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4.0 CCNI Open SDT & CCNI Save As SDT

Open SDT and Save As SDT are plugins used primarily by the group at the CCNI to 
read and save time series fMRI data from and to the STIMULATE (Strupp JP, http://
www.cmrr.umn.edu/stimulate/) data format. This data format consists of two files, a sin-
gle, raw data file with the extension (.sdt) and an accompanying dimensionality descrip-
tor located in a plaintext file of the same with the extension (.spr). Advantages to using 
this file format include cross compatibility between STIMULATE and the MRIAnaly-
sisPak, as well as the storage of 4D dimensionality information, eliminating the need to 
input this information during the input and analysis processes.



CCNI Split into BOLD CBF

MRIAnalysisPak Manual 7

5.0 CCNI Split into BOLD CBF

Continuous Arterial Spin Labeling (CASL) experiments performed in repetition with 
appropriate Blood Oxygenation Level Dependent (BOLD) weighting can be used to 
simultaneously measure BOLD and Cerebral Blood Flow (CBF). Data sets acquired 
with these experiments can be analyzed to produce two series of data, one representing 
the BOLD signal as a function of time, the other representing CBF for the same time 
points. This plugin produces these two series in the following manner.

The BOLD signal is measured from the control pulses, and CBF is measured by the 
comparison of the control and labeled pulses according to Equation 1, this is shown 
schematically in Figure 2. Where alpha is the labeling efficiency, lambda the blood 
brain partition coefficient, T1 is the tissue t1, and Sc and Sl are the signal amplitudes of 
the control and labeled slices respectively.

(EQ 1)

FIGURE 2. Measuring BOLD and CBF simultaneously 
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6.0 Calc Davis CMRO2

This plugin generates a relative change in Cerebral Metabolic Rate of Oxygen con-
sumption (CMRO2) map from two timecourse experiments, one a hypercapnic calibra-
tion scan and the other a stimulation scan. This is the Davis model for MRI based 
measurement of CMRO2 and is explained in greated detail in [Proc Natl Acad Sci U S 
A. 1998 Feb 17;95(4):1834-9]. The formula for this calculation is illustrated in equation 
2, and M is determined from the hypercapnic scan where CMRO2/CMRO2o is assumed 
to be 1:

(EQ 2)

Values are averaged over the Baseline, CO2 and Stimulation periods on a pixel by pixel 
basis. CBF values are calculated from the CBF series created in the same manner as is 
explained in section 5.0.

The figure below illustrates the screen for this utility.

FIGURE 3. Calc Davis CMRO2
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7.0 Calc Davis CMRO2 Manually

This plugin is similar to the one above, except that BOLD/BOLDo and CBF/CBFo and 
M maps are input directly, rather than calculated from raw scan data. 

FIGURE 4. Manual Davis CMRO2 Calc
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8.0 Calc Pct Change

This is a basic percent change calculation which averages values on a pixel by pixel 
basis for a baseline and stimulation period of a single timecourse data set, and returns a 
map of the percent change (X-Xo)/Xo.

FIGURE 5. Calc Pct Change interface
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9.0 Calc Ratio

Identical to Calc Pct Change, except that a map of the pure ratio is returned: (X/Xo) 
rather than (X/Xo)-1.
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10.0 Calc T1 & Calc T2

Multislice T1 and T2 calculations can be made from multislice image series containing 
images acquired at different TR and TE values. Values are input in millisecond units 
separated by commas or spaces (e.g. “35,55,75,100” do not include the quotes when you 
input the numbers).

The calculation is performed using a basic implementation of the Nelder Mead Down-
hill Simplex algorithm, and is somewhat inefficient as it is currently implemented, so be 
patient.

FIGURE 6. Calc T1 and Calc T2 interfaces
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11.0 GLM Analyzer

The GLM Analyzer is a generalized linear model analysis tool that allows the regression 
of time series data to an experimental model of the expected response (this is currently 
limited to finite slope boxcar models). 

11.1 SELECTING THE FMRI 
DATA SERIES

The data series that you wish to analyze must be open prior to running the plugin. Once 
the data series is selected, an algorithm is employed to downsample the data in the first 
quadrant of the image from the center slice, near the center of the field of view. The 
timecourse of this data is displayed on the GLM Analyzer window. This data should 
provide you with an idea of where the transitions in your time series are, and so help 
you to graphicaly fit an appropriate model.

11.2 SELECTING AND 
ADJUSTING THE 
BOXCAR MODEL

The BOXCAR model to be used for the fit can be selected from the drop down menu, 
and the red line illustrating the model transitions will be displayed in the window.

This model can be adjusted by clicking the transition points and dragging them to the 
locations deemed best given the displayed data. 

NOTE: the amplitude of the line is altered only in the visualization, and is not used in 
the calculation, which determines the optimal amplitude as well as phase shift within +/
- 10% of the overall timecourse.

11.3 PERFORMING THE FIT Once the fMRI sereies and model have been selected, perform the fit by clicking the FIT 
button; this is a slow process, but the percentage completed will be displayed. 

Once the fit is complete, you can analyze maps of (1) % Change (2) Correlation Coeffi-
cient (3) pValue of the null hypothesis (that the data does not fit the model) and (4) the 
phase shift identified in the algorithm for the best fit (+ or - 10% of overall timecourse)

11.4 ALGORITHMS USED IN 
THE FIT

Regression of the proposed model to the original source data is accomplished with the 
traditional analytical solution to the GLM model shown in equation 3 where Y is a col-
umn vector containing the original source data, M is a matrix containing two column 
vectors, the first column containing values between 0 and 1 representing the boxcar 
model, and the second column containing all 1’s to represent a DC offset in the original 
source data. The column vector b contains two row values, the first corresponding to the 
optimal contribution of the boxcar model column, the second corresponding to the value 
of the DC offset. The solution for b in equation 3 returns the b values which minimize 
the residue between the proposed model and the original data. This solution is evaluated 
for each pixel in the time course, and the resulting values are used to generate the 
returned maps.

(EQ 3)

ε+= bMY ( ) YMMMb TT 1−=
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Calculating the % change map

The percent change map is calculated by dividing the amplitude of the model contribu-
tion by the DC offset for each pixel. 

(EQ 4)

Calculating the Correlation Coefficient and pValue

The Correlation coefficient is calculated for each pixel by generating a test data series 
from the optimal model fit, and extracting the correlation coefficient using the tradi-
tional statistical techniques in equation 5. The pValue is calculated from the t-score by 
means of t distribution evaluation using an implementation from Numerical Recipes in 
C (see source code for complete reference). The pValue represents the probability of the 
null hypothesis, specifically the probability that the correlation observed between the 
regressed model data and the original experimental data occurred by chance. 

The pValue can be used as a threshold, where by pixels whose pValue is higher than the 
selected threshold are set to zero in the % change calculation.

(EQ 5)

The phase shift map

During the fit process, the model is evaluated at phase shifts up to +/- 10% of the total 
time series. The optimal phase is selected for the fit, and the phase map captures the 
integer offset of the model in unit time steps.
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FIGURE 7. GLMAnalyzer fitting an fMRI series to a BOXCAR model, and a % 
chg map result 
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12.0 Image Overlay 

The Image Overlay plugin is designed for analysis and visualization of multi-slice map 
and anatomical data, where regions can be outlined and displayed over a background 
image.

Contrast and LUT scales can be adjusted to optimize display characteristics, and the 
images can be exported back to ImageJ where they can be saved in standard image for-
mats.
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13.0 Manual Image Registration Plugin

This updated version of the Manual Image Registration has several new features which 
should make it a more productive tool to use. There is still much work to be done, so as 
you encounter problems, or opportunities for improvement, please send them to me in 
an email. Here is an abbreviated list of the new features implemented in this version:

• Re-open saved transforms to review image registration and make changes
• Add multiple slices in one operation
• Apply adjacent slice transforms
• Transform raw data directly from the Image Registration Plug-in 

13.1 KNOWN BUGS • When you apply the transform to raw data, you are prompted for the number of ana-
tomical slices in the raw data twice. Please supply the same number both times - I’ll 
fix this at the earliest convenience.

• Resolution must be consistent between all of the images used as Reference, Source 
and transformed data. Please see the “Image requirements and limitations” below for 
more information on this point.

13.2 IMAGE 
REQUIREMENTS AND 
LIMITATIONS

Currently, the Manual Image Registration plug-in is designed for use with images of the 
same resolution. The images used for the Reference, Source, and transformed images 
must all be the same resolution. In order to accommodate this limitation, select the low-
est resolution and convert any images you are using with the plug-in to this resolution. 
This limitation can be averted if correct image dimensionality (FOV, pixelsize, etc.) is 
supplied for each image used. If this functionality is important to you, please submit a 
request (karl.schmidt@umassmed.edu). 

Additionally, the transformation algorithm does not interpolate the destination image. 
Destination image pixels are re-sampled from the original image space with the inverse 
of the transformation matrix used to convert the Source image to Reference image 
space. Contact me if you have questions or concerns about how this may impact your 
analysis. 

13.3 CREATING AND 
SAVING A 
TRANSFORM

Before running the plug-in, you should open the images you will use as the reference 
and source. Once those have been opened, you can launch the Manual Registration 
Plug-in from the Plug-ins menu as shown in the figure.
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FIGURE 8. Launching the Manual Registration Plug-in

From the “Manually Register Images” File menu, select File => New and specify the 
number of slices that the transform will have when prompted to do so.

Selecting the Reference and Source images. 

Once the transform has been created, you must select the Reference and Source images 
from the Transform menu. When the image is selected, the Reference image will appear 
in Blue, and the Source Image will appear in Red. It is the Source image that you will 
translate, rotate and scale to line up with the Reference image.

The figure below shows the Reference image in Blue, and the Source image in Red.

FIGURE 9. Plug-in with Reference and Source Images Selected
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Aligning the Source to the Reference Image. 

Once the Reference and Source images have been selected, you must align the Source 
image to the reference for each slice in your transform by using the Register Opera-
tions menu options. 

Once you select an operation, your mouse will control the operations on the Source 
image, and the display will be updated as you work. Operations available include: trans-
lation, rotation, scale x, scale y, scale both.

FIGURE 10. Nearly aligned Source and Reference Images

Switching Slices. 

Each slice in your transform must be registered independently.

FIGURE 11. Copying the previous slice’s transform
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Switch between slices using the slider at the bottom of the window. You can apply the 
preceding or following transform from adjacent slices to make your job a bit easier as is 
shown in Figure 11.

Saving the Transform

Once you have completed a transform, always save it so that you can come back to it 
later to review the registration and use it to transform raw data. From the File menu 
select File => Save to preserve the transform in xml file format; you should rename it to 
something that will help you reference it in the future. 

13.4 APPLYING A 
TRANSFORM TO AN 
IMAGE OR IMAGE 
SERIES

Once your transform is complete you will use it to transform raw data sets. Open a 
transform and select File=>Apply Transform to transform raw data using this transfor-
mation.

13.5 TRANSFORM XML FILE 
FORMAT

This section is under construction. Contact the author with any questions.
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14.0 Time Project ROI

The Time Project ROI plugin calculates the time series profile for an ROI selected on a 
particular slice. This functionality differs from the native ImageJ Z Project stack pro-
cessing function by taking into account multiple anatomical slices which are repeated in 
the time series.

The example shown here illustrates a bold response beginning about 30% of the time-
course.

FIGURE 12. Time Project ROI 
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15.0 OLD MRI Analysis Calculator 

(COPIED FROM ORIG DOCUMENTATION MANUAL) 

The MRI Analysis Calculator is designed to perform T1, T2 Perfusion and Diffusion 
measurements on raw MR scan data. The measurements are performed on a pixelwise 
basis, on stacks of two or more slices. In most cases the associated R2 image, reflecting 
the residual at each pixel can also be produced during a calculation.

Generating T1, T2, Perfusion & Diffusion Images

The perfusion image calculation requires a T1 stack as well as an ASL (Arterial Spin 
Labeled) stack of two images for calculation. T1, T2 & Diffusion curve fitting is imple-
mented using a modified Simplex algorithm based on the class ij.measure.CurveFitter, 
and can complete the T1 calculation shown above (128x128x6 slices) in about 15 secs 
on modest hardware.

NOTE The diffusion calculation is not fully implemented - use at your own risk!

Notes on parameters:

• TR values for the T1 stack are in seconds, and separated by spaces
• T1 Clip and Perfusion threshold values are supplied to retain contrast through the 

range of interest, change them as you see fit
• The “Also generate R^2 map” option will open a second window illustrating the fit 

quality of each pixel as the R^2 value
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FIGURE 13. Sample Perfusion/Diffusion/T1/T2 map calculations
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16.0  Truncate Time Series

This plugin simply removes the repetitions specified from the selected time series. It is 
pretty tolerant of syntax (e.g. “3-5”, “4,6,23” etc).


